aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--math/oleo/Makefile15
1 files changed, 5 insertions, 10 deletions
diff --git a/math/oleo/Makefile b/math/oleo/Makefile
index 114cb90ec47f..38a56dbb4f20 100644
--- a/math/oleo/Makefile
+++ b/math/oleo/Makefile
@@ -26,6 +26,11 @@ CONFIGURE_ARGS= --with-x --without-xlt --without-SciPlot
INFO= oleo
PORTDOCS= AUTHORS FAQ
+OPTIONS= MOTIF "Motif support" off \
+ NLS "NLS support" on
+
+.include <bsd.port.pre.mk>
+
.if defined(WITH_MOTIF)
LIB_DEPENDS+= plot:${PORTSDIR}/graphics/plotutils \
Xbae:${PORTSDIR}/x11-toolkits/xbae \
@@ -45,16 +50,6 @@ USE_GETTEXT= yes
PLIST_SUB= NLS=""
.endif
-.include <bsd.port.pre.mk>
-
-pre-everything::
-.if !defined(WITH_MOTIF)
- @${ECHO_MSG}
- @${ECHO_MSG} "If you want to compile with Motif support,"
- @${ECHO_MSG} "hit Ctrl-C right now and use \"make WITH_MOTIF=yes\""
- @${ECHO_MSG}
-.endif
-
post-patch:
@${GREP} -lR "malloc\.h" ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e \
's|malloc\.h|stdlib.h|g'