aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--security/Makefile1
-rw-r--r--security/stoken/Makefile36
-rw-r--r--security/stoken/distinfo2
-rw-r--r--security/stoken/pkg-descr5
-rw-r--r--security/stoken/pkg-plist18
5 files changed, 62 insertions, 0 deletions
diff --git a/security/Makefile b/security/Makefile
index 3c76325bc6ce..5b4aec8d39b2 100644
--- a/security/Makefile
+++ b/security/Makefile
@@ -964,6 +964,7 @@
SUBDIR += starttls
SUBDIR += stegdetect
SUBDIR += steghide
+ SUBDIR += stoken
SUBDIR += strobe
SUBDIR += strongswan
SUBDIR += stunnel
diff --git a/security/stoken/Makefile b/security/stoken/Makefile
new file mode 100644
index 000000000000..7b70a3cb0e14
--- /dev/null
+++ b/security/stoken/Makefile
@@ -0,0 +1,36 @@
+# Created by: Alex Samorukov <samm@os2.kiev.ua>
+# $FreeBSD$
+
+PORTNAME= stoken
+PORTVERSION= 0.6
+CATEGORIES= security
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR=stoken
+
+MAINTAINER= samm@os2.kiev.ua
+COMMENT= Software Token for UNIX compatible with RSA SecurID
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= libtomcrypt.so:${PORTSDIR}/security/libtomcrypt
+
+OPTIONS_DEFINE= X11
+OPTIONS_SUB= yes
+
+X11_CONFIGURE_WITH= gtk
+X11_DESC= Build GUI token interface
+X11_USE= GNOME=gtk20
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+= --with-pkgconfigdir="${PREFIX}/libdata/pkgconfig"
+
+USE_LDCONFIG= yes
+USE_GNOME= libxml2
+USES= pkgconfig libtool
+
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+INSTALL_TARGET= install-strip
+
+.include <bsd.port.mk>
diff --git a/security/stoken/distinfo b/security/stoken/distinfo
new file mode 100644
index 000000000000..cfc43cd21d81
--- /dev/null
+++ b/security/stoken/distinfo
@@ -0,0 +1,2 @@
+SHA256 (stoken-0.6.tar.gz) = b29ee3715db7e55fafe93cbed4c0f7a91396a391a9416e8ea7c06d8e7e8bad37
+SIZE (stoken-0.6.tar.gz) = 367315
diff --git a/security/stoken/pkg-descr b/security/stoken/pkg-descr
new file mode 100644
index 000000000000..c03edd03b381
--- /dev/null
+++ b/security/stoken/pkg-descr
@@ -0,0 +1,5 @@
+Stoken is an open source tokencode generator compatible with RSA SecurID 128-bit
+(AES) tokens. It is a hobbyist project, not affiliated with or endorsed by RSA
+Security.
+
+WWW: http://stoken.sourceforge.net
diff --git a/security/stoken/pkg-plist b/security/stoken/pkg-plist
new file mode 100644
index 000000000000..b326c414cb2c
--- /dev/null
+++ b/security/stoken/pkg-plist
@@ -0,0 +1,18 @@
+@comment $FreeBSD$
+bin/stoken
+%%X11%%bin/stoken-gui
+include/stoken.h
+lib/libstoken.a
+lib/libstoken.so
+lib/libstoken.so.1
+lib/libstoken.so.1.2.0
+%%X11%%man/man1/stoken-gui.1.gz
+man/man1/stoken.1.gz
+%%X11%%share/applications/stoken-gui-small.desktop
+%%X11%%share/applications/stoken-gui.desktop
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/libstoken-test.c
+%%PORTDOCS%%%%DOCSDIR%%/sdtid-test.pl
+%%X11%%share/pixmaps/stoken-gui.png
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+libdata/pkgconfig/stoken.pc