aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/searchandrescue/Makefile10
1 files changed, 7 insertions, 3 deletions
diff --git a/games/searchandrescue/Makefile b/games/searchandrescue/Makefile
index c2f4859749a5..bbafde09d9b7 100644
--- a/games/searchandrescue/Makefile
+++ b/games/searchandrescue/Makefile
@@ -3,18 +3,21 @@
PORTNAME= SearchAndRescue
PORTVERSION= 1.4.0
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME:tl}/Program/
MAINTAINER= jessefrgsmith@yahoo.ca
COMMENT= Flight simulator in which the player rescues people
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
RUN_DEPENDS= ${LOCALBASE}/share/searchandrescue/human.ini:games/searchandrescue-data
USE_SDL= mixer
-USE_XORG= x11 xau xdmcp xext xmu xpm xxf86vm
-USE_GL= glu
+USE_XORG= ice sm x11 xau xdmcp xext xmu xpm xxf86vm
+USE_GL= gl glu
WRKSRC= ${WRKDIR}/${PORTNAME:tl}_${PORTVERSION}
PLIST_FILES= bin/${PORTNAME} \
@@ -30,6 +33,7 @@ post-patch:
-e 's,/usr/local,${LOCALBASE},g' \
-e 's,/usr/X11R6,${LOCALBASE},g' \
-e '/^CFLAGS = /s,=,= ${CFLAGS},g' \
+ -e '/^CPPFLAGS = /s, = .*, = ${CPPFLAGS},g' \
-e '/^CC = /s, = .*, = ${CC},' \
-e '/^CPP = /s, = .*, = ${CXX},' \
-e 's,-O6,,' \