aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/findmtu/Makefile31
-rw-r--r--net/findmtu/distinfo2
-rw-r--r--net/findmtu/files/findmtu.sh8
-rw-r--r--net/findmtu/pkg-descr8
-rw-r--r--net/findmtu/pkg-plist5
6 files changed, 55 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index a0e80297d6b4..60f7933bd254 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -113,6 +113,7 @@
SUBDIR += etunnel
SUBDIR += fcptools
SUBDIR += fidelio
+ SUBDIR += findmtu
SUBDIR += firetalk
SUBDIR += forg
SUBDIR += fpc-inet
diff --git a/net/findmtu/Makefile b/net/findmtu/Makefile
new file mode 100644
index 000000000000..a2a6740ecd90
--- /dev/null
+++ b/net/findmtu/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: findmtu
+# Date created: 13 July 2004
+# Whom: janos.mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= findmtu
+PORTVERSION= 0.9
+CATEGORIES= net ipv6
+MASTER_SITES= http://www.dia.uniroma3.it/~compunet/tunneldiscovery/findmtu/
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= A tool for performing IPv6 path MTU discovery on *NIX
+
+do-configure:
+ ${LN} -s ${WRKSRC}/Makefile.rawsocket ${WRKSRC}/Makefile
+
+post-build:
+ ${SED} -e "s:%%PREFIX%%:${PREFIX}:g" ${FILESDIR}/findmtu.sh > ${WRKDIR}/findmtu
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKDIR}/findmtu ${PREFIX}/bin/findmtu
+ ${INSTALL_PROGRAM} ${WRKSRC}/findmtu ${PREFIX}/bin/findmtu.real
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.freebsd ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/findmtu/distinfo b/net/findmtu/distinfo
new file mode 100644
index 000000000000..b633aa7cb148
--- /dev/null
+++ b/net/findmtu/distinfo
@@ -0,0 +1,2 @@
+MD5 (findmtu-0.9.tar.gz) = 5aa9e84714d5ba509b70a0a4be872105
+SIZE (findmtu-0.9.tar.gz) = 12814
diff --git a/net/findmtu/files/findmtu.sh b/net/findmtu/files/findmtu.sh
new file mode 100644
index 000000000000..a404f4f96eab
--- /dev/null
+++ b/net/findmtu/files/findmtu.sh
@@ -0,0 +1,8 @@
+#!/bin/sh
+if netstat -rn -f inet6 | grep -qv $1; then
+ # Delete host route. As it is not in the routing table,
+ # we are sure that it is a cloned route and can be deleted
+ # safely
+ route delete -inet6 $i > /dev/null 2> /dev/null
+fi
+%%PREFIX%%/bin/findmtu.real $1
diff --git a/net/findmtu/pkg-descr b/net/findmtu/pkg-descr
new file mode 100644
index 000000000000..a1884f224e22
--- /dev/null
+++ b/net/findmtu/pkg-descr
@@ -0,0 +1,8 @@
+FindMTU is a tool that performs IPv6 path MTU discovery. You can use it
+to debug network problems and to detect IPv6-in-IPv4 tunnels in the path
+to a destination.
+
+FindMTU only performs IPv6 path MTU discovery. It does not know about
+IPv4.
+
+WWW: http://www.dia.uniroma3.it/~compunet/tunneldiscovery/
diff --git a/net/findmtu/pkg-plist b/net/findmtu/pkg-plist
new file mode 100644
index 000000000000..c3ca3a8a3867
--- /dev/null
+++ b/net/findmtu/pkg-plist
@@ -0,0 +1,5 @@
+bin/findmtu
+bin/findmtu.real
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.freebsd
+%%PORTDOCS%%@dirrm %%DOCSDIR%%