aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/xfce4-mixer/Makefile4
-rw-r--r--deskutils/orage/Makefile4
-rw-r--r--print/xfce4-print/Makefile4
-rw-r--r--sysutils/xfce4-mcs-plugins/Makefile4
-rw-r--r--x11-fm/thunar/Makefile3
-rw-r--r--x11-themes/gtk-xfce-engine/Makefile4
-rw-r--r--x11-wm/xfce4-panel/Makefile4
-rw-r--r--x11-wm/xfce4-session/Makefile4
-rw-r--r--x11-wm/xfce4-wm/Makefile4
-rw-r--r--x11/libexo/Makefile2
-rw-r--r--x11/libxfce4mcs/Makefile4
11 files changed, 29 insertions, 12 deletions
diff --git a/audio/xfce4-mixer/Makefile b/audio/xfce4-mixer/Makefile
index f191301f406a..a627cc0f72d9 100644
--- a/audio/xfce4-mixer/Makefile
+++ b/audio/xfce4-mixer/Makefile
@@ -16,7 +16,6 @@ COMMENT= XFce 4 volume mixer module for xfce4-panel
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
@@ -24,6 +23,9 @@ USE_GNOME= gnometarget gtk20 intltool intlhack libxml2 pkgconfig
USE_XFCE= configenv libgui libmcs libutil mcsmanager panel
USE_XLIB= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/x11-wm/xfce4/bsd.xfce.mk"
.include <bsd.port.post.mk>
diff --git a/deskutils/orage/Makefile b/deskutils/orage/Makefile
index 08f3797432fb..5530222ee219 100644
--- a/deskutils/orage/Makefile
+++ b/deskutils/orage/Makefile
@@ -16,7 +16,6 @@ COMMENT= A calendar application to manage your time with XFce 4
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
@@ -44,4 +43,7 @@ post-patch:
@${REINPLACE_CMD} -e 's|libical-|no-&|g' ${WRKSRC}/configure
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
+
.include <bsd.port.post.mk>
diff --git a/print/xfce4-print/Makefile b/print/xfce4-print/Makefile
index d3f0e27718a1..3f9d97b7004b 100644
--- a/print/xfce4-print/Makefile
+++ b/print/xfce4-print/Makefile
@@ -17,7 +17,6 @@ COMMENT= XFce 4 graphical frontend for printing
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
@@ -65,7 +64,8 @@ RUN_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps-a4
.endif
post-patch:
- ${REINPLACE_CMD} -e 's/@LDFLAGS@/& -Wl,-E/' ${WRKSRC}/xfprint/Makefile.in \
+ @${REINPLACE_CMD} -e 's/@LDFLAGS@/& -Wl,-E/' ${WRKSRC}/xfprint/Makefile.in \
${WRKSRC}/xfprint-manager/Makefile.in
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/sysutils/xfce4-mcs-plugins/Makefile b/sysutils/xfce4-mcs-plugins/Makefile
index 64cfcd48fc0f..46fa1c78b734 100644
--- a/sysutils/xfce4-mcs-plugins/Makefile
+++ b/sysutils/xfce4-mcs-plugins/Makefile
@@ -16,7 +16,6 @@ COMMENT= XFce 4 settings manager plugins
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
@@ -24,6 +23,9 @@ USE_GNOME= gnometarget gtk20 intltool intlhack pkgconfig
USE_XFCE= configenv libgui mcsmanager
USE_XLIB= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/x11-wm/xfce4/bsd.xfce.mk"
.include <bsd.port.post.mk>
diff --git a/x11-fm/thunar/Makefile b/x11-fm/thunar/Makefile
index 6da592179c48..8bc3d4b1ee71 100644
--- a/x11-fm/thunar/Makefile
+++ b/x11-fm/thunar/Makefile
@@ -19,7 +19,6 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
@@ -133,6 +132,7 @@ CONFIGURE_ARGS+=--disable-startup-notification
post-patch:
@${REINPLACE_CMD} -e 's|docdir = .*|docdir = ${DOCSDIR}|' \
${WRKSRC}/docs/Makefile.in
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
.if !defined(WITH_FAM)
@${REINPLACE_CMD} -e 's|gamin|no-gamin|g' ${WRKSRC}/configure
.endif
@@ -144,5 +144,6 @@ post-patch:
post-install:
@-update-desktop-database
+#keep this here
.include "${PORTSDIR}/x11-wm/xfce4/bsd.xfce.mk"
.include <bsd.port.post.mk>
diff --git a/x11-themes/gtk-xfce-engine/Makefile b/x11-themes/gtk-xfce-engine/Makefile
index dab65e4c1022..25cd4ae58bf0 100644
--- a/x11-themes/gtk-xfce-engine/Makefile
+++ b/x11-themes/gtk-xfce-engine/Makefile
@@ -15,12 +15,14 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= An XFCE engine for GTK 2.0
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GNOME= glib20 gnomehack gtk20 pkgconfig
USE_XLIB= yes
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/x11-wm/xfce4/bsd.xfce.mk"
.include <bsd.port.post.mk>
diff --git a/x11-wm/xfce4-panel/Makefile b/x11-wm/xfce4-panel/Makefile
index b9eb0f323f88..38b8f42b797a 100644
--- a/x11-wm/xfce4-panel/Makefile
+++ b/x11-wm/xfce4-panel/Makefile
@@ -17,7 +17,6 @@ COMMENT= XFce 4 panel module
CONFLICTS= xfce4-systray-*
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
@@ -48,4 +47,7 @@ CONFIGURE_ARGS+=--enable-startup-notification
CONFIGURE_ARGS+=--disable-startup-notification
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
+
.include <bsd.port.post.mk>
diff --git a/x11-wm/xfce4-session/Makefile b/x11-wm/xfce4-session/Makefile
index a71786198a16..3fb94e4d6116 100644
--- a/x11-wm/xfce4-session/Makefile
+++ b/x11-wm/xfce4-session/Makefile
@@ -19,7 +19,6 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
@@ -30,6 +29,9 @@ USE_XLIB= yes
MAN1= xfce4-session.1 xfce4-session-logout.1
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
+
.include <bsd.port.pre.mk>
.include "${PORTSDIR}/x11-wm/xfce4/bsd.xfce.mk"
.include <bsd.port.post.mk>
diff --git a/x11-wm/xfce4-wm/Makefile b/x11-wm/xfce4-wm/Makefile
index f0aadefadc98..903e7dace3c9 100644
--- a/x11-wm/xfce4-wm/Makefile
+++ b/x11-wm/xfce4-wm/Makefile
@@ -18,7 +18,6 @@ COMMENT= XFce 4 window manager
CONFIGURE_ARGS= --enable-xinerama
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
@@ -46,4 +45,7 @@ CONFIGURE_ARGS+=--enable-startup-notification
CONFIGURE_ARGS+=--disable-startup-notification
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
+
.include <bsd.port.post.mk>
diff --git a/x11/libexo/Makefile b/x11/libexo/Makefile
index 4bd764fbffa3..f8e848cb858c 100644
--- a/x11/libexo/Makefile
+++ b/x11/libexo/Makefile
@@ -26,7 +26,6 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
GNU_CONFIGURE= yes
INSTALLS_ICONS= yes
-USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
@@ -94,5 +93,6 @@ PLIST_SUB+= MCS_MANAGER="@comment "
post-patch:
@${REINPLACE_CMD} -e 's|FALSE;;|FALSE;|' ${WRKSRC}/exo/exo-icon-view.c
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
.include <bsd.port.post.mk>
diff --git a/x11/libxfce4mcs/Makefile b/x11/libxfce4mcs/Makefile
index 719532804258..6508e0b7c9d3 100644
--- a/x11/libxfce4mcs/Makefile
+++ b/x11/libxfce4mcs/Makefile
@@ -15,7 +15,6 @@ MAINTAINER= oliver@FreeBSD.org
COMMENT= XFce 4 settings management library used by most XFce 4 modules
GNU_CONFIGURE= yes
-USE_AUTOTOOLS= libtool:15
USE_BZIP2= yes
USE_GETTEXT= yes
USE_GMAKE= yes
@@ -46,4 +45,7 @@ CONFIGURE_ARGS+=--enable-startup-notification
CONFIGURE_ARGS+=--disable-startup-notification
.endif
+post-patch:
+ @${REINPLACE_CMD} -e 's|echo aout|echo elf|g' ${WRKSRC}/configure
+
.include <bsd.port.post.mk>