aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/cplanet/Makefile36
-rw-r--r--www/cplanet/distinfo3
-rw-r--r--www/cplanet/pkg-descr4
-rw-r--r--www/cplanet/pkg-plist6
5 files changed, 50 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 091b35451360..3ad2eb58a3d6 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -109,6 +109,7 @@
SUBDIR += commonist
SUBDIR += contenido
SUBDIR += coppermine
+ SUBDIR += cplanet
SUBDIR += crawl
SUBDIR += crp
SUBDIR += css-mode.el
diff --git a/www/cplanet/Makefile b/www/cplanet/Makefile
new file mode 100644
index 000000000000..80588ed1fc51
--- /dev/null
+++ b/www/cplanet/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: cplanet
+# Date created: 2010-02-22
+# Whom: Bapt <baptiste.daroussin@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cplanet
+PORTVERSION= 0.3
+CATEGORIES= www textproc
+MASTER_SITES= http://baptux.free.fr/distfiles/
+
+MAINTAINER= baptiste.daroussin@gmail.com
+COMMENT= RSS Feed Aggregator that generate static html
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libneo_cs.a:${PORTSDIR}/www/clearsilver
+LIB_DEPENDS= mrss.19:${PORTSDIR}/textproc/libmrss
+
+USE_BZIP2= yes
+
+USE_ICONV= yes
+
+MAN1= cplanet.1
+
+.include <bsd.port.pre.mk>
+post-install:
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL} -o root -g wheel -m 644 ${WRKSRC}/samples/cplanet-atom.cs ${EXAMPLESDIR}
+ ${INSTALL} -o root -g wheel -m 644 ${WRKSRC}/samples/cplanet-opml.cs ${EXAMPLESDIR}
+ ${INSTALL} -o root -g wheel -m 644 ${WRKSRC}/samples/cplanet-rss.cs ${EXAMPLESDIR}
+ ${INSTALL} -o root -g wheel -m 644 ${WRKSRC}/samples/cplanet.cs ${EXAMPLESDIR}
+ ${INSTALL} -o root -g wheel -m 644 ${WRKSRC}/samples/cplanet.hdf ${EXAMPLESDIR}
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/www/cplanet/distinfo b/www/cplanet/distinfo
new file mode 100644
index 000000000000..4e509bed0173
--- /dev/null
+++ b/www/cplanet/distinfo
@@ -0,0 +1,3 @@
+MD5 (cplanet-0.3.tar.bz2) = 9114f951726bb7df4e66770df0315ca5
+SHA256 (cplanet-0.3.tar.bz2) = 9aba913ba364757efb092c9cfa2c4c7bb946a71cb777522704039f553753bb3f
+SIZE (cplanet-0.3.tar.bz2) = 7618
diff --git a/www/cplanet/pkg-descr b/www/cplanet/pkg-descr
new file mode 100644
index 000000000000..393236334ac0
--- /dev/null
+++ b/www/cplanet/pkg-descr
@@ -0,0 +1,4 @@
+cplanet is a RSS/ATOM feed aggregator written in C that generate static
+html files.
+
+WWW: http://brokk.etoilebsd.net/projects/show/cplanet
diff --git a/www/cplanet/pkg-plist b/www/cplanet/pkg-plist
new file mode 100644
index 000000000000..4299ae2d559d
--- /dev/null
+++ b/www/cplanet/pkg-plist
@@ -0,0 +1,6 @@
+bin/cplanet
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cplanet-atom.cs
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cplanet-opml.cs
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cplanet-rss.cs
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cplanet.cs
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/cplanet.hdf