aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/rss2email2/Makefile4
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/py-html2text2018/Makefile29
-rw-r--r--textproc/py-html2text2018/distinfo3
-rw-r--r--textproc/py-html2text2018/pkg-descr5
-rw-r--r--www/geeknote/Makefile4
6 files changed, 42 insertions, 4 deletions
diff --git a/mail/rss2email2/Makefile b/mail/rss2email2/Makefile
index 1e0d80633fd6..aa384e5e93f8 100644
--- a/mail/rss2email2/Makefile
+++ b/mail/rss2email2/Makefile
@@ -3,7 +3,7 @@
PORTNAME= rss2email
PORTVERSION= 2.71
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= mail python
MASTER_SITES= http://www.allthingsrss.com/rss2email/
PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
@@ -19,7 +19,7 @@ LICENSE= GPLv2 GPLv3
LICENSE_COMB= dual
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}feedparser>=5.0.1:textproc/py-feedparser@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}html2text>=3.0.1:textproc/py-html2text@${PY_FLAVOR}
+ ${PYTHON_PKGNAMEPREFIX}html2text2018>=3.0.1:textproc/py-html2text2018@${PY_FLAVOR}
USES= python:2.7 shebangfix
SHEBANG_FILES= rss2email.py
diff --git a/textproc/Makefile b/textproc/Makefile
index dcd1efaa8f61..f560436931fc 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -1267,6 +1267,7 @@
SUBDIR += py-guess-language
SUBDIR += py-hexdump
SUBDIR += py-html2text
+ SUBDIR += py-html2text2018
SUBDIR += py-humanfriendly
SUBDIR += py-hunspell
SUBDIR += py-hyperestraier-python
diff --git a/textproc/py-html2text2018/Makefile b/textproc/py-html2text2018/Makefile
new file mode 100644
index 000000000000..d4bf79807cf4
--- /dev/null
+++ b/textproc/py-html2text2018/Makefile
@@ -0,0 +1,29 @@
+# Created by: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= html2text
+PORTVERSION= 2018.1.9
+PORTREVISION= 2
+CATEGORIES= textproc python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+PKGNAMESUFFIX= 2018
+
+MAINTAINER= dbaio@FreeBSD.org
+COMMENT= Convert HTML into clean plain ASCII text
+
+LICENSE= GPLv3+
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+TEST_DEPENDS= ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage@${PY_FLAVOR}
+
+USES= python
+USE_PYTHON= distutils concurrent autoplist
+NO_ARCH= yes
+
+CONFLICTS_INSTALL= html2text py*-html2text
+
+do-test:
+ @cd ${WRKSRC} && coverage run --source=html2text setup.py test -v
+
+.include <bsd.port.mk>
diff --git a/textproc/py-html2text2018/distinfo b/textproc/py-html2text2018/distinfo
new file mode 100644
index 000000000000..c86459ac5332
--- /dev/null
+++ b/textproc/py-html2text2018/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1515708173
+SHA256 (html2text-2018.1.9.tar.gz) = 627514fb30e7566b37be6900df26c2c78a030cc9e6211bda604d8181233bcdd4
+SIZE (html2text-2018.1.9.tar.gz) = 52211
diff --git a/textproc/py-html2text2018/pkg-descr b/textproc/py-html2text2018/pkg-descr
new file mode 100644
index 000000000000..4ed6cf7b92db
--- /dev/null
+++ b/textproc/py-html2text2018/pkg-descr
@@ -0,0 +1,5 @@
+html2text is a Python script that converts a page of HTML into clean,
+easy-to-read plain ASCII text. Better yet, that ASCII also happens to
+be valid Markdown (a text-to-HTML format).
+
+WWW: https://github.com/Alir3z4/html2text/
diff --git a/www/geeknote/Makefile b/www/geeknote/Makefile
index 5fb859288640..a9306b3944e4 100644
--- a/www/geeknote/Makefile
+++ b/www/geeknote/Makefile
@@ -3,7 +3,7 @@
PORTNAME= geeknote
DISTVERSION= 0.2a
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www python
MAINTAINER= koobs@FreeBSD.org
@@ -12,7 +12,7 @@ COMMENT= Command line client for Evernote
LICENSE= GPLv2
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}evernote>=1.17:www/py-evernote@${PY_FLAVOR} \
- ${PYTHON_PKGNAMEPREFIX}html2text>0:textproc/py-html2text@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}html2text2018>0:textproc/py-html2text2018@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}sqlalchemy10>0:databases/py-sqlalchemy10@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}markdown2>0:textproc/py-markdown2@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.0:www/py-beautifulsoup@${PY_FLAVOR} \