aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.gstreamer.mk4
-rw-r--r--multimedia/gstreamer1-plugins-all/Makefile2
-rw-r--r--multimedia/gstreamer1-plugins-core/Makefile2
-rw-r--r--multimedia/gstreamer1-plugins-rtmp/Makefile13
-rw-r--r--multimedia/gstreamer1-plugins/Makefile.common5
5 files changed, 22 insertions, 4 deletions
diff --git a/Mk/bsd.gstreamer.mk b/Mk/bsd.gstreamer.mk
index 7639bc2455aa..ab29ae2cbb07 100644
--- a/Mk/bsd.gstreamer.mk
+++ b/Mk/bsd.gstreamer.mk
@@ -89,7 +89,7 @@ _GSTREAMER_PLUGINS+= \
# plugins only in 1.0
.if defined(USE_GSTREAMER1)
_GSTREAMER_PLUGINS+= \
- assrender celt curl dvdread libav modplug png spandsp vpx \
+ assrender celt curl dvdread libav modplug png rtmp spandsp vpx \
x ximagesrc zbar
.endif
@@ -292,6 +292,8 @@ mplex_DEPENDS= multimedia/gstreamer-plugins-mplex
qt4_DEPENDS= multimedia/gstreamer-qt4
qt4_GST_PREFIX= gstreamer-
+rtmp_DEPENDS= multimedia/gstreamer1-plugins-rtmp
+
v4l2_DEPENDS= multimedia/gstreamer-plugins-v4l2
vp8_DEPENDS= multimedia/gstreamer-plugins-vp8
diff --git a/multimedia/gstreamer1-plugins-all/Makefile b/multimedia/gstreamer1-plugins-all/Makefile
index e2e9fb6105c2..df233f2470c6 100644
--- a/multimedia/gstreamer1-plugins-all/Makefile
+++ b/multimedia/gstreamer1-plugins-all/Makefile
@@ -3,7 +3,7 @@
PORTNAME= gstreamer1-plugins-all
PORTVERSION= ${GST1_VERSION}
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= # empty
DISTFILES= # empty
diff --git a/multimedia/gstreamer1-plugins-core/Makefile b/multimedia/gstreamer1-plugins-core/Makefile
index 1c57f6a18dc5..9d87ed29730b 100644
--- a/multimedia/gstreamer1-plugins-core/Makefile
+++ b/multimedia/gstreamer1-plugins-core/Makefile
@@ -3,7 +3,7 @@
# $MCom: ports/multimedia/gstreamer-plugins-core/Makefile,v 1.17 2006/07/17 01:39:57 ahze Exp $
PORTNAME= gstreamer1-plugins-core
-PORTVERSION= ${GST1_VERSION}
+PORTVERSION= ${GST1_VERSION}${GST1_MINIMAL_VERSION}
PORTREVISION= 0
CATEGORIES= multimedia audio
MASTER_SITES= # empty
diff --git a/multimedia/gstreamer1-plugins-rtmp/Makefile b/multimedia/gstreamer1-plugins-rtmp/Makefile
new file mode 100644
index 000000000000..bcffa9864852
--- /dev/null
+++ b/multimedia/gstreamer1-plugins-rtmp/Makefile
@@ -0,0 +1,13 @@
+# $FreeBSD$
+
+PORTREVISION= 0
+CATEGORIES= multimedia
+
+COMMENT= Gstreamer rtmp plugin
+
+GST_PLUGIN= rtmp
+DIST= bad
+
+MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer1-plugins
+
+.include "${MASTERDIR}/Makefile"
diff --git a/multimedia/gstreamer1-plugins/Makefile.common b/multimedia/gstreamer1-plugins/Makefile.common
index b9ab6101b991..4dbcd47440bd 100644
--- a/multimedia/gstreamer1-plugins/Makefile.common
+++ b/multimedia/gstreamer1-plugins/Makefile.common
@@ -29,6 +29,7 @@ BAD_GST_ALL_PLUGINS+= \
mplex \
opencv \
resindvd \
+ rtmp \
schro \
soundtouch \
spandsp \
@@ -62,7 +63,6 @@ BAD_GST_ALL_PLUGINS+= \
opus \
pvr \
rsvg \
- rtmp \
sdl \
sndfile \
sndio \
@@ -327,6 +327,9 @@ gst_pulse_LIB_DEPENDS= pulse:${PORTSDIR}/audio/pulseaudio
gst_resindvd_BUILD_DEPENDS= libdvdnav>=4.1.2:${PORTSDIR}/multimedia/libdvdnav
gst_resindvd_RUN_DEPENDS= libdvdnav>=4.1.2:${PORTSDIR}/multimedia/libdvdnav
+# rtmp
+gst_rtmp_LIB_DEPENDS= rtmp.0:${PORTSDIR}/multimedia/rtmpdump
+
# shout2
# keep the version to tell de difference between libshout and libshout2
gst_shout2_LIB_DEPENDS= shout.5:${PORTSDIR}/audio/libshout2