aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/rubyphoto/Makefile61
-rw-r--r--graphics/rubyphoto/distinfo1
-rw-r--r--graphics/rubyphoto/pkg-descr11
-rw-r--r--graphics/rubyphoto/pkg-message12
-rw-r--r--graphics/rubyphoto/pkg-plist41
6 files changed, 127 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 6dd1e0b7b649..80a0f2a23bd6 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -330,6 +330,7 @@
SUBDIR += ruby-rmagick
SUBDIR += ruby-svg
SUBDIR += ruby-tgif
+ SUBDIR += rubyphoto
SUBDIR += s10sh
SUBDIR += s3switch
SUBDIR += sam2p
diff --git a/graphics/rubyphoto/Makefile b/graphics/rubyphoto/Makefile
new file mode 100644
index 000000000000..6b60f0dd18ee
--- /dev/null
+++ b/graphics/rubyphoto/Makefile
@@ -0,0 +1,61 @@
+# New ports collection makefile for: rubyphoto
+# Date created: June 14, 2003
+# Whom: Munish Chopra <mchopra@engmail.uwaterloo.ca>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rubyphoto
+PORTVERSION= 1.4
+CATEGORIES= graphics ruby www
+MASTER_SITES= http://plig.net/~ture/rubyphoto/files/
+
+MAINTAINER= mchopra@engmail.uwaterloo.ca
+COMMENT= A program for creating image galleries for the web
+
+LIB_DEPENDS= expat.4:${PORTSDIR}/textproc/expat2
+RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick \
+ ${RUBY_SITELIBDIR}/image_size.rb:${PORTSDIR}/graphics/ruby-image_size \
+ ${RUBY_SITELIBDIR}/xml/parser.rb:${PORTSDIR}/textproc/ruby-xmlparser
+
+NO_BUILD= yes
+
+USE_RUBY= yes
+RUBY_SHEBANG_FILES= ruby_photo.rb
+
+do-install:
+ ${INSTALL_SCRIPT} ${WRKSRC}/abspath.rb ${RUBY_SITELIBDIR}
+ ${INSTALL_SCRIPT} ${WRKSRC}/findbin.rb ${RUBY_SITELIBDIR}
+ @${MKDIR} ${DATADIR}
+ @${MKDIR} ${DATADIR}/sample_input
+ @${MKDIR} ${DATADIR}/templates
+ @${MKDIR} ${DATADIR}/templates/alternate
+ @${MKDIR} ${DATADIR}/swigs-converters
+ @${MKDIR} ${DATADIR}/xml-generators
+ ${INSTALL_DATA} ${WRKSRC}/COPYING ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.html ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/album.rb ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/config.rb ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/dyn_resize.rb ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/image_cat.rb ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/image_size_cache.rb ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/joke.rb ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/myxml.rb ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/photo.rb ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/rp_debug.rb ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/ruby_photo.rb ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/template.rb ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/urlencode.rb ${DATADIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample_input/* ${DATADIR}/sample_input
+ ${INSTALL_DATA} ${WRKSRC}/templates/album.xml ${DATADIR}/templates
+ ${INSTALL_DATA} ${WRKSRC}/templates/image.xml ${DATADIR}/templates
+ ${INSTALL_DATA} ${WRKSRC}/templates/shared.xml ${DATADIR}/templates
+ ${INSTALL_DATA} ${WRKSRC}/templates/tree.xml ${DATADIR}/templates
+ ${INSTALL_DATA} ${WRKSRC}/templates/alternate/* ${DATADIR}/templates/alternate
+ ${INSTALL_DATA} ${WRKSRC}/swigs-converters/* ${DATADIR}/swigs-converters
+ ${INSTALL_DATA} ${WRKSRC}/xml-generators/* ${DATADIR}/xml-generators
+
+post-install:
+ @${SED} -e "s#%%DATADIR%%#${DATADIR}#" ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/graphics/rubyphoto/distinfo b/graphics/rubyphoto/distinfo
new file mode 100644
index 000000000000..b218e4318096
--- /dev/null
+++ b/graphics/rubyphoto/distinfo
@@ -0,0 +1 @@
+MD5 (rubyphoto-1.4.tar.gz) = 6610464b1e276b3c5c9e5e8f98a69c1c
diff --git a/graphics/rubyphoto/pkg-descr b/graphics/rubyphoto/pkg-descr
new file mode 100644
index 000000000000..cfb39bc5189a
--- /dev/null
+++ b/graphics/rubyphoto/pkg-descr
@@ -0,0 +1,11 @@
+RubyPhoto is a program for creating image galleries for the web. It
+recurses through a directory tree creating album index files for each
+sub-directory and image index files and thumbnails of specified sizes
+for each image. The generated HTML is completely customisable via
+templates. All configuration and image/album information is supplied
+in XML files.
+
+WWW: http://plig.net/~ture/rubyphoto/
+
+- Munish Chopra
+<mchopra@engmail.uwaterloo.ca>
diff --git a/graphics/rubyphoto/pkg-message b/graphics/rubyphoto/pkg-message
new file mode 100644
index 000000000000..52a7b7a5059c
--- /dev/null
+++ b/graphics/rubyphoto/pkg-message
@@ -0,0 +1,12 @@
+---------------------------------------------------------
+* Copy %%DATADIR%%/templates/* to
+ ~/.rubyphoto-templates.
+* Copy %%DATADIR%%/sample_input/config.xml
+ to ~/.rubyphoto-conf and edit it if you wish to deviate
+ from the default settings.
+* Copy rubyphoto.css and the granitesm_*.gif icons from
+ %%DATADIR%%/sample_input/ to your
+ top-level photo directory. In this directory, create
+ a file called .rubyphoto-ignore which contains
+ granitesm_*.gif.
+---------------------------------------------------------
diff --git a/graphics/rubyphoto/pkg-plist b/graphics/rubyphoto/pkg-plist
new file mode 100644
index 000000000000..76de2301b5c3
--- /dev/null
+++ b/graphics/rubyphoto/pkg-plist
@@ -0,0 +1,41 @@
+%%DATADIR%%/COPYING
+%%DATADIR%%/README.html
+%%DATADIR%%/album.rb
+%%DATADIR%%/config.rb
+%%DATADIR%%/dyn_resize.rb
+%%DATADIR%%/image_cat.rb
+%%DATADIR%%/image_size_cache.rb
+%%DATADIR%%/joke.rb
+%%DATADIR%%/myxml.rb
+%%DATADIR%%/photo.rb
+%%DATADIR%%/rp_debug.rb
+%%DATADIR%%/ruby_photo.rb
+%%DATADIR%%/sample_input/album.xml
+%%DATADIR%%/sample_input/config.xml
+%%DATADIR%%/sample_input/config.xml.old
+%%DATADIR%%/sample_input/example.jpg.xml
+%%DATADIR%%/sample_input/granitesm_left.gif
+%%DATADIR%%/sample_input/granitesm_right.gif
+%%DATADIR%%/sample_input/granitesm_top.gif
+%%DATADIR%%/sample_input/granitesm_up.gif
+%%DATADIR%%/sample_input/rubyphoto.css
+%%DATADIR%%/templates/alternate/album.xml
+%%DATADIR%%/templates/alternate/image.xml
+%%DATADIR%%/templates/alternate/shared.xml
+%%DATADIR%%/templates/alternate/tree.xml
+%%DATADIR%%/templates/album.xml
+%%DATADIR%%/templates/image.xml
+%%DATADIR%%/templates/shared.xml
+%%DATADIR%%/templates/tree.xml
+%%DATADIR%%/swigs-converters/albums.rb
+%%DATADIR%%/swigs-converters/images.rb
+%%DATADIR%%/xml-generators/classify-photos
+%%DATADIR%%/xml-generators/make-album
+%%DATADIR%%/template.rb
+%%DATADIR%%/urlencode.rb
+@dirrm %%DATADIR%%/sample_input
+@dirrm %%DATADIR%%/templates/alternate
+@dirrm %%DATADIR%%/templates
+@dirrm %%DATADIR%%/swigs-converters
+@dirrm %%DATADIR%%/xml-generators
+@dirrm %%DATADIR%%