aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/mimedefang/Makefile9
-rw-r--r--mail/mimedefang/distinfo2
-rw-r--r--mail/mimedefang/files/patch-init-script.in25
-rw-r--r--mail/mimedefang/pkg-message5
-rw-r--r--mail/mimedefang/pkg-plist4
5 files changed, 16 insertions, 29 deletions
diff --git a/mail/mimedefang/Makefile b/mail/mimedefang/Makefile
index 8c243becc7fe..d486c8b87bc0 100644
--- a/mail/mimedefang/Makefile
+++ b/mail/mimedefang/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= mimedefang
-PORTVERSION= 2.21
+PORTVERSION= 2.24
CATEGORIES= mail
MASTER_SITES= http://www.roaringpenguin.com/mimedefang/
@@ -21,6 +21,7 @@ BUILD_DEPENDS= \
${PERL_SITELIBDIR}/Mail/SpamAssassin.pm:${PORTSDIR}/mail/p5-Mail-SpamAssassin
USE_PERL5= yes
+USE_REINPLACE= yes
PERL_SITELIBDIR= ${LOCALBASE}/lib/perl5/site_perl/${PERL_VER}
GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc/mimedefang \
@@ -29,13 +30,17 @@ CONFIGURE_ARGS+= --sysconfdir=${PREFIX}/etc/mimedefang \
MAN5= mimedefang-filter.5
MAN7= mimedefang-protocol.7
-MAN8= mimedefang.8 mimedefang.pl.8 mimedefang-multiplexor.8
+MAN8= mimedefang.8 mimedefang.pl.8 mimedefang-multiplexor.8 \
+ md-mx-ctrl.8 watch-mimedefang.8
.if !exists( /usr/include/libmilter/mfapi.h )
BUILD_DEPENDS+= ${LOCALBASE}/include/libmilter/mfapi.h:${PORTSDIR}/mail/sendmail
.endif
post-install:
+ @${REINPLACE_CMD} -e 's,# MX_USER=,MX_USER=,g ; \
+ s,# MX_MAX_RSS=,MX_MAX_RSS=,g ; \
+ s,# MX_MAX_AS=,MX_MAX_AS=,g' ${WRKSRC}/examples/init-script
@${INSTALL_SCRIPT} ${WRKSRC}/examples/init-script ${PREFIX}/etc/rc.d/mimedefang.sh-dist
.if !defined(NOPORTDOCS)
@${MKDIR} ${EXAMPLESDIR}
diff --git a/mail/mimedefang/distinfo b/mail/mimedefang/distinfo
index 5aec9dcf3daf..4257c5a847af 100644
--- a/mail/mimedefang/distinfo
+++ b/mail/mimedefang/distinfo
@@ -1 +1 @@
-MD5 (mimedefang-2.21.tar.gz) = 9feefde1796b1f05798d38ded011a560
+MD5 (mimedefang-2.24.tar.gz) = c959a7aaf12c405e74071de826e8b65d
diff --git a/mail/mimedefang/files/patch-init-script.in b/mail/mimedefang/files/patch-init-script.in
deleted file mode 100644
index dbd39b29c059..000000000000
--- a/mail/mimedefang/files/patch-init-script.in
+++ /dev/null
@@ -1,25 +0,0 @@
---- examples/init-script.in.orig Sat Sep 7 02:04:17 2002
-+++ examples/init-script.in Sat Sep 7 02:05:03 2002
-@@ -37,7 +37,7 @@
- MULTIPLEXOR=yes
-
- # Run the multiplexor and filters as this user, not root. RECOMMENDED
--# MX_USER=@DEFANGUSER_DEFAULT@
-+MX_USER=@DEFANGUSER_DEFAULT@
-
- # If you want to keep spool directories around if the filter fails,
- # set the next one to yes
-@@ -99,11 +99,11 @@
-
- # Limit slave processes' resident-set size to this many kilobytes. Default
- # is unlimited.
--# MX_MAX_RSS=10000
-+MX_MAX_RSS=10000
-
- # Limit total size of slave processes' memory space to this many kilobytes.
- # Default is unlimited.
--# MX_MAX_AS=30000
-+MX_MAX_AS=30000
-
- # Number of seconds a process should be idle before checking for
- # minimum number and killed
diff --git a/mail/mimedefang/pkg-message b/mail/mimedefang/pkg-message
index a87bf72a07c6..a9a1e266df97 100644
--- a/mail/mimedefang/pkg-message
+++ b/mail/mimedefang/pkg-message
@@ -9,3 +9,8 @@ To finish installation please follow these steps:
define(`confINPUT_MAIL_FILTERS', `mimedefang')dnl
rebuild sendmail.cf and install it.
+
+Also, you can install some anti-virus software to check your mail, for example:
+
+ security/p5-File-Scan (Perl5 anti-virus file scanning package)
+ security/vscan (Evaluation version of a DOS/Windows/Linux file virus scanner)
diff --git a/mail/mimedefang/pkg-plist b/mail/mimedefang/pkg-plist
index d192b3992ebb..458c9d9805ea 100644
--- a/mail/mimedefang/pkg-plist
+++ b/mail/mimedefang/pkg-plist
@@ -1,17 +1,19 @@
bin/mimedefang-multiplexor
bin/mimedefang
bin/mimedefang.pl
+bin/md-mx-ctrl
+bin/watch-mimedefang
etc/rc.d/mimedefang.sh-dist
@unexec if cmp -s %D/etc/mimedefang/mimedefang-filter %D/etc/mimedefang/mimedefang-filter.example; then rm -f %D/etc/mimedefang/mimedefang-filter; fi
etc/mimedefang/mimedefang-filter.example
@unexec if cmp -s %D/etc/mimedefang/spamassassin/sa-mimedefang.cf %D/etc/mimedefang/spamassassin/sa-mimedefang.cf.example; then rm -f %D/etc/mimedefang/spamassassin/sa-mimedefang.cf; fi
etc/mimedefang/spamassassin/sa-mimedefang.cf.example
-etc/mimedefang/mimedefang-ip-key
%%PORTDOCS%%share/doc/mimedefang/README
%%PORTDOCS%%share/doc/mimedefang/README.ANOMY
%%PORTDOCS%%share/doc/mimedefang/README.SPAMASSASSIN
%%PORTDOCS%%share/doc/mimedefang/README.NONROOT
%%PORTDOCS%%share/doc/mimedefang/README.SECURITY
+%%PORTDOCS%%share/doc/mimedefang/README.IRIX
%%PORTDOCS%%share/examples/mimedefang/suggested-minimum-filter-for-windows-clients
%%PORTDOCS%%share/examples/mimedefang/stream-by-domain-filter
%%PORTDOCS%%share/examples/mimedefang/README