aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/mpt/Makefile3
-rw-r--r--audio/py-xmms/Makefile3
-rw-r--r--audio/rio500/Makefile3
-rw-r--r--audio/songprint/Makefile3
-rw-r--r--databases/freetds-devel/Makefile3
-rw-r--r--databases/freetds/Makefile3
-rw-r--r--databases/mdbtools/Makefile3
-rw-r--r--devel/getxml/Makefile3
-rw-r--r--devel/hat/Makefile3
-rw-r--r--devel/hs-hat/Makefile3
-rw-r--r--devel/libole2/Makefile3
-rw-r--r--devel/liboop/Makefile3
-rw-r--r--devel/libsoup/Makefile3
-rw-r--r--devel/libsoup22/Makefile3
-rw-r--r--devel/orbitcpp/Makefile3
-rw-r--r--devel/py-orbit/Makefile3
-rw-r--r--devel/py-orbit2/Makefile3
-rw-r--r--devel/silc-toolkit/Makefile3
-rw-r--r--devel/soup/Makefile3
-rw-r--r--graphics/gts/Makefile3
-rw-r--r--graphics/mjpegtools/Makefile3
-rw-r--r--graphics/ruby-gdk_pixbuf/Makefile3
-rw-r--r--graphics/ruby-gdk_pixbuf2/Makefile3
-rw-r--r--graphics/transcode/Makefile3
-rw-r--r--graphics/xmms-jess/Makefile3
-rw-r--r--irc/irssi-devel/Makefile3
-rw-r--r--irc/irssi/Makefile3
-rw-r--r--japanese/libicq/Makefile3
-rw-r--r--mail/pop3lite/Makefile3
-rw-r--r--mail/xfmail/Makefile3
-rw-r--r--misc/libelysium/Makefile3
-rw-r--r--misc/mc/Makefile3
-rw-r--r--misc/pybliographer/Makefile3
-rw-r--r--misc/xdelta/Makefile3
-rw-r--r--multimedia/mjpegtools/Makefile3
-rw-r--r--multimedia/transcode/Makefile3
-rw-r--r--net-im/libicq/Makefile3
-rw-r--r--net-mgmt/scli/Makefile3
-rw-r--r--net-p2p/dctc/Makefile3
-rw-r--r--net/dctc/Makefile3
-rw-r--r--net/ethereal/Makefile3
-rw-r--r--net/gnet-glib2/Makefile3
-rw-r--r--net/gnet/Makefile3
-rw-r--r--net/gnet2/Makefile3
-rw-r--r--net/gsk/Makefile3
-rw-r--r--net/libicq/Makefile3
-rw-r--r--net/scli/Makefile3
-rw-r--r--net/silc-client/Makefile3
-rw-r--r--net/wireshark/Makefile3
-rw-r--r--net/xferstats/Makefile3
-rw-r--r--textproc/gdome2/Makefile3
-rw-r--r--textproc/minidom/Makefile3
-rw-r--r--x11/dgs/Makefile3
53 files changed, 106 insertions, 53 deletions
diff --git a/audio/mpt/Makefile b/audio/mpt/Makefile
index 5a286fcb3ea7..9ae34a2461cd 100644
--- a/audio/mpt/Makefile
+++ b/audio/mpt/Makefile
@@ -16,7 +16,8 @@ MAINTAINER= lioux@FreeBSD.org
LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw \
songprint.1:${PORTSDIR}/audio/songprint
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib"
diff --git a/audio/py-xmms/Makefile b/audio/py-xmms/Makefile
index cb49843339f7..056b63346595 100644
--- a/audio/py-xmms/Makefile
+++ b/audio/py-xmms/Makefile
@@ -20,7 +20,8 @@ LIB_DEPENDS= xmms.3:${PORTSDIR}/audio/xmms
USE_PYTHON= yes
USE_PYDISTUTILS= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
PLIST_SUB+= PYTHON_SITELIBDIR=${PYTHON_SITELIBDIR:S,^${LOCALBASE}/,,g}
XMMS_CONFIG?= ${X11BASE}/bin/xmms-config
MAKE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" XMMS_CONFIG="${XMMS_CONFIG}"
diff --git a/audio/rio500/Makefile b/audio/rio500/Makefile
index 01e9d8f84178..1ec9d7b1ecc1 100644
--- a/audio/rio500/Makefile
+++ b/audio/rio500/Makefile
@@ -13,7 +13,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= k_nishizawa@anet.ne.jp
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-devicepath='/dev' \
--with-deviceentry='urio0' \
diff --git a/audio/songprint/Makefile b/audio/songprint/Makefile
index 7c337de535fd..20854dae2c75 100644
--- a/audio/songprint/Makefile
+++ b/audio/songprint/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= lioux@FreeBSD.org
LIB_DEPENDS= fftw.2:${PORTSDIR}/math/fftw
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/databases/freetds-devel/Makefile b/databases/freetds-devel/Makefile
index 3afcc561e00d..717701b8fdc1 100644
--- a/databases/freetds-devel/Makefile
+++ b/databases/freetds-devel/Makefile
@@ -34,7 +34,8 @@ CONFIGURE_ARGS+= --with-unixodbc=${LOCALBASE}
.endif
.if defined(WITH_IODBC) || defined(WITH_UNIXODBC)
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
PLIST_SUB+= ODBC=""
.else
PLIST_SUB+= ODBC="@comment "
diff --git a/databases/freetds/Makefile b/databases/freetds/Makefile
index 3afcc561e00d..717701b8fdc1 100644
--- a/databases/freetds/Makefile
+++ b/databases/freetds/Makefile
@@ -34,7 +34,8 @@ CONFIGURE_ARGS+= --with-unixodbc=${LOCALBASE}
.endif
.if defined(WITH_IODBC) || defined(WITH_UNIXODBC)
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
PLIST_SUB+= ODBC=""
.else
PLIST_SUB+= ODBC="@comment "
diff --git a/databases/mdbtools/Makefile b/databases/mdbtools/Makefile
index 75c55d6c1314..3df2729fcd12 100644
--- a/databases/mdbtools/Makefile
+++ b/databases/mdbtools/Makefile
@@ -16,7 +16,8 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
MAKE_ARGS+= GLIB_CONFIG="${GLIB_CONFIG}"
INSTALLS_SHLIB= yes
diff --git a/devel/getxml/Makefile b/devel/getxml/Makefile
index f7259d09ecfd..2300164b1317 100644
--- a/devel/getxml/Makefile
+++ b/devel/getxml/Makefile
@@ -17,7 +17,8 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= xml.5:${PORTSDIR}/textproc/libxml
USE_REINPLACE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
post-patch:
diff --git a/devel/hat/Makefile b/devel/hat/Makefile
index 58056e220ab6..140c6477ee27 100644
--- a/devel/hat/Makefile
+++ b/devel/hat/Makefile
@@ -27,7 +27,8 @@ RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
USE_GMAKE= yes
HAS_CONFIGURE= yes
USE_REINPLACE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
.if !defined(WITH_GHC) || defined(WITHOUT_NHC98)
ALL_TARGET= hat
.endif
diff --git a/devel/hs-hat/Makefile b/devel/hs-hat/Makefile
index 58056e220ab6..140c6477ee27 100644
--- a/devel/hs-hat/Makefile
+++ b/devel/hs-hat/Makefile
@@ -27,7 +27,8 @@ RUN_DEPENDS+= ghc:${PORTSDIR}/lang/ghc
USE_GMAKE= yes
HAS_CONFIGURE= yes
USE_REINPLACE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
.if !defined(WITH_GHC) || defined(WITHOUT_NHC98)
ALL_TARGET= hat
.endif
diff --git a/devel/libole2/Makefile b/devel/libole2/Makefile
index c38053b7bfc7..4b05983a7d7e 100644
--- a/devel/libole2/Makefile
+++ b/devel/libole2/Makefile
@@ -14,7 +14,8 @@ MASTER_SITE_SUBDIR= unstable/sources/libole2
MAINTAINER= gnome@FreeBSD.org
USE_GMAKE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/devel/liboop/Makefile b/devel/liboop/Makefile
index 4583ab750161..2591c1b2b1cc 100644
--- a/devel/liboop/Makefile
+++ b/devel/liboop/Makefile
@@ -17,7 +17,8 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= adns.1:${PORTSDIR}/net/adns \
wwwcore.1:${PORTSDIR}/www/libwww
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_LIBTOOL= yes
USE_REINPLACE= yes
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
diff --git a/devel/libsoup/Makefile b/devel/libsoup/Makefile
index fb5d022dd73e..7dd00661a1d2 100644
--- a/devel/libsoup/Makefile
+++ b/devel/libsoup/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
WRKSRC= ${WRKDIR}/${DISTNAME}
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
diff --git a/devel/libsoup22/Makefile b/devel/libsoup22/Makefile
index fb5d022dd73e..7dd00661a1d2 100644
--- a/devel/libsoup22/Makefile
+++ b/devel/libsoup22/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
WRKSRC= ${WRKDIR}/${DISTNAME}
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
diff --git a/devel/orbitcpp/Makefile b/devel/orbitcpp/Makefile
index 67151454fce5..1f573f08e567 100644
--- a/devel/orbitcpp/Makefile
+++ b/devel/orbitcpp/Makefile
@@ -17,7 +17,8 @@ BROKEN= "Does not build"
LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_GMAKE= yes
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
diff --git a/devel/py-orbit/Makefile b/devel/py-orbit/Makefile
index 10d8fbdf4d81..125cdd783ef0 100644
--- a/devel/py-orbit/Makefile
+++ b/devel/py-orbit/Makefile
@@ -19,7 +19,8 @@ MAINTAINER= wjv@FreeBSD.org
LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit
USE_GMAKE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
USE_PYTHON= yes
diff --git a/devel/py-orbit2/Makefile b/devel/py-orbit2/Makefile
index 10d8fbdf4d81..125cdd783ef0 100644
--- a/devel/py-orbit2/Makefile
+++ b/devel/py-orbit2/Makefile
@@ -19,7 +19,8 @@ MAINTAINER= wjv@FreeBSD.org
LIB_DEPENDS= ORBit.2:${PORTSDIR}/devel/ORBit
USE_GMAKE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
USE_PYTHON= yes
diff --git a/devel/silc-toolkit/Makefile b/devel/silc-toolkit/Makefile
index c335c86aafc0..bdbff9b15b22 100644
--- a/devel/silc-toolkit/Makefile
+++ b/devel/silc-toolkit/Makefile
@@ -26,7 +26,8 @@ RUN_DEPENDS= silc:${PORTSDIR}/net/silc-client
USE_BZIP2= yes
GNU_CONFIGURE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
CONFIGURE_ARGS= --with-silcd-config-file=${PREFIX}/etc/${PORTNAME} \
--with-docdir=${PREFIX}/share/doc/${PORTNAME}${PKGNAMESUFFIX} \
--with-etcdir=${PREFIX}/etc/${PORTNAME} \
diff --git a/devel/soup/Makefile b/devel/soup/Makefile
index fb5d022dd73e..7dd00661a1d2 100644
--- a/devel/soup/Makefile
+++ b/devel/soup/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt \
WRKSRC= ${WRKDIR}/${DISTNAME}
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-html-dir=${PREFIX}/share/doc
diff --git a/graphics/gts/Makefile b/graphics/gts/Makefile
index 187fbd2d3182..0024eb673ee8 100644
--- a/graphics/gts/Makefile
+++ b/graphics/gts/Makefile
@@ -17,7 +17,8 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= gnugetopt:${PORTSDIR}/devel/libgnugetopt
USE_LIBTOOL= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
diff --git a/graphics/mjpegtools/Makefile b/graphics/mjpegtools/Makefile
index 99241feb45b1..95b882ec9f14 100644
--- a/graphics/mjpegtools/Makefile
+++ b/graphics/mjpegtools/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
LIB_DEPENDS= aviplay-0.7.0:${PORTSDIR}/graphics/avifile \
jpeg.9:${PORTSDIR}/graphics/jpeg
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_GMAKE= yes
USE_REINPLACE= yes
USE_XLIB= yes
diff --git a/graphics/ruby-gdk_pixbuf/Makefile b/graphics/ruby-gdk_pixbuf/Makefile
index 188743998897..ff7a2285e48a 100644
--- a/graphics/ruby-gdk_pixbuf/Makefile
+++ b/graphics/ruby-gdk_pixbuf/Makefile
@@ -22,7 +22,8 @@ USE_GNOMECTRL= yes
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
USE_XLIB= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
.include "${.CURDIR}/../../x11/ruby-gnome/Makefile.common"
diff --git a/graphics/ruby-gdk_pixbuf2/Makefile b/graphics/ruby-gdk_pixbuf2/Makefile
index 188743998897..ff7a2285e48a 100644
--- a/graphics/ruby-gdk_pixbuf2/Makefile
+++ b/graphics/ruby-gdk_pixbuf2/Makefile
@@ -22,7 +22,8 @@ USE_GNOMECTRL= yes
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
USE_XLIB= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
.include "${.CURDIR}/../../x11/ruby-gnome/Makefile.common"
diff --git a/graphics/transcode/Makefile b/graphics/transcode/Makefile
index 91d675725937..3bf25e257e43 100644
--- a/graphics/transcode/Makefile
+++ b/graphics/transcode/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS= dvdread.2:${PORTSDIR}/graphics/libdvdread \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
USE_XLIB= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
diff --git a/graphics/xmms-jess/Makefile b/graphics/xmms-jess/Makefile
index 6b9653e750e3..cf4a956d5024 100644
--- a/graphics/xmms-jess/Makefile
+++ b/graphics/xmms-jess/Makefile
@@ -21,7 +21,8 @@ SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}"
GNU_CONFIGURE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_X_PREFIX= yes
.include <bsd.port.mk>
diff --git a/irc/irssi-devel/Makefile b/irc/irssi-devel/Makefile
index 84950b59d578..d0a8b05053c0 100644
--- a/irc/irssi-devel/Makefile
+++ b/irc/irssi-devel/Makefile
@@ -15,7 +15,8 @@ MAINTAINER?= vanilla@FreeBSD.org
USE_BZIP2= yes
USE_PERL5= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
# `+=' is for slave ports
CONFIGURE_ARGS+= --without-socks --without-bot --with-textui \
diff --git a/irc/irssi/Makefile b/irc/irssi/Makefile
index 84950b59d578..d0a8b05053c0 100644
--- a/irc/irssi/Makefile
+++ b/irc/irssi/Makefile
@@ -15,7 +15,8 @@ MAINTAINER?= vanilla@FreeBSD.org
USE_BZIP2= yes
USE_PERL5= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
# `+=' is for slave ports
CONFIGURE_ARGS+= --without-socks --without-bot --with-textui \
diff --git a/japanese/libicq/Makefile b/japanese/libicq/Makefile
index f136de9299b2..62c9e5770c62 100644
--- a/japanese/libicq/Makefile
+++ b/japanese/libicq/Makefile
@@ -20,7 +20,8 @@ PATCH_DIST_STRIP= -p1
MAINTAINER= flathill@FreeBSD.org
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
diff --git a/mail/pop3lite/Makefile b/mail/pop3lite/Makefile
index a762d9391a3a..9afacf29876f 100644
--- a/mail/pop3lite/Makefile
+++ b/mail/pop3lite/Makefile
@@ -13,7 +13,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_GMAKE= yes
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
diff --git a/mail/xfmail/Makefile b/mail/xfmail/Makefile
index 44b1c3294d56..b7d94f7e42b5 100644
--- a/mail/xfmail/Makefile
+++ b/mail/xfmail/Makefile
@@ -23,7 +23,8 @@ LIB_DEPENDS= forms.1:${PORTSDIR}/x11-toolkits/xforms \
USE_AUTOMAKE_VER= 15
USE_AUTOCONF= yes
USE_BZIP2= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_GMAKE= yes
USE_LIBTOOL= yes
USE_X_PREFIX= yes
diff --git a/misc/libelysium/Makefile b/misc/libelysium/Makefile
index c838d2bf6830..7f547a5c5d89 100644
--- a/misc/libelysium/Makefile
+++ b/misc/libelysium/Makefile
@@ -12,7 +12,8 @@ MASTER_SITES= http://elysium.zoned.net/${PORTNAME}/
MAINTAINER= sobomax@FreeBSD.org
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
INSTALLS_SHLIB= yes
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
diff --git a/misc/mc/Makefile b/misc/mc/Makefile
index 8c4e34a48d53..e723312376be 100644
--- a/misc/mc/Makefile
+++ b/misc/mc/Makefile
@@ -24,7 +24,8 @@ RUN_DEPENDS= ispell:${PORTSDIR}/textproc/ispell
.endif
USE_GMAKE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
.if defined(WITH_SLANG)
CONFIGURE_ARGS= --with-slang --without-gnome --with-edit
diff --git a/misc/pybliographer/Makefile b/misc/pybliographer/Makefile
index 74eab4911a96..a3f85641d6a5 100644
--- a/misc/pybliographer/Makefile
+++ b/misc/pybliographer/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= ${PYTHON_SITELIBDIR}/_gnomemodule.so:${PORTSDIR}/x11-toolkits/py-
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/_gnomemodule.so:${PORTSDIR}/x11-toolkits/py-gnome \
recode:${PORTSDIR}/converters/recode
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_PYTHON= yes
USE_GNOME= yes
USE_X_PREFIX= yes
diff --git a/misc/xdelta/Makefile b/misc/xdelta/Makefile
index 5010b7ce0e04..081413027153 100644
--- a/misc/xdelta/Makefile
+++ b/misc/xdelta/Makefile
@@ -13,7 +13,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= c9710216@atlas.newcastle.edu.au
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
INSTALLS_SHLIB= yes
CONFIGURE_TARGET= --target=${MACHINE_ARCH}-unknown-freebsd${OSREL}
diff --git a/multimedia/mjpegtools/Makefile b/multimedia/mjpegtools/Makefile
index 99241feb45b1..95b882ec9f14 100644
--- a/multimedia/mjpegtools/Makefile
+++ b/multimedia/mjpegtools/Makefile
@@ -18,7 +18,8 @@ BUILD_DEPENDS= nasm:${PORTSDIR}/devel/nasm
LIB_DEPENDS= aviplay-0.7.0:${PORTSDIR}/graphics/avifile \
jpeg.9:${PORTSDIR}/graphics/jpeg
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_GMAKE= yes
USE_REINPLACE= yes
USE_XLIB= yes
diff --git a/multimedia/transcode/Makefile b/multimedia/transcode/Makefile
index 91d675725937..3bf25e257e43 100644
--- a/multimedia/transcode/Makefile
+++ b/multimedia/transcode/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS= dvdread.2:${PORTSDIR}/graphics/libdvdread \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
USE_XLIB= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CFLAGS="-I${X11BASE}/include -I${LOCALBASE}/include" \
diff --git a/net-im/libicq/Makefile b/net-im/libicq/Makefile
index f365c3616b6e..a5d3bd4eedfc 100644
--- a/net-im/libicq/Makefile
+++ b/net-im/libicq/Makefile
@@ -14,7 +14,8 @@ MASTER_SITE_SUBDIR= flathill
MAINTAINER= flathill@FreeBSD.org
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
diff --git a/net-mgmt/scli/Makefile b/net-mgmt/scli/Makefile
index ffebfd850e87..2300a3bbdc6d 100644
--- a/net-mgmt/scli/Makefile
+++ b/net-mgmt/scli/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= lyngbol@wheel.dk
LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
GNU_CONFIGURE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
MAN1= scli.1
diff --git a/net-p2p/dctc/Makefile b/net-p2p/dctc/Makefile
index 412228af02c5..45410abcd11e 100644
--- a/net-p2p/dctc/Makefile
+++ b/net-p2p/dctc/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
LIB_DEPENDS= db4.0:${PORTSDIR}/databases/db4 \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
diff --git a/net/dctc/Makefile b/net/dctc/Makefile
index 412228af02c5..45410abcd11e 100644
--- a/net/dctc/Makefile
+++ b/net/dctc/Makefile
@@ -17,7 +17,8 @@ BUILD_DEPENDS= makedepend:${PORTSDIR}/devel/makedepend
LIB_DEPENDS= db4.0:${PORTSDIR}/databases/db4 \
gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_PERL5= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include \
diff --git a/net/ethereal/Makefile b/net/ethereal/Makefile
index 9cca8d7761f6..75ef2cb72fe7 100644
--- a/net/ethereal/Makefile
+++ b/net/ethereal/Makefile
@@ -28,7 +28,8 @@ MAN1+= ethereal.1
PLIST_SUB+= ETHEREAL=bin/ethereal
.else
PLIST_SUB+= ETHEREAL="@comment ethereal not built"
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
CONFIGURE_ARGS+= --enable-ethereal=no \
--disable-gtktest
.endif
diff --git a/net/gnet-glib2/Makefile b/net/gnet-glib2/Makefile
index 5b57166be256..83643e322dbe 100644
--- a/net/gnet-glib2/Makefile
+++ b/net/gnet-glib2/Makefile
@@ -13,7 +13,8 @@ MASTER_SITES= http://www.gnetlibrary.org/src/
MAINTAINER= nakai@FreeBSD.org
USE_REINPLACE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
diff --git a/net/gnet/Makefile b/net/gnet/Makefile
index 5b57166be256..83643e322dbe 100644
--- a/net/gnet/Makefile
+++ b/net/gnet/Makefile
@@ -13,7 +13,8 @@ MASTER_SITES= http://www.gnetlibrary.org/src/
MAINTAINER= nakai@FreeBSD.org
USE_REINPLACE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
diff --git a/net/gnet2/Makefile b/net/gnet2/Makefile
index 5b57166be256..83643e322dbe 100644
--- a/net/gnet2/Makefile
+++ b/net/gnet2/Makefile
@@ -13,7 +13,8 @@ MASTER_SITES= http://www.gnetlibrary.org/src/
MAINTAINER= nakai@FreeBSD.org
USE_REINPLACE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
diff --git a/net/gsk/Makefile b/net/gsk/Makefile
index 4b2bcc47b156..8d1b70378b59 100644
--- a/net/gsk/Makefile
+++ b/net/gsk/Makefile
@@ -19,7 +19,8 @@ USE_OPENSSL= yes
CONFIGURE_ARGS= --enable-ssl
.endif
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
CONFIGURE_ENV= LIBS="${PTHREAD_LIBS}"
USE_GMAKE= yes
diff --git a/net/libicq/Makefile b/net/libicq/Makefile
index f365c3616b6e..a5d3bd4eedfc 100644
--- a/net/libicq/Makefile
+++ b/net/libicq/Makefile
@@ -14,7 +14,8 @@ MASTER_SITE_SUBDIR= flathill
MAINTAINER= flathill@FreeBSD.org
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
diff --git a/net/scli/Makefile b/net/scli/Makefile
index ffebfd850e87..2300a3bbdc6d 100644
--- a/net/scli/Makefile
+++ b/net/scli/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= lyngbol@wheel.dk
LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
GNU_CONFIGURE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
MAN1= scli.1
diff --git a/net/silc-client/Makefile b/net/silc-client/Makefile
index 3d2fbfb40243..5cc44a0b5880 100644
--- a/net/silc-client/Makefile
+++ b/net/silc-client/Makefile
@@ -28,7 +28,8 @@ RUN_DEPENDS= ${LOCALBASE}/share/doc/silc/CREDITS:${.CURDIR}/../silc-doc
USE_BZIP2= yes
USE_PERL5= yes
GNU_CONFIGURE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
CONFIGURE_ARGS= --with-etcdir=${PREFIX}/etc/${PORTNAME} \
--with-helpdir=${PREFIX}/share/${PORTNAME}/help
PLIST_SUB= INSTALL_DIR="${INSTALL_DIR}"
diff --git a/net/wireshark/Makefile b/net/wireshark/Makefile
index 9cca8d7761f6..75ef2cb72fe7 100644
--- a/net/wireshark/Makefile
+++ b/net/wireshark/Makefile
@@ -28,7 +28,8 @@ MAN1+= ethereal.1
PLIST_SUB+= ETHEREAL=bin/ethereal
.else
PLIST_SUB+= ETHEREAL="@comment ethereal not built"
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
CONFIGURE_ARGS+= --enable-ethereal=no \
--disable-gtktest
.endif
diff --git a/net/xferstats/Makefile b/net/xferstats/Makefile
index d56afa3bdfe2..a3961a2432d7 100644
--- a/net/xferstats/Makefile
+++ b/net/xferstats/Makefile
@@ -15,7 +15,8 @@ MAINTAINER= demon@FreeBSD.org
WRKSRC= ${WRKDIR}/xferstats
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
GNU_CONFIGURE= yes
MAN8= xferstats.8
diff --git a/textproc/gdome2/Makefile b/textproc/gdome2/Makefile
index f59013785428..772015a84d74 100644
--- a/textproc/gdome2/Makefile
+++ b/textproc/gdome2/Makefile
@@ -14,7 +14,8 @@ MAINTAINER= knu@FreeBSD.org
LIB_DEPENDS= xml2.5:${PORTSDIR}/textproc/libxml2
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_LIBTOOL= yes
CONFIGURE_ENV= GLIB_CONFIG="${GLIB_CONFIG}" CPPFLAGS="-I${LOCALBASE}/include"
PLIST_SUB= DOCSDIR="share/doc/${DISTNAME}"
diff --git a/textproc/minidom/Makefile b/textproc/minidom/Makefile
index 8278fe7a6224..5e0894bc969b 100644
--- a/textproc/minidom/Makefile
+++ b/textproc/minidom/Makefile
@@ -17,7 +17,8 @@ MAINTAINER= ports@FreeBSD.org
LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2 \
iconv.3:${PORTSDIR}/converters/libiconv
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
USE_LIBTOOL= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
diff --git a/x11/dgs/Makefile b/x11/dgs/Makefile
index e8ed404e7fb4..3811835380a7 100644
--- a/x11/dgs/Makefile
+++ b/x11/dgs/Makefile
@@ -20,7 +20,8 @@ RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript-gnu
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GLIB= yes
+USE_GNOMENG= yes
+USE_GNOME= glib12
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes