aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--misc/txt2regex/Makefile12
-rw-r--r--misc/txt2regex/distinfo4
-rw-r--r--misc/txt2regex/pkg-descr10
3 files changed, 14 insertions, 12 deletions
diff --git a/misc/txt2regex/Makefile b/misc/txt2regex/Makefile
index 1f482c1ce6a5..18c451a4d405 100644
--- a/misc/txt2regex/Makefile
+++ b/misc/txt2regex/Makefile
@@ -7,7 +7,7 @@
#
PORTNAME= txt2regex
-PORTVERSION= 0.7
+PORTVERSION= 0.8
CATEGORIES= misc
MASTER_SITES= http://txt2regex.sourceforge.net/
EXTRACT_SUFX= .tgz
@@ -15,18 +15,20 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
COMMENT= A Regular Expression "wizard"
-RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash
USE_REINPLACE= yes
NO_BUILD= yes
+
+MAN1= txt2regex.1
PLIST_FILES= bin/txt2regex
post-patch:
- @${REINPLACE_CMD} -e "s,/bin/bash,${LOCALBASE}/bin/bash,g ; \
- s,\`seq,\`gseq,g" ${WRKSRC}/${DISTNAME}.sh
- @${REINPLACE_CMD} -e "s,/usr,${LOCALBASE},g" ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e \
+ "s,/bin/bash,${LOCALBASE}/bin/bash,g" ${WRKSRC}/${DISTNAME}.sh
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/${DISTNAME}.sh ${PREFIX}/bin/txt2regex
+ ${INSTALL_MAN} ${WRKSRC}/txt2regex.man ${MANPREFIX}/man/man1/txt2regex.1
.include <bsd.port.mk>
diff --git a/misc/txt2regex/distinfo b/misc/txt2regex/distinfo
index 84d3a62def86..4041170d0c92 100644
--- a/misc/txt2regex/distinfo
+++ b/misc/txt2regex/distinfo
@@ -1,2 +1,2 @@
-MD5 (txt2regex-0.7.tgz) = 5cc7366bd762c8f05fea431d8db1eba9
-SIZE (txt2regex-0.7.tgz) = 39287
+MD5 (txt2regex-0.8.tgz) = 83bc1f95b36fe51ade8d130fab390103
+SIZE (txt2regex-0.8.tgz) = 40514
diff --git a/misc/txt2regex/pkg-descr b/misc/txt2regex/pkg-descr
index 505417e9eeea..b37a144357c7 100644
--- a/misc/txt2regex/pkg-descr
+++ b/misc/txt2regex/pkg-descr
@@ -1,7 +1,7 @@
-^txt2regex$ is a Regular Expression "wizard", all written with bash2 builtins,
-that converts human sentences to RegExs. with a simple interface, you just
-answer to questions and build your own RegEx for a large variety of programs,
-like awk, ed, emacs, grep, perl, php, python, sed, tcl and vim. there are 18
-supported programs now.
+^txt2regex$ is a Regular Expression Wizard that converts human sentences to
+regexes. In a simple interactive console interface, the user answer
+questions and the program build the regexes for more than 20 programs, like
+Vim, Emacs, Perl, PHP, Python, Procmail and OpenOffice.org. It is a Shell
+Script 100% written with Bash builtin commands.
WWW: http://txt2regex.sourceforge.net/