aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/HVSC-Update/Makefile36
-rw-r--r--audio/HVSC-Update/distinfo1
-rw-r--r--audio/HVSC-Update/pkg-comment1
-rw-r--r--audio/HVSC-Update/pkg-descr3
-rw-r--r--audio/HVSC-Update/pkg-plist4
-rw-r--r--audio/Makefile1
6 files changed, 46 insertions, 0 deletions
diff --git a/audio/HVSC-Update/Makefile b/audio/HVSC-Update/Makefile
new file mode 100644
index 000000000000..137907bf640d
--- /dev/null
+++ b/audio/HVSC-Update/Makefile
@@ -0,0 +1,36 @@
+# New ports collection makefile for: HVSC-Update
+# Date created: 13 October 2002
+# Whom: Anders Nordby <anders@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= HVSC-Update
+PORTVERSION= 2.8.1
+CATEGORIES= audio emulators
+MASTER_SITES= http://sidplay2.sourceforge.net/ \
+ ftp://ftp.nuug.no/pub/anders/distfiles/
+DISTNAME= ${PORTNAME}-Tool-${PORTVERSION}-Source
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= anders@FreeBSD.org
+
+BUILD_DEPENDS= imake:${PORTSDIR}/devel/imake-4
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-Tool-${PORTVERSION}-Source
+
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+DOCS= HVSC_Update.txt PSID_v2NG.txt
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/src/Update ${PREFIX}/bin/HVSC-Update
+.if !defined(NOPORTDOCS)
+ @${INSTALL} -d -m 0755 ${DOCSDIR}
+.for f in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/HVSC-Update/distinfo b/audio/HVSC-Update/distinfo
new file mode 100644
index 000000000000..be5656c7bf07
--- /dev/null
+++ b/audio/HVSC-Update/distinfo
@@ -0,0 +1 @@
+MD5 (HVSC-Update-Tool-2.8.1-Source.tgz) = 2dd139c8bc5f3a7f3df1fabc8ab61a2b
diff --git a/audio/HVSC-Update/pkg-comment b/audio/HVSC-Update/pkg-comment
new file mode 100644
index 000000000000..c5fb3f2de338
--- /dev/null
+++ b/audio/HVSC-Update/pkg-comment
@@ -0,0 +1 @@
+Update program for the HVSC C= 64 SID tune collection
diff --git a/audio/HVSC-Update/pkg-descr b/audio/HVSC-Update/pkg-descr
new file mode 100644
index 000000000000..86e971e2ae9f
--- /dev/null
+++ b/audio/HVSC-Update/pkg-descr
@@ -0,0 +1,3 @@
+HVSC-Update is a tool to update your HVSC C= 64 SID tune collection.
+
+WWW: http://www.hvsc.c64.org/
diff --git a/audio/HVSC-Update/pkg-plist b/audio/HVSC-Update/pkg-plist
new file mode 100644
index 000000000000..dfb6c49d1b6f
--- /dev/null
+++ b/audio/HVSC-Update/pkg-plist
@@ -0,0 +1,4 @@
+bin/HVSC-Update
+%%PORTDOCS%%share/doc/HVSC-Update-Tool/HVSC_Update.txt
+%%PORTDOCS%%share/doc/HVSC-Update-Tool/PSID_v2NG.txt
+%%PORTDOCS%%@dirrm share/doc/HVSC-Update-Tool
diff --git a/audio/Makefile b/audio/Makefile
index 0b5fbe80d59a..809be21a4177 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -1,6 +1,7 @@
# $FreeBSD$
#
+ SUBDIR += HVSC-Update
SUBDIR += Maaate
SUBDIR += abcde
SUBDIR += abcmidi