aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--print/font2svg/Makefile16
1 files changed, 15 insertions, 1 deletions
diff --git a/print/font2svg/Makefile b/print/font2svg/Makefile
index 97ed703d3d54..e2b492d1c38c 100644
--- a/print/font2svg/Makefile
+++ b/print/font2svg/Makefile
@@ -15,12 +15,26 @@ MASTER_SITES= http://www.gdv.uni-hannover.de/~peinecke/font2svg/
MAINTAINER= ports@FreeBSD.org
COMMENT= All font to svg-font converter
+.if defined(WITH_GHOSTSCRIPT_AFPL) && ${WITH_GHOSTSCRIPT_AFPL} == yes
+GSPORT?= print/ghostscript-afpl
+.else
+GSPORT?= print/ghostscript-gnu
+.endif
+
RUN_DEPENDS= bash:${PORTSDIR}/shells/bash2 \
- gs:${PORTSDIR}/print/ghostscript-gnu
+ gs:${PORTSDIR}/${GSPORT}
USE_REINPLACE= yes
NO_BUILD= yes
+pre-fetch:
+.if !defined(WITH_GHOSTSCRIPT_AFPL) || ${WITH_GHOSTSCRIPT_AFPL} != yes
+ @${ECHO} ""
+ @${ECHO} " Define WITH_GHOSTSCRIPT_AFPL=yes to use"
+ @${ECHO} " AFPL Postscript interpreter instead of GNU one"
+ @${ECHO} ""
+.endif
+
post-patch:
@${REINPLACE_CMD} -e "s|/bin/bash|${LOCALBASE}/bin/bash|" \
-e "s|/home/peinecke/cprog/font2svg|${DATADIR}|" \