aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--news/nntp/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/news/nntp/Makefile b/news/nntp/Makefile
index 72ad4cc3ec6b..65f2e8a6b03c 100644
--- a/news/nntp/Makefile
+++ b/news/nntp/Makefile
@@ -49,6 +49,12 @@ ALONE= -e 's|\#define.ALONE|\#undef ALONE|'
post-extract:
${CP} ${WRKSRC}/conf.h.dist ${WRKSRC}/conf.h
+
+post-patch:
+ ${REINPLACE_CMD} \
+ -e 's=getline(=xmit_getline(=' \
+ ${WRKSRC}/xmit/nntpxmit.c
+
pre-configure:
${REINPLACE_CMD} ${ALONE} \
-e "s=/usr/local/news/lib/bin/config=${NEWSBIN}/config=" \