aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/river/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/x11-wm/river/Makefile b/x11-wm/river/Makefile
index 5ad5df87db9f..2140e5496192 100644
--- a/x11-wm/river/Makefile
+++ b/x11-wm/river/Makefile
@@ -2,6 +2,7 @@
PORTNAME= river
PORTVERSION= s20210314
+PORTREVISION= 1
CATEGORIES= x11-wm
MAINTAINER= jbeich@FreeBSD.org
@@ -35,7 +36,7 @@ NO_INSTALL= yes # strip(1) breaks runtime
PLIST_FILES= bin/${PORTNAME} \
bin/${PORTNAME}ctl \
bin/${PORTNAME}tile \
- ${ETCDIR}/init \
+ "@sample ${ETCDIR}/init.sample" \
share/bash-completion/completions/${PORTNAME}ctl \
share/zsh/site-functions/_${PORTNAME}ctl \
${NULL}
@@ -66,4 +67,8 @@ do-build:
do-test:
@(cd ${WRKSRC} && ${TEST_ENV} zig build test ${CONFIGURE_ARGS})
+post-install:
+# Let @sample handle default files under etc/
+ @${MV} ${STAGEDIR}${ETCDIR}/init ${STAGEDIR}${ETCDIR}/init.sample
+
.include <bsd.port.mk>