aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Template-Semantic/Makefile26
-rw-r--r--textproc/p5-Template-Semantic/distinfo2
-rw-r--r--textproc/p5-Template-Semantic/pkg-descr6
-rw-r--r--textproc/p5-Template-Semantic/pkg-plist9
5 files changed, 44 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 4f307f78b13e..4ad58407d02f 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -752,6 +752,7 @@
SUBDIR += p5-Template-Plugin-HTML-SuperForm
SUBDIR += p5-Template-Plugin-Lingua-EN-Inflect
SUBDIR += p5-Template-Plugin-XML-Escape
+ SUBDIR += p5-Template-Semantic
SUBDIR += p5-Template-Tiny
SUBDIR += p5-Term-QRCode
SUBDIR += p5-Test-Perl-Critic
diff --git a/textproc/p5-Template-Semantic/Makefile b/textproc/p5-Template-Semantic/Makefile
new file mode 100644
index 000000000000..c774f97a3bf8
--- /dev/null
+++ b/textproc/p5-Template-Semantic/Makefile
@@ -0,0 +1,26 @@
+# $FreeBSD$
+
+PORTNAME= Template-Semantic
+PORTVERSION= 0.09
+CATEGORIES= textproc perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to use pure XHTML/XML as a template
+
+RUN_DEPENDS= \
+ p5-HTML-Selector-XPath>=0.09:${PORTSDIR}/www/p5-HTML-Selector-XPath \
+ p5-XML-LibXML>=1.69:${PORTSDIR}/textproc/p5-XML-LibXML
+BUILD_DEPENDS= ${RUN_DEPENDS}
+TEST_DEPENDS= \
+ p5-Text-Pipe>0:${PORTSDIR}/textproc/p5-Text-Pipe
+
+PERL_CONFIGURE= yes
+
+MAN3= Template::Semantic.3 \
+ Template::Semantic::Cookbook.3 \
+ Template::Semantic::Document.3 \
+ Template::Semantic::Filter.3
+
+.include <bsd.port.mk>
diff --git a/textproc/p5-Template-Semantic/distinfo b/textproc/p5-Template-Semantic/distinfo
new file mode 100644
index 000000000000..93a02b5123f5
--- /dev/null
+++ b/textproc/p5-Template-Semantic/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Template-Semantic-0.09.tar.gz) = 26dd1b7955c690aa82c86af409373cdee447641633b544c8c4288b4eacc6f32f
+SIZE (Template-Semantic-0.09.tar.gz) = 63125
diff --git a/textproc/p5-Template-Semantic/pkg-descr b/textproc/p5-Template-Semantic/pkg-descr
new file mode 100644
index 000000000000..e3b3dcc8efe5
--- /dev/null
+++ b/textproc/p5-Template-Semantic/pkg-descr
@@ -0,0 +1,6 @@
+Template::Semantic is a template engine for XHTML/XML based on
+XML::LibXML that doesn't use any template syntax. This module takes
+pure XHTML/XML as a template, and uses XPath or CSS selectors to
+assign values.
+
+WWW: http://search.cpan.org/dist/Template-Semantic/
diff --git a/textproc/p5-Template-Semantic/pkg-plist b/textproc/p5-Template-Semantic/pkg-plist
new file mode 100644
index 000000000000..029900834d01
--- /dev/null
+++ b/textproc/p5-Template-Semantic/pkg-plist
@@ -0,0 +1,9 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Semantic/.packlist
+%%SITE_PERL%%/Template/Semantic.pm
+%%SITE_PERL%%/Template/Semantic/Cookbook.pod
+%%SITE_PERL%%/Template/Semantic/Document.pm
+%%SITE_PERL%%/Template/Semantic/Filter.pm
+@dirrm %%SITE_PERL%%/Template/Semantic
+@dirrmtry %%SITE_PERL%%/Template
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template/Semantic
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Template