aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/tei-p3/Makefile37
-rw-r--r--textproc/tei-p3/distinfo1
-rw-r--r--textproc/tei-p3/files/catalog5
-rw-r--r--textproc/tei-p3/pkg-comment1
-rw-r--r--textproc/tei-p3/pkg-descr11
-rw-r--r--textproc/tei-p3/pkg-plist53
7 files changed, 109 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index fbe37e478929..f88af28d4db9 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -367,6 +367,7 @@
SUBDIR += tei-guidelines-p3
SUBDIR += tei-guidelines-p4
SUBDIR += tei-lite
+ SUBDIR += tei-p3
SUBDIR += tei-xlite
SUBDIR += tex2im
SUBDIR += texi2db
diff --git a/textproc/tei-p3/Makefile b/textproc/tei-p3/Makefile
new file mode 100644
index 000000000000..b7d6bf7f27b1
--- /dev/null
+++ b/textproc/tei-p3/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: tei-p3
+# Date created: 19 May 2002
+# Whom: Henrik Motakef <henrik.motakef@web.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tei
+PORTVERSION= p3
+CATEGORIES= textproc
+MASTER_SITES= http://www.tei-c.org/Vault/GL/
+DISTNAME= teip3dtd
+
+MAINTAINER= henrik.motakef@web.de
+
+RUN_DEPENDS= ${MKCATALOG}:${PORTSDIR}/textproc/mkcatalog
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+PLIST_SUB= DTD_NAME=${PORTNAME} DTD_VERSION=${PORTVERSION} \
+ MKCATALOG=${MKCATALOG}
+
+SGMLDIR= ${PREFIX}/share/sgml
+INSTDIR= ${SGMLDIR}/${PORTNAME}/${PORTVERSION}
+MKCATALOG= ${PREFIX}/sbin/mkcatalog
+
+do-install:
+ @[ -d ${INSTDIR} ] || ${MKDIR} ${INSTDIR}
+ @${INSTALL_MAN} ${WRKSRC}/*.dtd ${INSTDIR}
+ @${INSTALL_MAN} ${WRKSRC}/*.ent ${INSTDIR}
+ @${SED} -e 's!%%INSTDIR%%!${INSTDIR}!' ${FILESDIR}/catalog \
+ > ${INSTDIR}/catalog
+
+post-install:
+ @${MKCATALOG} -q install ${PORTNAME}/${PORTVERSION}
+
+.include <bsd.port.mk>
diff --git a/textproc/tei-p3/distinfo b/textproc/tei-p3/distinfo
new file mode 100644
index 000000000000..02d9b8c709fe
--- /dev/null
+++ b/textproc/tei-p3/distinfo
@@ -0,0 +1 @@
+MD5 (teip3dtd.tar.gz) = a058bd1113b4e832023ba171518f2d84
diff --git a/textproc/tei-p3/files/catalog b/textproc/tei-p3/files/catalog
new file mode 100644
index 000000000000..afcfea08a4d7
--- /dev/null
+++ b/textproc/tei-p3/files/catalog
@@ -0,0 +1,5 @@
+PUBLIC "-//TEI P3//DTD Main Document Type//EN" "%%INSTDIR%%/tei2.dtd"END-of-tei-p3/files/catalog
+exit
+
+
+
diff --git a/textproc/tei-p3/pkg-comment b/textproc/tei-p3/pkg-comment
new file mode 100644
index 000000000000..babae93b393f
--- /dev/null
+++ b/textproc/tei-p3/pkg-comment
@@ -0,0 +1 @@
+DTD of the Text Encoding Initiative
diff --git a/textproc/tei-p3/pkg-descr b/textproc/tei-p3/pkg-descr
new file mode 100644
index 000000000000..3255f5c24a0e
--- /dev/null
+++ b/textproc/tei-p3/pkg-descr
@@ -0,0 +1,11 @@
+The DTD of the Text Encoding Initiative allows encoding of a wide range
+of document types in the domain of humanities. If focuses on, but is not
+restricted to, the needs of the scholarly research and education community.
+
+This port contains the TEI P3 DTD. It can be used to create documents that
+conform to either SGML or XML.
+
+WWW: http://www.tei-c.org/
+
+-- Henrik Motakef
+ <henrik.motakef@web.de>
diff --git a/textproc/tei-p3/pkg-plist b/textproc/tei-p3/pkg-plist
new file mode 100644
index 000000000000..1db6517c56fd
--- /dev/null
+++ b/textproc/tei-p3/pkg-plist
@@ -0,0 +1,53 @@
+@unexec %%MKCATALOG%% -q deinstall %%DTD_NAME%%/%%DTD_VERSION%%
+share/sgml/tei/p3/p2ents.dtd
+share/sgml/tei/p3/tei2.dtd
+share/sgml/tei/p3/teiana2.dtd
+share/sgml/tei/p3/teiback2.dtd
+share/sgml/tei/p3/teicert2.dtd
+share/sgml/tei/p3/teicore2.dtd
+share/sgml/tei/p3/teicorp2.dtd
+share/sgml/tei/p3/teidict2.dtd
+share/sgml/tei/p3/teidram2.dtd
+share/sgml/tei/p3/teifig2.dtd
+share/sgml/tei/p3/teifron2.dtd
+share/sgml/tei/p3/teifs2.dtd
+share/sgml/tei/p3/teifsd2.dtd
+share/sgml/tei/p3/teigen2.dtd
+share/sgml/tei/p3/teihdr2.dtd
+share/sgml/tei/p3/teilink2.dtd
+share/sgml/tei/p3/teimix2.dtd
+share/sgml/tei/p3/teind2.dtd
+share/sgml/tei/p3/teinet2.dtd
+share/sgml/tei/p3/teipl2.dtd
+share/sgml/tei/p3/teipros2.dtd
+share/sgml/tei/p3/teishd2.dtd
+share/sgml/tei/p3/teispok2.dtd
+share/sgml/tei/p3/teistr2.dtd
+share/sgml/tei/p3/teitc2.dtd
+share/sgml/tei/p3/teite2f.dtd
+share/sgml/tei/p3/teite2n.dtd
+share/sgml/tei/p3/teiterm2.dtd
+share/sgml/tei/p3/teitran2.dtd
+share/sgml/tei/p3/teitsd2.dtd
+share/sgml/tei/p3/teitsd2b.dtd
+share/sgml/tei/p3/teivers2.dtd
+share/sgml/tei/p3/teiwsd2.dtd
+share/sgml/tei/p3/teiana2.ent
+share/sgml/tei/p3/teiclas2.ent
+share/sgml/tei/p3/teidict2.ent
+share/sgml/tei/p3/teidram2.ent
+share/sgml/tei/p3/teifig2.ent
+share/sgml/tei/p3/teigis2.ent
+share/sgml/tei/p3/teikey2.ent
+share/sgml/tei/p3/teilink2.ent
+share/sgml/tei/p3/teind2.ent
+share/sgml/tei/p3/teispok2.ent
+share/sgml/tei/p3/teitc2.ent
+share/sgml/tei/p3/teiterm2.ent
+share/sgml/tei/p3/teitran2.ent
+share/sgml/tei/p3/teivers2.ent
+share/sgml/tei/p3/catalog
+@exec %%MKCATALOG%% -q install %%DTD_NAME%%/%%DTD_VERSION%%
+@dirrm share/sgml/tei/p3
+@unexec rmdir %D/share/sgml/tei 2>/dev/null || true
+@unexec rmdir %D/share/sgml 2>/dev/null || true