aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--MOVED1
-rw-r--r--net-im/Makefile3
-rw-r--r--net-im/licq-console/pkg-descr5
-rw-r--r--net-im/licq-icq/Makefile (renamed from net-im/licq-console/Makefile)15
-rw-r--r--net-im/licq-icq/pkg-descr6
-rw-r--r--net-im/licq-jabber/Makefile7
-rw-r--r--net-im/licq-msn/Makefile34
-rw-r--r--net-im/licq-msn/pkg-descr6
-rw-r--r--net-im/licq-osd/Makefile3
-rw-r--r--net-im/licq-qt-gui/Makefile9
-rw-r--r--net-im/licq/Makefile.inc2
-rw-r--r--net-im/licq/distinfo4
-rw-r--r--net-im/licq/pkg-message4
-rw-r--r--net-im/licq/pkg-plist18
14 files changed, 82 insertions, 35 deletions
diff --git a/MOVED b/MOVED
index 7d4f0d96caec..1609b802da9d 100644
--- a/MOVED
+++ b/MOVED
@@ -4899,3 +4899,4 @@ devel/bugzilla3|devel/bugzilla24|2013-08-30|EOL: Please update to a supported ve
german/bugzilla3|german/bugzilla42|2013-08-30|EOL: Please update to a supported version
japanese/bugzilla3|japanese/bugzilla42|2013-08-30|EOL: Please update to a supported version
russian/bugzilla3|russian/bugzilla42|2013-08-30|EOL: Please update to a supported version
+net-im/licq-console||2013-08-30|No longer maintained upstream
diff --git a/net-im/Makefile b/net-im/Makefile
index 06cd53a2eb8a..4dffffab3000 100644
--- a/net-im/Makefile
+++ b/net-im/Makefile
@@ -70,8 +70,9 @@
SUBDIR += libtelepathy
SUBDIR += libyahoo2
SUBDIR += licq
- SUBDIR += licq-console
+ SUBDIR += licq-icq
SUBDIR += licq-jabber
+ SUBDIR += licq-msn
SUBDIR += licq-osd
SUBDIR += licq-qt-gui
SUBDIR += linpopup
diff --git a/net-im/licq-console/pkg-descr b/net-im/licq-console/pkg-descr
deleted file mode 100644
index 00dc753997eb..000000000000
--- a/net-im/licq-console/pkg-descr
+++ /dev/null
@@ -1,5 +0,0 @@
-An ncurses console plugin for the popular icq clone licq.
-
-LICENSE: GPL2 or later with execption to link with OpenSSL
-
-WWW: http://www.licq.org/
diff --git a/net-im/licq-console/Makefile b/net-im/licq-icq/Makefile
index 70999d828507..3fd8aa184c1a 100644
--- a/net-im/licq-console/Makefile
+++ b/net-im/licq-icq/Makefile
@@ -1,24 +1,21 @@
-# Created by: Jeremy Norris <ishmael27@home.com>
# $FreeBSD$
-PORTNAME= console
-PORTVERSION= 1.7.1
-PORTREVISION= 1
+PORTNAME= icq
+PORTVERSION= 1.8.0
CATEGORIES= net-im
MAINTAINER= dinoex@FreeBSD.org
-COMMENT= Ncurses-based console plugin for Licq
-
-LIB_DEPENDS= cdk:${PORTSDIR}/devel/cdk \
- boost_regex:${PORTSDIR}/devel/boost-libs
+COMMENT= ICQ plugin for Licq
LICENSE= GPLv2
+LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs
+
USES= cmake
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
DOCFILES= README
-PLIST_FILES= lib/licq/licq_console.so \
+PLIST_FILES= lib/licq/protocol_icq.so \
%%PORTDOCS%%%%DOCSDIR%%/README
PLIST_DIRS= %%PORTDOCS%%%%DOCSDIR%%
diff --git a/net-im/licq-icq/pkg-descr b/net-im/licq-icq/pkg-descr
new file mode 100644
index 000000000000..dc531a99507a
--- /dev/null
+++ b/net-im/licq-icq/pkg-descr
@@ -0,0 +1,6 @@
+Adds support for the Jabber (XMPP) protocol to Licq. Still in early
+development, but capable of sending and receiving messages.
+
+LICENSE: GPL2 or later with execption to link with OpenSSL
+
+WWW: http://www.licq.org/
diff --git a/net-im/licq-jabber/Makefile b/net-im/licq-jabber/Makefile
index cffe4b0657d8..5962828b834b 100644
--- a/net-im/licq-jabber/Makefile
+++ b/net-im/licq-jabber/Makefile
@@ -1,18 +1,17 @@
# $FreeBSD$
PORTNAME= jabber
-PORTVERSION= 1.7.1
-PORTREVISION= 1
+PORTVERSION= 1.8.0
CATEGORIES= net-im
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Jabber (XMPP) plugin for Licq
+LICENSE= GPLv2
+
LIB_DEPENDS= gloox:${PORTSDIR}/net-im/gloox \
boost_regex:${PORTSDIR}/devel/boost-libs
-LICENSE= GPLv2
-
USES= cmake
DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
diff --git a/net-im/licq-msn/Makefile b/net-im/licq-msn/Makefile
new file mode 100644
index 000000000000..1683c3628736
--- /dev/null
+++ b/net-im/licq-msn/Makefile
@@ -0,0 +1,34 @@
+# $FreeBSD$
+
+PORTNAME= msn
+PORTVERSION= 1.8.0
+CATEGORIES= net-im
+
+MAINTAINER= dinoex@FreeBSD.org
+COMMENT= MSN plugin for Licq
+
+LICENSE= GPLv2
+
+LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs
+
+USES= cmake
+DOCSDIR= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
+
+DOCFILES= README
+PLIST_FILES= lib/licq/protocol_msn.so \
+ %%PORTDOCS%%%%DOCSDIR%%/README
+PLIST_DIRS= %%PORTDOCS%%%%DOCSDIR%%
+
+LICQ_PORT?= net-im/licq
+
+.include <bsd.port.pre.mk>
+
+.include "${PORTSDIR}/${LICQ_PORT}/Makefile.inc"
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}/
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/net-im/licq-msn/pkg-descr b/net-im/licq-msn/pkg-descr
new file mode 100644
index 000000000000..dc531a99507a
--- /dev/null
+++ b/net-im/licq-msn/pkg-descr
@@ -0,0 +1,6 @@
+Adds support for the Jabber (XMPP) protocol to Licq. Still in early
+development, but capable of sending and receiving messages.
+
+LICENSE: GPL2 or later with execption to link with OpenSSL
+
+WWW: http://www.licq.org/
diff --git a/net-im/licq-osd/Makefile b/net-im/licq-osd/Makefile
index 2f4a6bbc6ab1..d2c9ebd1b03c 100644
--- a/net-im/licq-osd/Makefile
+++ b/net-im/licq-osd/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= osd
-PORTVERSION= 1.7.1
-PORTREVISION= 2
+PORTVERSION= 1.8.0
PORTEPOCH= 1
CATEGORIES= net-im
diff --git a/net-im/licq-qt-gui/Makefile b/net-im/licq-qt-gui/Makefile
index ac042ee1adea..4f1f772bb4f4 100644
--- a/net-im/licq-qt-gui/Makefile
+++ b/net-im/licq-qt-gui/Makefile
@@ -2,19 +2,18 @@
# $FreeBSD$
PORTNAME= qt4-gui
-PORTVERSION= 1.7.1
-PORTREVISION= 1
+PORTVERSION= 1.8.0
CATEGORIES= net-im
PKGNAMESUFFIX?= ${KDE_SUFFIX}${PKGNAMESUFFIX2}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Qt plugin for licq
-LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs
-#BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen
-
LICENSE= GPLv2
+LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost-libs
+RUN_DEPENDS= ${LOCALBASE}/lib/licq/protocol_icq.so:${PORTSDIR}/${LICQ_PORT}-icq
+
USE_XORG= x11 xext ice xscrnsaver
USES= cmake
USE_QT4= qmake_build moc_build rcc_build uic_build linguist_build
diff --git a/net-im/licq/Makefile.inc b/net-im/licq/Makefile.inc
index 11e3628fff15..07ed7ff9b1e7 100644
--- a/net-im/licq/Makefile.inc
+++ b/net-im/licq/Makefile.inc
@@ -2,7 +2,7 @@
# $FreeBSD$
PKGNAMEPREFIX= licq-
-LICQ_VER= 1.7.1
+LICQ_VER= 1.8.0
.if ${PORTNAME} != "base"
BUILD_DEPENDS+= licq:${PORTSDIR}/${LICQ_PORT}
RUN_DEPENDS+= licq:${PORTSDIR}/${LICQ_PORT}
diff --git a/net-im/licq/distinfo b/net-im/licq/distinfo
index 6f580217b502..dceacc1356c2 100644
--- a/net-im/licq/distinfo
+++ b/net-im/licq/distinfo
@@ -1,2 +1,2 @@
-SHA256 (licq-1.7.1.tar.bz2) = f40537cc6286f6fbfd1e4dd6e98198e58721723003a5a1d1c6ccbf99bdc00da4
-SIZE (licq-1.7.1.tar.bz2) = 2399713
+SHA256 (licq-1.8.0.tar.bz2) = e30de74b92928bbf0724a2c6f45931cbb4bd90d8d9b1d4ddd002cfa01867da1f
+SIZE (licq-1.8.0.tar.bz2) = 2252723
diff --git a/net-im/licq/pkg-message b/net-im/licq/pkg-message
index 41656d4d7bc4..a1ec9e455fe6 100644
--- a/net-im/licq/pkg-message
+++ b/net-im/licq/pkg-message
@@ -1,3 +1,3 @@
In order to actually use licq, at least one plugin port needs to be installed.
-Currently they include: licq-qt-gui, licq-jons-gtk-gui, licq-console
-and several others. Check the net category to find them.
+Currently they include: licq-qt-gui, licq-kde-gui and several others.
+Check the net category to find them.
diff --git a/net-im/licq/pkg-plist b/net-im/licq/pkg-plist
index 1263ce357833..fdcb9ef97549 100644
--- a/net-im/licq/pkg-plist
+++ b/net-im/licq/pkg-plist
@@ -8,15 +8,16 @@ include/licq/contactlist/owner.h
include/licq/contactlist/user.h
include/licq/contactlist/usermanager.h
include/licq/conversation.h
+include/licq/crypto.h
include/licq/daemon.h
include/licq/event.h
include/licq/exceptions/exception.h
include/licq/filter.h
include/licq/gpghelper.h
include/licq/icq/chat.h
-include/licq/icq/codes.h
include/licq/icq/filetransfer.h
include/licq/icq/icq.h
+include/licq/icq/icqdata.h
include/licq/icq/owner.h
include/licq/icq/user.h
include/licq/inifile.h
@@ -27,16 +28,25 @@ include/licq/logging/logsink.h
include/licq/logging/logutils.h
include/licq/logging/pluginlogsink.h
include/licq/macro.h
-include/licq/md5.h
+include/licq/mainloop.h
include/licq/oneventmanager.h
include/licq/packet.h
include/licq/pipe.h
-include/licq/plugin/generalbase.h
include/licq/plugin/generalplugin.h
+include/licq/plugin/generalpluginfactory.h
+include/licq/plugin/generalpluginhelper.h
+include/licq/plugin/generalplugininstance.h
+include/licq/plugin/generalplugininterface.h
include/licq/plugin/plugin.h
+include/licq/plugin/pluginfactory.h
+include/licq/plugin/plugininstance.h
+include/licq/plugin/plugininterface.h
include/licq/plugin/pluginmanager.h
-include/licq/plugin/protocolbase.h
include/licq/plugin/protocolplugin.h
+include/licq/plugin/protocolpluginfactory.h
+include/licq/plugin/protocolpluginhelper.h
+include/licq/plugin/protocolplugininstance.h
+include/licq/plugin/protocolplugininterface.h
include/licq/pluginsignal.h
include/licq/protocolmanager.h
include/licq/protocolsignal.h