aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--emulators/jzintv/Makefile12
-rw-r--r--security/vlock/Makefile16
2 files changed, 16 insertions, 12 deletions
diff --git a/emulators/jzintv/Makefile b/emulators/jzintv/Makefile
index 40ac2507de51..8109b36df583 100644
--- a/emulators/jzintv/Makefile
+++ b/emulators/jzintv/Makefile
@@ -26,7 +26,9 @@ USE_ZIP= yes
CPPFLAGS+= -I${LOCALBASE}/include `${SDL_CONFIG} --cflags`
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS} `${SDL_CONFIG} --libs`
-OPTIONS= TOOLS "Install additional tools" off
+OPTIONS_DEFINE= TOOLS
+TOOLS_DESC= Install additional tools
+
TOOLS= as1600 crc32 dasm1600 dis1600 frombit_r gms2rom imvtoppm rom2bin \
show_grom tobit tobit_r bin2rom dasm0256 dasm1600o frombit fromhex \
imvtogif rom_merge split_rom tobit_f tohex
@@ -35,7 +37,7 @@ SUB_FILES= pkg-message
.include <bsd.port.pre.mk>
-.if defined(WITH_TOOLS)
+.if ${PORT_OPTIONS:MTOOLS}
PLIST_SUB+= PL_TOOLS=""
.else
PLIST_SUB+= PL_TOOLS="@comment "
@@ -51,18 +53,18 @@ do-install:
${MKDIR} ${DATADIR}/rom
${INSTALL_DATA} ${WRKSRC}/rom/*.rom ${DATADIR}/rom/
${INSTALL_PROGRAM} ${WRKSRC}/bin/jzintv ${PREFIX}/bin/jzintv
-.if defined(WITH_TOOLS)
+.if ${PORT_OPTIONS:MTOOLS}
.for tool in ${TOOLS}
${INSTALL_PROGRAM} ${WRKSRC}/bin/${tool} ${PREFIX}/bin/jzintv-${tool}
.endfor
.endif
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
${MKDIR} ${DOCSDIR}/doc
${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Release-Notes.txt ${DOCSDIR}
(cd ${WRKSRC}/doc/ && ${COPYTREE_SHARE} \* ${DOCSDIR}/doc)
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
${MKDIR} ${EXAMPLESDIR}
(cd ${WRKSRC}/examples/ && ${COPYTREE_SHARE} \* ${EXAMPLESDIR})
.endif
diff --git a/security/vlock/Makefile b/security/vlock/Makefile
index cf92468ca9ee..4297973c3de6 100644
--- a/security/vlock/Makefile
+++ b/security/vlock/Makefile
@@ -28,9 +28,11 @@ CONFIGURE_ARGS= --enable-plugins --enable-pam \
EXTRA_LDFLAGS="-L${LOCALBASE}/lib"
USE_CSTD= gnu99
-OPTIONS= ROOTPWD "Enable unlock using root password" on \
- VLOCKSCRIPTS "Install sample hook scripts" off \
- CACASAVER "Enable libcaca screensaver" off
+OPTIONS_DEFINE= ROOTPWD VLOCKSCRIPTS CACASAVER
+OPTIONS_DEFAULT= ROOTPWD
+ROOTPWD_DESC= Enable unlock using root password
+VLOCKSCRIPTS_DESC= Install sample hook scripts
+CACASAVER_DESC= Enable libcaca screensaver
MANLANG= ""
MAN1= vlock.1
@@ -49,20 +51,20 @@ PORTDOCS= ChangeLog PLUGINS README README.X11 SECURITY TODO
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_ROOTPWD)
+.if ${PORT_OPTIONS:MROOTPWD}
CONFIGURE_ARGS+= --enable-root-password
.else
CONFIGURE_ARGS+= --disable-root-password
.endif
-.if !defined(WITHOUT_VLOCKSCRIPTS)
+.if ${PORT_OPTIONS:MVLOCKSCRIPTS}
VLOCKSCRIPTS+= amarok.sh example_script.sh mplayer.sh
PLIST_SUB+= PL_VLOCKSCRIPTS=""
.else
PLIST_SUB+= PL_VLOCKSCRIPTS="@comment "
.endif
-.if !defined(WITHOUT_CACASAVER)
+.if ${PORT_OPTIONS:MCACASAVER}
BUILD_DEPENDS+= ${LOCALBASE}/lib/libcaca.a:${PORTSDIR}/graphics/libcaca
VLOCKMODULES+= caca.so
PLIST_SUB+= PL_CACASAVER=""
@@ -77,7 +79,7 @@ pre-install:
if ! pw groupshow ${VLOCKGRP}; then pw groupadd ${VLOCKGRP} -g ${VLOCKGID}; fi
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
.for doc in ${PORTDOCS}
${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}