aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11/imwheel/Makefile23
-rw-r--r--x11/imwheel/distinfo2
-rw-r--r--x11/imwheel/files/patch-Makefile.in14
-rw-r--r--x11/imwheel/files/patch-aa46
-rw-r--r--x11/imwheel/files/patch-ab2
-rw-r--r--x11/imwheel/files/patch-ac20
-rw-r--r--x11/imwheel/files/patch-ad20
-rw-r--r--x11/imwheel/files/patch-ae4
-rw-r--r--x11/imwheel/files/patch-af8
-rw-r--r--x11/imwheel/files/patch-getopt::Makefile.in11
-rw-r--r--x11/imwheel/files/patch-getopt::getopt.c16
-rw-r--r--x11/imwheel/pkg-descr21
-rw-r--r--x11/imwheel/pkg-plist.nodocs2
13 files changed, 63 insertions, 126 deletions
diff --git a/x11/imwheel/Makefile b/x11/imwheel/Makefile
index 778b90d9b8f4..da702eecb51e 100644
--- a/x11/imwheel/Makefile
+++ b/x11/imwheel/Makefile
@@ -6,30 +6,25 @@
#
PORTNAME= imwheel
-PORTVERSION= 0.9.7
+PORTVERSION= 0.9.9
CATEGORIES= x11
-MASTER_SITES= http://jcatki.dhs.org/imwheel/files/
-DISTNAME= ${PKGNAME}.nogpm
+MASTER_SITES= http://jonatkins.org/imwheel/files/
-MAINTAINER= jhb@FreeBSD.org
+MAINTAINER= ports@FreeBSD.org
USE_GMAKE= YES
USE_X_PREFIX= YES
-WRKSRC= ${WRKDIR}/imwheel
+GNU_CONFIGURE= YES
+CONFIGURE_ARGS= --disable-gpm
MAN1= imwheel.1
-.if defined(NOPORTDOCS)
-PLIST= ${PKGDIR}/pkg-plist.nodocs
-.endif
-
post-patch:
- @${PERL} -pi -e 's|%%X11BASE%%|${X11BASE}|g' ${WRKSRC}/imwheel.1
+.for i in imwheel.1 util.c
+ @${PERL} -pi -e 's|%%PREFIX%%|${PREFIX}|g' ${WRKSRC}/${i}
+.endfor
-do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/imwheel ${PREFIX}/bin
- ${INSTALL_MAN} ${WRKSRC}/imwheel.1 ${PREFIX}/man/man1
- ${INSTALL_DATA} ${WRKSRC}/imwheelrc ${PREFIX}/etc
+post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${PREFIX}/share/doc/imwheel
${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/EMACS \
diff --git a/x11/imwheel/distinfo b/x11/imwheel/distinfo
index 42a35c2001a5..d6367a96b9ba 100644
--- a/x11/imwheel/distinfo
+++ b/x11/imwheel/distinfo
@@ -1 +1 @@
-MD5 (imwheel-0.9.7.nogpm.tar.gz) = 9c65552620207ea1817b77fd2486d522
+MD5 (imwheel-0.9.9.tar.gz) = 1010dadb54a38a20f7fec430e6e5d262
diff --git a/x11/imwheel/files/patch-Makefile.in b/x11/imwheel/files/patch-Makefile.in
new file mode 100644
index 000000000000..727521c161a0
--- /dev/null
+++ b/x11/imwheel/files/patch-Makefile.in
@@ -0,0 +1,14 @@
+--- Makefile.in.orig Thu Feb 22 09:41:40 2001
++++ Makefile.in Fri Jun 29 01:14:30 2001
+@@ -581,9 +581,9 @@
+ @SUID_TRUE@ progname=$(DESTDIR)$(bindir)/`echo imwheel|sed 's/$(EXEEXT)$$//'|sed '$(transform)'|sed 's/$$/$(EXEEXT)/'` ; \
+ @SUID_TRUE@ chown @suid@ $$progname ; \
+ @SUID_TRUE@ chmod u+s $$progname
+-@SUID_TRUE@ install -m 644 imwheelrc /etc/imwheelrc
++@SUID_TRUE@ $(BSD_INSTALL_DATA) imwheelrc ${PREFIX}/etc/imwheelrc
+ @SUID_FALSE@install-exec-hook:
+-@SUID_FALSE@ install -m 644 imwheelrc /etc/imwheelrc
++@SUID_FALSE@ $(BSD_INSTALL_DATA) imwheelrc ${PREFIX}/etc/imwheelrc
+
+ extras: $(EXTRA_PROGRAMS)
+
diff --git a/x11/imwheel/files/patch-aa b/x11/imwheel/files/patch-aa
deleted file mode 100644
index 244ecccca91c..000000000000
--- a/x11/imwheel/files/patch-aa
+++ /dev/null
@@ -1,46 +0,0 @@
---- Makefile.orig Wed Feb 2 04:24:39 2000
-+++ Makefile Tue Feb 22 08:49:17 2000
-@@ -5,7 +5,7 @@
-
- .PHONY: jax getopt mdetect
-
--CC=gcc
-+#CC=gcc
-
- ifeq ("$(shell uname -s)","Linux")
- SHELL=/bin/sh
-@@ -19,17 +19,17 @@
- endif
- else
- SHELL=/bin/sh
--INCDIRS=-I/usr/X11R6/include -Ijax -Igetopt
--LIBDIRS=-L/usr/X11R6/lib
-+INCDIRS=-I${X11BASE}/include -Ijax -Igetopt
-+LIBDIRS=-L${X11BASE}/lib
- SUBDIRLIBS=jax/libjax.a getopt/libgetopt.a
--SUBDIRS=jax getopt mdetect
-+SUBDIRS=jax getopt
- LIBS=-lX11 -lXext -lXtst -lXmu
- GPM=
- endif
-
- #FLAGS=-g -DDEBUG -Wall
- #FLAGS=-g -pg
--FLAGS=-O6 -s -Wall
-+FLAGS=-Wall -DIMWHEELRC="\"${PREFIX}/etc/imwheelrc\""
- INSTALLDIR=/usr/local/bin
- # No spaces are allowd before or after the PIDDIR directory
- #PIDDIR=/var/run#NOTE : this is great for root users... but regular users
-@@ -38,9 +38,9 @@
- # another setuid root program in your install base.
- PIDDIR=/tmp#NOTE : This has been voted by a large majority to be the best
- # place for this file. for the good of all users.
--CFLAGS=$(FLAGS) $(INCDIRS) -DPIDDIR="\"$(PIDDIR)\"" -DVERSION="\"$(VERSION)\""
--LDFLAGS=$(FLAGS) $(LIBDIRS) $(LIBS)
--PROGS= imwheel $(GPM) mdump setimps2 getmdt setmmplus setps2
-+CFLAGS+=$(FLAGS) $(INCDIRS) -DPIDDIR="\"$(PIDDIR)\"" -DVERSION="\"$(VERSION)\""
-+LDFLAGS+=$(FLAGS) $(LIBDIRS) $(LIBS)
-+PROGS= imwheel
-
- all: $(SUBDIRS) $(PROGS)
-
diff --git a/x11/imwheel/files/patch-ab b/x11/imwheel/files/patch-ab
index 26b8fc13bce8..8371ae29bd1b 100644
--- a/x11/imwheel/files/patch-ab
+++ b/x11/imwheel/files/patch-ab
@@ -5,7 +5,7 @@
struct WinAction *getRC()
{
- char fname[2][1024]={"","/etc/imwheelrc"}, line[1024], *p, *q, winid[1024];
-+ char fname[2][1024]={"",IMWHEELRC}, line[1024], *p, *q, winid[1024];
++ char fname[2][1024]={"","%%PREFIX%%/etc/imwheelrc"}, line[1024], *p, *q, winid[1024];
int fi,i;
struct WinAction *newwa=NULL;
FILE *f=NULL;
diff --git a/x11/imwheel/files/patch-ac b/x11/imwheel/files/patch-ac
deleted file mode 100644
index 60b99d4fbfc0..000000000000
--- a/x11/imwheel/files/patch-ac
+++ /dev/null
@@ -1,20 +0,0 @@
---- getopt/Makefile.orig Tue Feb 22 08:32:25 2000
-+++ getopt/Makefile Tue Feb 22 08:33:19 2000
-@@ -1,12 +1,12 @@
- # GetOpt Makefile
-
--CC=gcc
-+#CC=gcc
- #FLAGS=-g -DDEBUG -Wall
- #FLAGS=-g -pg
--FLAGS=-O6 -s -Wall
--CFLAGS=$(FLAGS)
--LDFLAGS=$(FLAGS)
--SHELL=`which bash`
-+FLAGS=-Wall
-+CFLAGS+=$(FLAGS)
-+LDFLAGS+=$(FLAGS)
-+SHELL=`which sh`
- LIB=libgetopt.a
- OBJS=getopt.o getopt1.o
- RANLIB=ranlib
diff --git a/x11/imwheel/files/patch-ad b/x11/imwheel/files/patch-ad
deleted file mode 100644
index e5e039f35b09..000000000000
--- a/x11/imwheel/files/patch-ad
+++ /dev/null
@@ -1,20 +0,0 @@
---- jax/Makefile.orig Tue Feb 22 08:33:53 2000
-+++ jax/Makefile Tue Feb 22 08:35:02 2000
-@@ -1,13 +1,13 @@
--CC=gcc -O -s
-+#CC=gcc -O -s
- #CC=gcc -g
--INC=-I/usr/X11R6/include
--LIB=-L/usr/X11R6/lib
-+INC=-I${X11BASE}/include
-+LIB=-L${X11BASE}/lib
- ARCHIVE=*.c *.h Makefile *.1 *.man
-
- all: libjax.a
-
- jax.o : jax.c jax.h
-- $(CC) -c jax.c $(INC)
-+ $(CC) $(CFLAGS) -c jax.c $(INC)
-
- libjax.a: jax.o
- rm -f libjax.a
diff --git a/x11/imwheel/files/patch-ae b/x11/imwheel/files/patch-ae
index 2f375e995d79..12d9a4bb4f8d 100644
--- a/x11/imwheel/files/patch-ae
+++ b/x11/imwheel/files/patch-ae
@@ -5,7 +5,7 @@
.LP
.SH "IMWHEELRC"
-IMWheel uses, optionally, two configuration files. One called /etc/imwheelrc,
-+IMWheel uses, optionally, two configuration files. One called %%X11BASE%%/etc/imwheelrc,
++IMWheel uses, optionally, two configuration files. One called %%PREFIX%%/etc/imwheelrc,
which is used for everybody. The other is $HOME/.imwheelrc, used only for one
user. One is supplied and should have been installed automatically in /etc
if not also in the installing users $HOME as well. All whitespace is ignored
@@ -14,7 +14,7 @@
The users configuration file.
-/etc/.imwheelrc
-+%%X11BASE%%/etc/imwheelrc
++%%PREFIX%%/etc/imwheelrc
The global location for the configuration
file, it is always loaded. Overided by
the users configuration file.
diff --git a/x11/imwheel/files/patch-af b/x11/imwheel/files/patch-af
index bc9e2b1d26cb..8aa449a9517e 100644
--- a/x11/imwheel/files/patch-af
+++ b/x11/imwheel/files/patch-af
@@ -15,10 +15,10 @@
None, Down, Shift_L|Page_Down
"^rxvt"
--Alt_L, Up, Alt_L|Page_Up
--Alt_L, Down, Alt_L|Page_Down
-+None, Up, Alt_L|Page_Up
-+None, Down, Alt_L|Page_Down
+-Alt_L, Up, Shift_L|Page_Up
+-Alt_L, Down, Shift_L|Page_Down
++None, Up, Shift_L|Page_Up
++None, Down, Shift_L|Page_Down
"^XTerm"
-Alt_L, Up, Shift_R|Page_Up
diff --git a/x11/imwheel/files/patch-getopt::Makefile.in b/x11/imwheel/files/patch-getopt::Makefile.in
new file mode 100644
index 000000000000..3a65236b63de
--- /dev/null
+++ b/x11/imwheel/files/patch-getopt::Makefile.in
@@ -0,0 +1,11 @@
+--- getopt/Makefile.in.orig Thu Feb 22 08:41:45 2001
++++ getopt/Makefile.in
+@@ -79,7 +79,7 @@
+ mdump_dist = @mdump_dist@
+ suid = @suid@
+
+-CFLAGS = -O6 -s -Wall
++#CFLAGS = -O6 -s -Wall
+ noinst_LIBRARIES = libgetopt.a
+ libgetopt_a_SOURCES = getopt.c getopt1.c getopt.h
+
diff --git a/x11/imwheel/files/patch-getopt::getopt.c b/x11/imwheel/files/patch-getopt::getopt.c
new file mode 100644
index 000000000000..47198b724f93
--- /dev/null
+++ b/x11/imwheel/files/patch-getopt::getopt.c
@@ -0,0 +1,16 @@
+--- getopt/getopt.c.orig Tue Apr 6 05:22:57 1999
++++ getopt/getopt.c Fri Jun 29 01:22:22 2001
+@@ -166,11 +166,12 @@
+ /* Value of POSIXLY_CORRECT environment variable. */
+ static char *posixly_correct;
+
+-#ifdef __GNU_LIBRARY__
++#if defined(__GNU_LIBRARY__) || defined(__FreeBSD__)
+ /* We want to avoid inclusion of string.h with non-GNU libraries
+ because there are many ways it can cause trouble.
+ On some systems, it contains special magic macros that don't work
+ in GCC. */
++#include <stdlib.h>
+ #include <string.h>
+ #define my_index strchr
+ #else
diff --git a/x11/imwheel/pkg-descr b/x11/imwheel/pkg-descr
index 870c48a9368b..21b8b66f5d97 100644
--- a/x11/imwheel/pkg-descr
+++ b/x11/imwheel/pkg-descr
@@ -1,18 +1,7 @@
-From the README:
+IMWheel translates mouse wheel activity into keycodes for X11 applications,
+using a configuration file that allows per-user translation preferences.
- This is a not so short little ditty that does the simple conversion of mouse
- button presses into key presses. By grabbing only the 4th and 5th mouse
- buttons the program is able to receive input from the Intellimouse series
- mice. The wheel button can always be used as middle button, this program
- does not affect how the XServer reacts towards it. A mouse with a wheel
- button is a 3 button mouse, and should be configured as such!
+For more information on setting up your wheeled mouse to work with X, see
+either the imwheel man page or the FreeBSD FAQ.
-Note that other wheeled mice such as the Logitech MouseMan+ or TrackMan+ are
-Intellimouse compatible and can be used with this as well. For more
-information on setting up your wheeled mouse to work with X, see either the
-imwheel man page or the FAQ.
-
-WWW: http://jcatki.dhs.org/imwheel/
-
-- John
-jhb@FreeBSD.org
+WWW: http://jonatkins.org/imwheel/
diff --git a/x11/imwheel/pkg-plist.nodocs b/x11/imwheel/pkg-plist.nodocs
deleted file mode 100644
index 976567f01910..000000000000
--- a/x11/imwheel/pkg-plist.nodocs
+++ /dev/null
@@ -1,2 +0,0 @@
-bin/imwheel
-etc/imwheelrc