aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/linux-musicipserver/Makefile16
-rw-r--r--audio/osd-lyrics/Makefile21
2 files changed, 16 insertions, 21 deletions
diff --git a/audio/linux-musicipserver/Makefile b/audio/linux-musicipserver/Makefile
index 7c0ff55cf1d0..6c940ec61c4d 100644
--- a/audio/linux-musicipserver/Makefile
+++ b/audio/linux-musicipserver/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: musicipserver
-# Date created: 2009-03-24
-# Whom: Christopher Key <cjk32@cam.ac.uk>
-#
+# Created by: Christopher Key <cjk32@cam.ac.uk>
# $FreeBSD$
-#
PORTNAME= musicipserver
PORTVERSION= 1.8
@@ -30,7 +26,9 @@ RUN_DEPENDS= empty:${PORTSDIR}/net/empty \
LICENSE_DISTFILES= ${DISTNAME}.tgz
-OPTIONS= SPICEFLY_SKIN "Install Spicefly skin" on
+OPTIONS_DEFINE= SPICEFLY_SKIN
+OPTIONS_DEFAULT= SPICEFLY_SKIN
+OPTIONS_DESC= Install Spicefly skin
WRKSRC= ${WRKDIR}/MusicIP/MusicMagicMixer/
@@ -59,12 +57,12 @@ PLIST_SUB= MUSICIPSERVERDBDIR=${MUSICIPSERVERDBDIR} \
.include <bsd.port.options.mk>
-.if defined(WITH_SPICEFLY_SKIN) && !defined(WITHOUT_SPICEFLY_SKIN)
+.if ${PORT_OPTIONS:MSPICEFLY_SKIN}
EXTRACT_DEPENDS+= unzip:${PORTSDIR}/archivers/unzip
DISTFILES+= index-1.1.zip:spicefly
.endif
-.if defined(WITH_SPICEFLY_SKIN) && !defined(WITHOUT_SPICEFLY_SKIN)
+.if ${PORT_OPTIONS:MSPICEFLY_SKIN}
post-extract:
@cd ${WRKDIR} && ${UNZIP_CMD} -qo ${_DISTDIR}/index-1.1.zip -d ${WRKDIR}/spicefly
.endif
@@ -76,7 +74,7 @@ do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/MusicMagicServer ${PREFIX}/bin
@${MKDIR} ${DATADIR}
@${LN} -fhs ${LOCALBASE}/libexec/mipcore ${DATADIR}/mipcore
-.if defined(WITH_SPICEFLY_SKIN) && !defined(WITHOUT_SPICEFLY_SKIN)
+.if ${PORT_OPTIONS:MSPICEFLY_SKIN}
@${MKDIR} ${DATADIR}/server
@${INSTALL_DATA} ${WRKDIR}/spicefly/index.html ${DATADIR}/server
.else
diff --git a/audio/osd-lyrics/Makefile b/audio/osd-lyrics/Makefile
index 7782f4e2184b..481ba4e31cd4 100644
--- a/audio/osd-lyrics/Makefile
+++ b/audio/osd-lyrics/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: OSD Lyrics
-# Date created: 18 Nov 2011
-# Whom: Alexey Dokuchaev <danfe@FreeBSD.org>
-#
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= osdlyrics
PORTVERSION= 0.4.3
@@ -32,30 +28,31 @@ USE_SQLITE= yes
INSTALLS_ICONS= yes
PORTDOCS= AUTHORS ChangeLog NEWS README
-OPTIONS= MPD "Enable MPD support" off \
- XMMS2 "Enable XMMS2 support" off \
- AMAROK "Enable Amarok 1.4 support" off
+OPTIONS_DEFINE= DOCS MPD XMMS2 AMAROK
+MPD_DESC= Enable MPD support
+XMMS2_DESC= Enable XMMS2 support
+AMAROK_DESC= Enable Amarok 1.4 support
.include <bsd.port.options.mk>
-.if defined(WITH_MPD)
+.if ${PORT_OPTIONS:MMPD}
LIB_DEPENDS+= mpd:${PORTSDIR}/audio/libmpd
.else
CONFIGURE_ARGS+= --disable-mpd
.endif
-.if defined(WITH_XMMS2)
+.if ${PORT_OPTIONS:MXMMS2}
LIB_DEPENDS+= xmmsclient:${PORTSDIR}/audio/xmms2
.else
CONFIGURE_ARGS+= --disable-xmms2
.endif
-.if defined(WITH_AMAROK)
+.if ${PORT_OPTIONS:MAMAROK}
CONFIGURE_ARGS+= --enable-amarok1
.endif
post-install:
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${DOCSDIR}
.endif