aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-mgmt/Makefile1
-rw-r--r--net-mgmt/netwag/Makefile41
-rw-r--r--net-mgmt/netwag/distinfo4
-rw-r--r--net-mgmt/netwag/files/patch-config.dat14
-rw-r--r--net-mgmt/netwag/pkg-descr9
-rw-r--r--net-mgmt/netwag/pkg-plist17
6 files changed, 86 insertions, 0 deletions
diff --git a/net-mgmt/Makefile b/net-mgmt/Makefile
index dfa35138756f..764bd682133d 100644
--- a/net-mgmt/Makefile
+++ b/net-mgmt/Makefile
@@ -86,6 +86,7 @@
SUBDIR += netsaint-plugins
SUBDIR += netspoc
SUBDIR += netustad
+ SUBDIR += netwag
SUBDIR += netwox
SUBDIR += nitpicker
SUBDIR += nocol
diff --git a/net-mgmt/netwag/Makefile b/net-mgmt/netwag/Makefile
new file mode 100644
index 000000000000..8e56a94e45c1
--- /dev/null
+++ b/net-mgmt/netwag/Makefile
@@ -0,0 +1,41 @@
+# New ports collection makefile for: netwag
+# Date created: 11.08.2004
+# Whom: janos.mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= netwag
+PORTVERSION= 5.21.0
+CATEGORIES= net-mgmt ipv6
+MASTER_SITES= http://www.laurentconstantin.com/common/netw/${PORTNAME}/download/v5/ \
+ http://membres.lycos.fr/lauconstantin/common/netw/${PORTNAME}/download/v5/ \
+ http://laurentconstantin.free.fr/common/netw/${PORTNAME}/download/v5/
+DISTFILES= ${PORTNAME}-${PORTVERSION}-src.tgz ${PORTNAME}-${PORTVERSION}-doc_html.tgz
+
+MAINTAINER= janos.mohacsi@bsd.hu
+COMMENT= A graphical front end for netwox
+
+BUILD_DEPENDS= netwox:${PORTSDIR}/net-mgmt/netwox \
+ wish8.4:${PORTSDIR}/x11-toolkits/tk84
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-src/src
+USE_REINPLACE= yes
+SHORTPORTVERSION=${PORTVERSION:C/([0-9]*)\.([0-9]*)\.[0-9]*/\1\2/}
+MAN1= ${PORTNAME}.1 ${PORTNAME}${SHORTPORTVERSION}.1
+
+PLIST_SUB+= SHORTPORTVERSION=${SHORTPORTVERSION}
+
+do-configure:
+ @${REINPLACE_CMD} -e 's|%%PREFIX%%|${PREFIX}|' \
+ ${WRKSRC}/config.dat
+ cd ${WRKSRC}; ${SH} ./genemake
+
+post-install:
+.ifndef(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ @${CP} -R ${WRKSRC}/../../${PORTNAME}-${PORTVERSION}-doc_html/* ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net-mgmt/netwag/distinfo b/net-mgmt/netwag/distinfo
new file mode 100644
index 000000000000..845093bd87c1
--- /dev/null
+++ b/net-mgmt/netwag/distinfo
@@ -0,0 +1,4 @@
+MD5 (netwag-5.21.0-src.tgz) = 501a6ba5e87534f9ba397ecc00c4284b
+SIZE (netwag-5.21.0-src.tgz) = 72234
+MD5 (netwag-5.21.0-doc_html.tgz) = cf29690753be32bfaa413becc27a387f
+SIZE (netwag-5.21.0-doc_html.tgz) = 45497
diff --git a/net-mgmt/netwag/files/patch-config.dat b/net-mgmt/netwag/files/patch-config.dat
new file mode 100644
index 000000000000..c9215c7e7b89
--- /dev/null
+++ b/net-mgmt/netwag/files/patch-config.dat
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- config.dat.orig Wed Aug 11 17:49:39 2004
++++ config.dat Wed Aug 11 17:49:54 2004
+@@ -4,7 +4,7 @@
+
+ ##########################################################################
+ ### installation prefix directory of netwib [should not need to be modified]
+-NETWIBDEF_INSTPREFIX=/usr/local
++NETWIBDEF_INSTPREFIX=%%PREFIX%%
+
+ ##########################################################################
+ ### installation destination directory [should not need to be modified]
diff --git a/net-mgmt/netwag/pkg-descr b/net-mgmt/netwag/pkg-descr
new file mode 100644
index 000000000000..882fc7be5769
--- /dev/null
+++ b/net-mgmt/netwag/pkg-descr
@@ -0,0 +1,9 @@
+Netwag is a graphical front end for netwox.
+
+Netwag permits to easily :
+ - search amongst tools proposed in netwox
+ - construct command line
+ - run tools
+ - keep an history of commands
+
+WWW: http://www.laurentconstantin.com/en/netw/netwox/
diff --git a/net-mgmt/netwag/pkg-plist b/net-mgmt/netwag/pkg-plist
new file mode 100644
index 000000000000..70c9a57ee19f
--- /dev/null
+++ b/net-mgmt/netwag/pkg-plist
@@ -0,0 +1,17 @@
+bin/netwag%%SHORTPORTVERSION%%
+bin/netwag
+%%PORTDOCS%%%%DOCSDIR%%/html/lessons.html
+%%PORTDOCS%%%%DOCSDIR%%/images/banner_netwag.jpg
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/txt/installbin.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/installsrcunix.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/presentation.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/probleminstallbin.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/probleminstallunix.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/problemreport.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/problemusagebin.txt
+%%PORTDOCS%%%%DOCSDIR%%/txt/problemusageunix.txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/txt
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%