aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/p5-Text-Emoticon-GoogleTalk/Makefile28
-rw-r--r--textproc/p5-Text-Emoticon-GoogleTalk/distinfo3
-rw-r--r--textproc/p5-Text-Emoticon-GoogleTalk/pkg-descr5
-rw-r--r--textproc/p5-Text-Emoticon-GoogleTalk/pkg-plist7
5 files changed, 44 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index b988db02d5b1..7ed3e7aad96a 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -478,6 +478,7 @@
SUBDIR += p5-Text-Diff3
SUBDIR += p5-Text-DoubleMetaphone
SUBDIR += p5-Text-Emoticon
+ SUBDIR += p5-Text-Emoticon-GoogleTalk
SUBDIR += p5-Text-EtText
SUBDIR += p5-Text-ExtractWords
SUBDIR += p5-Text-FillIn
diff --git a/textproc/p5-Text-Emoticon-GoogleTalk/Makefile b/textproc/p5-Text-Emoticon-GoogleTalk/Makefile
new file mode 100644
index 000000000000..c199d7539f87
--- /dev/null
+++ b/textproc/p5-Text-Emoticon-GoogleTalk/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: Text-Emoticon-GoogleTalk
+# Date created: 2006/07/21
+# Whom: chinsan <chinsan.tw@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Text-Emoticon-GoogleTalk
+PORTVERSION= 0.01
+CATEGORIES= textproc perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Text
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan.tw@gmail.com
+COMMENT= Emoticon filter of GoogleTalk
+
+PERL_CONFIGURE= yes
+
+MAN3= Text::Emoticon::GoogleTalk.3
+
+.include <bsd.port.pre.mk>
+
+.if ${PERL_LEVEL} < 500600
+IGNORE= requires perl 5.6.0 or later. Install lang/perl5.8 then try again
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/p5-Text-Emoticon-GoogleTalk/distinfo b/textproc/p5-Text-Emoticon-GoogleTalk/distinfo
new file mode 100644
index 000000000000..ae6afb022ac6
--- /dev/null
+++ b/textproc/p5-Text-Emoticon-GoogleTalk/distinfo
@@ -0,0 +1,3 @@
+MD5 (Text-Emoticon-GoogleTalk-0.01.tar.gz) = e3336970e95dedc675394c1fda090335
+SHA256 (Text-Emoticon-GoogleTalk-0.01.tar.gz) = c1c6afccb1eae6514178559abac48c5b705dec6dc960684e9e537fd03225955b
+SIZE (Text-Emoticon-GoogleTalk-0.01.tar.gz) = 1872
diff --git a/textproc/p5-Text-Emoticon-GoogleTalk/pkg-descr b/textproc/p5-Text-Emoticon-GoogleTalk/pkg-descr
new file mode 100644
index 000000000000..4c9d36a94322
--- /dev/null
+++ b/textproc/p5-Text-Emoticon-GoogleTalk/pkg-descr
@@ -0,0 +1,5 @@
+Text::Emoticon::GoogleTalk is a text filter that replace text emoticons like
+":-)", "<3", etc. with the icons of Google Talk (or Gmail Chat), detailed in
+http://mail.google.com/support/bin/answer.py?answer=34056
+
+WWW: http://search.cpan.org/dist/Text-Emoticon-GoogleTalk/
diff --git a/textproc/p5-Text-Emoticon-GoogleTalk/pkg-plist b/textproc/p5-Text-Emoticon-GoogleTalk/pkg-plist
new file mode 100644
index 000000000000..48a4b377af47
--- /dev/null
+++ b/textproc/p5-Text-Emoticon-GoogleTalk/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Emoticon/GoogleTalk/.packlist
+%%SITE_PERL%%/Text/Emoticon/GoogleTalk.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Emoticon/GoogleTalk
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text/Emoticon
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Text
+@dirrmtry %%SITE_PERL%%/Text/Emoticon
+@dirrmtry %%SITE_PERL%%/Text