aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--databases/pear-DB/Makefile9
-rw-r--r--databases/pear-DBA/Makefile9
-rw-r--r--databases/pear-DBA_Relational/Makefile9
-rw-r--r--databases/pear-DB_DataObject/Makefile18
-rw-r--r--databases/pear-DB_DataObject_FormBuilder/Makefile18
-rw-r--r--databases/pear-DB_Pager/Makefile12
-rw-r--r--databases/pear-DB_QueryTool/Makefile6
-rw-r--r--databases/pear-DB_Sqlite_Tools/Makefile6
-rw-r--r--databases/pear-DB_Table/Makefile22
-rw-r--r--databases/pear-DB_ldap/Makefile6
-rw-r--r--databases/pear-DB_ldap2/Makefile6
-rw-r--r--databases/pear-DoctrineCommon/Makefile6
-rw-r--r--databases/pear-DoctrineDBAL/Makefile29
-rw-r--r--databases/pear-DoctrineORM/Makefile6
-rw-r--r--databases/pear-MDB/Makefile6
-rw-r--r--databases/pear-MDB2/Makefile9
-rw-r--r--databases/pear-MDB2_Driver_mysql/Makefile12
-rw-r--r--databases/pear-MDB2_Driver_mysqli/Makefile12
-rw-r--r--databases/pear-MDB2_Driver_pgsql/Makefile12
-rw-r--r--databases/pear-MDB2_Schema/Makefile12
-rw-r--r--databases/pear-MDB_QueryTool/Makefile6
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_Array/Makefile6
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_CSV/Makefile6
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_DB/Makefile7
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile6
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_DBTable/Makefile6
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_DataObject/Makefile6
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile6
-rw-r--r--databases/pear-Structures_DataGrid_DataSource_PDO/Makefile6
-rw-r--r--databases/pear-XML_Query2XML/Makefile15
30 files changed, 83 insertions, 212 deletions
diff --git a/databases/pear-DB/Makefile b/databases/pear-DB/Makefile
index f17932696bf8..836d316af595 100644
--- a/databases/pear-DB/Makefile
+++ b/databases/pear-DB/Makefile
@@ -10,11 +10,6 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.r/RC/}
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR Database Abstraction Layer
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-DBA/Makefile b/databases/pear-DBA/Makefile
index 58128b3b01d0..7340b6452b69 100644
--- a/databases/pear-DBA/Makefile
+++ b/databases/pear-DBA/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= databases www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Berkely-style database abstraction class
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-DBA_Relational/Makefile b/databases/pear-DBA_Relational/Makefile
index 939f6be81417..c6f6f69ce0d5 100644
--- a/databases/pear-DBA_Relational/Makefile
+++ b/databases/pear-DBA_Relational/Makefile
@@ -8,13 +8,8 @@ CATEGORIES= databases www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= Berkely-style database abstraction class
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-
PORTSCOUT= skipv:0.19
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-DB_DataObject/Makefile b/databases/pear-DB_DataObject/Makefile
index e802c2c230aa..2248db97fdbe 100644
--- a/databases/pear-DB_DataObject/Makefile
+++ b/databases/pear-DB_DataObject/Makefile
@@ -13,24 +13,14 @@ BUILD_DEPENDS= pear-DB>=1.7.0:${PORTSDIR}/databases/pear-DB \
RUN_DEPENDS= pear-DB>=1.7.0:${PORTSDIR}/databases/pear-DB \
pear-Date>=1.4.3:${PORTSDIR}/devel/pear-Date
-LATEST_LINK= pear-${PORTNAME}
+USES= pear
OPTIONS_DEFINE= PEAR_MDB2 PEAR_VALIDATE
PEAR_MDB2_DESC= PEAR::MDB2 support
PEAR_VALIDATE_DESC= PEAR::Validate support
-PEAR_AUTOINSTALL= yes
+PEAR_MDB2_RUN_DEPENDS= pear-MDB2>=2.3.0:${PORTSDIR}/databases/pear-MDB2
+PEAR_VALIDATE_RUN_DEPENDS= pear-Validate>=0.1.1:${PORTSDIR}/devel/pear-Validate
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MPEAR_MDB2}
-RUN_DEPENDS+= pear-MDB2>=2.3.0:${PORTSDIR}/databases/pear-MDB2
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_VALIDATE}
-RUN_DEPENDS+= pear-Validate>=0.1.1:${PORTSDIR}/devel/pear-Validate
-.endif
-
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-DB_DataObject_FormBuilder/Makefile b/databases/pear-DB_DataObject_FormBuilder/Makefile
index af8b58d8232c..bb2b7e0d6aa2 100644
--- a/databases/pear-DB_DataObject_FormBuilder/Makefile
+++ b/databases/pear-DB_DataObject_FormBuilder/Makefile
@@ -10,25 +10,15 @@ COMMENT= Automatically build HTML_QuickForm objects using DB_DataObject
BUILD_DEPENDS= ${PEARDIR}/HTML/QuickForm.php:${PORTSDIR}/devel/pear-HTML_QuickForm \
${PEARDIR}/DB/DataObject.php:${PORTSDIR}/databases/pear-DB_DataObject
-RUN_DEPENDS:= ${PEARDIR}/HTML/QuickForm.php:${PORTSDIR}/devel/pear-HTML_QuickForm \
+RUN_DEPENDS= ${PEARDIR}/HTML/QuickForm.php:${PORTSDIR}/devel/pear-HTML_QuickForm \
${PEARDIR}/DB/DataObject.php:${PORTSDIR}/databases/pear-DB_DataObject
-LATEST_LINK= pear-DB_DataObject_FormBuilder
+USES= pear
OPTIONS_DEFINE= PEAR_DATE PEAR_HTML_TABLE
PEAR_DATE_DESC= PEAR::Date support
PEAR_HTML_TABLE_DESC= PEAR::HTML_Table support
-PEAR_AUTOINSTALL=yes
+PEAR_DATE_RUN_DEPENDS= ${PEARDIR}/Date.php:${PORTSDIR}/devel/pear-Date
+PEAR_HTML_TABLE_RUN_DEPENDS= ${PEARDIR}/HTML/Table.php:${PORTSDIR}/devel/pear-HTML_Table
-.include <bsd.port.options.mk>
-
-.if ${PORT_OPTIONS:MPEAR_DATE}
-RUN_DEPENDS+= ${PEARDIR}/Date.php:${PORTSDIR}/devel/pear-Date
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_HTML_TABLE}
-RUN_DEPENDS+= ${PEARDIR}/HTML/Table.php:${PORTSDIR}/devel/pear-HTML_Table
-.endif
-
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>
diff --git a/databases/pear-DB_Pager/Makefile b/databases/pear-DB_Pager/Makefile
index 027944d2a671..5b4d4cf8bc06 100644
--- a/databases/pear-DB_Pager/Makefile
+++ b/databases/pear-DB_Pager/Makefile
@@ -8,13 +8,9 @@ CATEGORIES= databases www pear
MAINTAINER= toshiya@saitoh.nu
COMMENT= PEAR Database Abstraction Layer
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+RUN_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-DB_QueryTool/Makefile b/databases/pear-DB_QueryTool/Makefile
index 90e3e0df14d3..09dc14fb27a6 100644
--- a/databases/pear-DB_QueryTool/Makefile
+++ b/databases/pear-DB_QueryTool/Makefile
@@ -13,8 +13,6 @@ BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB \
RUN_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB \
${PEARDIR}/Log/null.php:${PORTSDIR}/sysutils/pear-Log
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-DB_Sqlite_Tools/Makefile b/databases/pear-DB_Sqlite_Tools/Makefile
index 0d61468f8595..7264b1c80803 100644
--- a/databases/pear-DB_Sqlite_Tools/Makefile
+++ b/databases/pear-DB_Sqlite_Tools/Makefile
@@ -13,8 +13,6 @@ BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB \
RUN_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB \
${PEARDIR}/Log/null.php:${PORTSDIR}/sysutils/pear-Log
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-DB_Table/Makefile b/databases/pear-DB_Table/Makefile
index 800a7f050f82..23a286156464 100644
--- a/databases/pear-DB_Table/Makefile
+++ b/databases/pear-DB_Table/Makefile
@@ -10,29 +10,15 @@ CATEGORIES= databases www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR object-oriented interface to a database table
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-LATEST_LINK= pear-DB_Table
OPTIONS_DEFINE= PEAR_HTML_QUICKFORM PEAR_DB PEAR_MDB2
PEAR_HTML_QUICKFORM_DESC= PEAR::HTML_QuickForm support
PEAR_DB_DESC= PEAR::DB support
PEAR_MDB2_DESC= PEAR::MDB2 support
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.options.mk>
+PEAR_HTML_QUICKFORM_RUN_DEPENDS= ${PEARDIR}/HTML/QuickForm.php:${PORTSDIR}/devel/pear-HTML_QuickForm
+PEAR_DB_RUN_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+PEAR_MDB2_RUN_DEPENDS= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
-.if ${PORT_OPTIONS:MPEAR_HTML_QUICKFORM}
-RUN_DEPENDS+= ${PEARDIR}/HTML/QuickForm.php:${PORTSDIR}/devel/pear-HTML_QuickForm
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_DB}
-RUN_DEPENDS+= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_MDB2}
-RUN_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
-.endif
-
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>
diff --git a/databases/pear-DB_ldap/Makefile b/databases/pear-DB_ldap/Makefile
index 8834c0f82f36..25d1ac738380 100644
--- a/databases/pear-DB_ldap/Makefile
+++ b/databases/pear-DB_ldap/Makefile
@@ -11,8 +11,6 @@ COMMENT= PEAR DB compliant interface to LDAP servers
BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
RUN_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-DB_ldap2/Makefile b/databases/pear-DB_ldap2/Makefile
index a00bc11560cf..7dbaf8579762 100644
--- a/databases/pear-DB_ldap2/Makefile
+++ b/databases/pear-DB_ldap2/Makefile
@@ -13,8 +13,6 @@ BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
RUN_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
USE_PHP= ldap
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-DoctrineCommon/Makefile b/databases/pear-DoctrineCommon/Makefile
index 55d5e540b5e2..f9cb020a80ab 100644
--- a/databases/pear-DoctrineCommon/Makefile
+++ b/databases/pear-DoctrineCommon/Makefile
@@ -14,9 +14,7 @@ LICENSE= LGPL21
BUILD_DEPENDS= ${PEARDIR}/.channels/pear.doctrine-project.org.reg:${PORTSDIR}/devel/pear-channel-doctrine
RUN_DEPENDS= ${PEARDIR}/.channels/pear.doctrine-project.org.reg:${PORTSDIR}/devel/pear-channel-doctrine
+USES= pear
PEAR_CHANNEL= doctrine
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-DoctrineDBAL/Makefile b/databases/pear-DoctrineDBAL/Makefile
index 86ae696012e6..7246a48d70d0 100644
--- a/databases/pear-DoctrineDBAL/Makefile
+++ b/databases/pear-DoctrineDBAL/Makefile
@@ -26,29 +26,16 @@ ODBC_DESC= Install PHP DBO driver for ODBC
PGSQL_DESC= Install PHP DBO driver for PostgreSQL
SQLITE_DESC= Install PHP DBO driver for SQLite
+USES= pear
PEAR_CHANNEL= doctrine
-PEAR_AUTOINSTALL= yes
USE_PHP= pdo
WANT_PHP_CLI= yes
-.include <bsd.port.pre.mk>
-
-.if ${PORT_OPTIONS:MDBLIB}
-RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_dblib.so:${PORTSDIR}/databases/php${PHP_VER}-pdo_dblib
-.endif
-.if ${PORT_OPTIONS:MMYSQL}
-USE_PHP+= pdo_mysql
-.endif
-.if ${PORT_OPTIONS:MODBC}
-RUN_DEPENDS+= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_odbc.so:${PORTSDIR}/databases/php${PHP_VER}-pdo_odbc
-.endif
-.if ${PORT_OPTIONS:MPGSQL}
-USE_PHP+= pdo_pgsql
-.endif
-.if ${PORT_OPTIONS:MSQLITE}
-USE_PHP+= pdo_sqlite
-.endif
-
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+DBLIB_RUN_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_dblib.so:${PORTSDIR}/databases/php${PHP_VER}-pdo_dblib
+MYSQL_USE= PHP=pdo_mysql
+ODBC_RUN_DEPENDS= ${PHPBASE}/lib/php/${PHP_EXT_DIR}/pdo_odbc.so:${PORTSDIR}/databases/php${PHP_VER}-pdo_odbc
+PGSQL_USE= PHP=pdo_pgsql
+SQLITE_USE= PHP=pdo_sqlite
+
+.include <bsd.port.mk>
diff --git a/databases/pear-DoctrineORM/Makefile b/databases/pear-DoctrineORM/Makefile
index 9efe4d5791f6..21fda593ec2b 100644
--- a/databases/pear-DoctrineORM/Makefile
+++ b/databases/pear-DoctrineORM/Makefile
@@ -18,9 +18,7 @@ RUN_DEPENDS= ${PEARDIR}/.channels/pear.doctrine-project.org.reg:${PORTSDIR}/deve
${PEARDIR}/Symfony/Component/Console/Application.php:${PORTSDIR}/devel/pear-Symfony_Component_Console \
${PEARDIR}/Symfony/Component/Yaml/Yaml.php:${PORTSDIR}/textproc/pear-Symfony_Component_Yaml
+USES= pear
PEAR_CHANNEL= doctrine
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-MDB/Makefile b/databases/pear-MDB/Makefile
index b96e7593d147..414c9f0400e6 100644
--- a/databases/pear-MDB/Makefile
+++ b/databases/pear-MDB/Makefile
@@ -11,8 +11,6 @@ COMMENT= PEAR unified API for DB access, based on user meta data
BUILD_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
RUN_DEPENDS= ${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-MDB2/Makefile b/databases/pear-MDB2/Makefile
index 5d28d96a42d0..7fdd64235210 100644
--- a/databases/pear-MDB2/Makefile
+++ b/databases/pear-MDB2/Makefile
@@ -8,11 +8,6 @@ CATEGORIES= databases www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR database abstraction layer
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
-RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
+USES= pear
-PEAR_AUTOINSTALL= yes
-
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-MDB2_Driver_mysql/Makefile b/databases/pear-MDB2_Driver_mysql/Makefile
index ae292d57fa28..2bac9780b001 100644
--- a/databases/pear-MDB2_Driver_mysql/Makefile
+++ b/databases/pear-MDB2_Driver_mysql/Makefile
@@ -8,14 +8,10 @@ CATEGORIES= databases www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR MySQL MDB2 driver
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
-RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+BUILD_DEPENDS= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+RUN_DEPENDS= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+USES= pear
USE_PHP= mysql
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-MDB2_Driver_mysqli/Makefile b/databases/pear-MDB2_Driver_mysqli/Makefile
index 9ee11c39c5ba..d29a28c9b758 100644
--- a/databases/pear-MDB2_Driver_mysqli/Makefile
+++ b/databases/pear-MDB2_Driver_mysqli/Makefile
@@ -8,14 +8,10 @@ CATEGORIES= databases www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR MySQL MDB2 driver
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
-RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+BUILD_DEPENDS= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+RUN_DEPENDS= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+USES= pear
USE_PHP= mysqli
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-MDB2_Driver_pgsql/Makefile b/databases/pear-MDB2_Driver_pgsql/Makefile
index 5e4bd7cdcb98..ccf1df2cad8b 100644
--- a/databases/pear-MDB2_Driver_pgsql/Makefile
+++ b/databases/pear-MDB2_Driver_pgsql/Makefile
@@ -8,14 +8,10 @@ CATEGORIES= databases www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR pgsql MDB2 driver
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
-RUN_DEPENDS:= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+BUILD_DEPENDS= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+RUN_DEPENDS= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+USES= pear
USE_PHP= pgsql
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-MDB2_Schema/Makefile b/databases/pear-MDB2_Schema/Makefile
index 2330a10f884e..3a4bcec8aaea 100644
--- a/databases/pear-MDB2_Schema/Makefile
+++ b/databases/pear-MDB2_Schema/Makefile
@@ -8,19 +8,15 @@ CATEGORIES= databases www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= PEAR XML based database schema manager
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2 \
+BUILD_DEPENDS= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2 \
${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser \
${PEARDIR}/XML/DTD.php:${PORTSDIR}/textproc/pear-XML_DTD \
${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer
-RUN_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear \
- ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2 \
+RUN_DEPENDS= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2 \
${PEARDIR}/XML/Parser.php:${PORTSDIR}/devel/pear-XML_Parser \
${PEARDIR}/XML/DTD.php:${PORTSDIR}/textproc/pear-XML_DTD \
${PEARDIR}/XML/Serializer.php:${PORTSDIR}/devel/pear-XML_Serializer
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-MDB_QueryTool/Makefile b/databases/pear-MDB_QueryTool/Makefile
index 2cb0d78041b6..632ea7710012 100644
--- a/databases/pear-MDB_QueryTool/Makefile
+++ b/databases/pear-MDB_QueryTool/Makefile
@@ -13,8 +13,6 @@ BUILD_DEPENDS= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB \
RUN_DEPENDS:= ${PEARDIR}/MDB.php:${PORTSDIR}/databases/pear-MDB \
${PEARDIR}/Log/null.php:${PORTSDIR}/sysutils/pear-Log
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-Structures_DataGrid_DataSource_Array/Makefile b/databases/pear-Structures_DataGrid_DataSource_Array/Makefile
index 85abcfbb8b5d..01d40f78c089 100644
--- a/databases/pear-Structures_DataGrid_DataSource_Array/Makefile
+++ b/databases/pear-Structures_DataGrid_DataSource_Array/Makefile
@@ -11,8 +11,6 @@ COMMENT= DataSource driver using arrays
BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structures_DataGrid
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structures_DataGrid
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-Structures_DataGrid_DataSource_CSV/Makefile b/databases/pear-Structures_DataGrid_DataSource_CSV/Makefile
index 5ef36444df5a..ec9134b14d94 100644
--- a/databases/pear-Structures_DataGrid_DataSource_CSV/Makefile
+++ b/databases/pear-Structures_DataGrid_DataSource_CSV/Makefile
@@ -11,8 +11,6 @@ COMMENT= DataSource driver using CSV files
BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid/DataSource/Array.php:${PORTSDIR}/databases/pear-Structures_DataGrid_DataSource_Array
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid/DataSource/Array.php:${PORTSDIR}/databases/pear-Structures_DataGrid_DataSource_Array
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-Structures_DataGrid_DataSource_DB/Makefile b/databases/pear-Structures_DataGrid_DataSource_DB/Makefile
index e7f3b4f8bc3a..c0e31245ba2c 100644
--- a/databases/pear-Structures_DataGrid_DataSource_DB/Makefile
+++ b/databases/pear-Structures_DataGrid_DataSource_DB/Makefile
@@ -8,13 +8,10 @@ CATEGORIES= databases www pear
MAINTAINER= miwi@FreeBSD.org
COMMENT= DB datasource driver for pear-Structures_DataGrid
-BUILD_DEPENDS= ${PEARDIR}/PEAR.php:${PORTSDIR}/devel/pear
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structures_DataGrid \
${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB \
${PEARDIR}/Structures/DataGrid/DataSource/Array.php:${PORTSDIR}/databases/pear-Structures_DataGrid_DataSource_Array
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile b/databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile
index eae087c8702d..c7147b648533 100644
--- a/databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile
+++ b/databases/pear-Structures_DataGrid_DataSource_DBQuery/Makefile
@@ -13,9 +13,7 @@ BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structu
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structures_DataGrid \
${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
+USES= pear
USE_PHP= mysql
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-Structures_DataGrid_DataSource_DBTable/Makefile b/databases/pear-Structures_DataGrid_DataSource_DBTable/Makefile
index b8a18c04695b..6c675db2abd3 100644
--- a/databases/pear-Structures_DataGrid_DataSource_DBTable/Makefile
+++ b/databases/pear-Structures_DataGrid_DataSource_DBTable/Makefile
@@ -13,9 +13,7 @@ BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structu
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structures_DataGrid \
${PEARDIR}/DB/Table.php:${PORTSDIR}/databases/pear-DB_Table
+USES= pear
USE_PHP= mysql
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-Structures_DataGrid_DataSource_DataObject/Makefile b/databases/pear-Structures_DataGrid_DataSource_DataObject/Makefile
index a913cf63c75b..5ee821a68e59 100644
--- a/databases/pear-Structures_DataGrid_DataSource_DataObject/Makefile
+++ b/databases/pear-Structures_DataGrid_DataSource_DataObject/Makefile
@@ -13,9 +13,7 @@ BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structu
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structures_DataGrid \
${PEARDIR}/DB/DataObject.php:${PORTSDIR}/databases/pear-DB_DataObject
+USES= pear
USE_PHP= mysql
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile b/databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile
index 7b4d35223bfb..07bcfcd83607 100644
--- a/databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile
+++ b/databases/pear-Structures_DataGrid_DataSource_MDB2/Makefile
@@ -13,9 +13,7 @@ BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structu
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid.php:${PORTSDIR}/devel/pear-Structures_DataGrid \
${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+USES= pear
USE_PHP= mysql
-PEAR_AUTOINSTALL= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-Structures_DataGrid_DataSource_PDO/Makefile b/databases/pear-Structures_DataGrid_DataSource_PDO/Makefile
index 2d4622df898a..3b654bf5e3e6 100644
--- a/databases/pear-Structures_DataGrid_DataSource_PDO/Makefile
+++ b/databases/pear-Structures_DataGrid_DataSource_PDO/Makefile
@@ -11,8 +11,6 @@ COMMENT= DataSource driver using PHP Data Objects (PDO) and an SQL query
BUILD_DEPENDS= ${PEARDIR}/Structures/DataGrid/DataSource/Array.php:${PORTSDIR}/databases/pear-Structures_DataGrid_DataSource_Array
RUN_DEPENDS= ${PEARDIR}/Structures/DataGrid/DataSource/Array.php:${PORTSDIR}/databases/pear-Structures_DataGrid_DataSource_Array
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/databases/pear-XML_Query2XML/Makefile b/databases/pear-XML_Query2XML/Makefile
index 7f5ab5915f67..63cc8abf1ab6 100644
--- a/databases/pear-XML_Query2XML/Makefile
+++ b/databases/pear-XML_Query2XML/Makefile
@@ -11,22 +11,13 @@ COMMENT= PEAR class transform SQL queries into XML data
BUILD_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
RUN_DEPENDS= ${PEARDIR}/DB.php:${PORTSDIR}/databases/pear-DB
-LATEST_LINK= pear-XML_Query2xml
OPTIONS_DEFINE= PEAR_MDB2 PEAR_NET_LDAP2
PEAR_MDB2_DESC= Add support for pear-MDB2
PEAR_NET_LDAP2_DESC= Add support for pear-Net_LDAP2
-PEAR_AUTOINSTALL= yes
+USES= pear
-.include <bsd.port.options.mk>
+PEAR_MDB2_BUILD_DEPENDS= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
+PEAR_NET_LDAP2_BUILD_DEPENDS= ${PEARDIR}/Net/LDAP2.php:${PORTSDIR}/net/pear-Net_LDAP2
-.if ${PORT_OPTIONS:MPEAR_MDB2}
-BUILD_DEPENDS+= ${PEARDIR}/MDB2.php:${PORTSDIR}/databases/pear-MDB2
-.endif
-
-.if ${PORT_OPTIONS:MPEAR_NET_LDAP2}
-BUILD_DEPENDS+= ${PEARDIR}/Net/LDAP2.php:${PORTSDIR}/net/pear-Net_LDAP2
-.endif
-
-.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
.include <bsd.port.mk>