aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www/dansguardian/Makefile6
-rw-r--r--www/dansguardian/distinfo2
-rw-r--r--www/dansguardian/files/patch-FatController.cpp11
-rw-r--r--www/dansguardian/files/patch-autoconf::fbsd.in68
-rw-r--r--www/dansguardian/pkg-plist6
5 files changed, 44 insertions, 49 deletions
diff --git a/www/dansguardian/Makefile b/www/dansguardian/Makefile
index 01877e33f967..d62e05f6f012 100644
--- a/www/dansguardian/Makefile
+++ b/www/dansguardian/Makefile
@@ -6,17 +6,19 @@
#
PORTNAME= dansguardian
-PORTVERSION= 2.6.1.3
+PORTVERSION= 2.6.1.6
CATEGORIES= www
MASTER_SITES= # empty, see below
DISTNAME= DansGuardian-${PORTVERSION:R}-${PORTVERSION:E}.source
MAINTAINER= fcash@sd73.bc.ca
-COMMENT= A fast, featureful web content filter for Squid proxy servers
+COMMENT= A fast, feature-rich web content filter for Squid proxy servers
RUN_DEPENDS= ${LOCALBASE}/sbin/squid:${PORTSDIR}/www/squid24:install \
${LOCALBASE}/sbin/httpd:${PORTSDIR}/${APACHE_PORT}:install
+CONFLICTS= dansguardian-devel
+
WRKSRC= ${WRKDIR}/DansGuardian-${PORTVERSION:R}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --prefix=${PREFIX} \
diff --git a/www/dansguardian/distinfo b/www/dansguardian/distinfo
index f708cb1f24ac..c01f8979476c 100644
--- a/www/dansguardian/distinfo
+++ b/www/dansguardian/distinfo
@@ -1 +1 @@
-MD5 (DansGuardian-2.6.1-3.source.tar.gz) = 21fa3b79fb66817c95003d320b62a4c1
+MD5 (DansGuardian-2.6.1-6.source.tar.gz) = 9f550a23fd692f3df0850b93dfefaf14
diff --git a/www/dansguardian/files/patch-FatController.cpp b/www/dansguardian/files/patch-FatController.cpp
deleted file mode 100644
index 541096155c69..000000000000
--- a/www/dansguardian/files/patch-FatController.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- FatController.cpp.orig Mon Jul 7 14:59:33 2003
-+++ FatController.cpp Mon Jul 7 14:59:52 2003
-@@ -513,7 +513,7 @@
- if (conn) {
- if (report) {
- if (!isDaemonised) {
-- std::cerr << "Error creating connecting to test proxy" << std::endl;
-+ std::cerr << "Error creating connection to test proxy" << std::endl;
- }
- syslog(LOG_ERR, "%s","Error creating connection to test proxy");
- }
diff --git a/www/dansguardian/files/patch-autoconf::fbsd.in b/www/dansguardian/files/patch-autoconf::fbsd.in
index d2c6f11e1af4..b6057b4bacb0 100644
--- a/www/dansguardian/files/patch-autoconf::fbsd.in
+++ b/www/dansguardian/files/patch-autoconf::fbsd.in
@@ -1,5 +1,5 @@
---- autoconf/fbsd.in.orig Mon Jul 7 02:47:25 2003
-+++ autoconf/fbsd.in Mon Jul 7 14:51:43 2003
+--- autoconf/fbsd.in.orig Wed Nov 19 16:06:41 2003
++++ autoconf/fbsd.in Mon Nov 24 11:14:17 2003
@@ -20,7 +20,7 @@
logrotate.dansguardian
@@ -9,38 +9,17 @@
PASSVARS += -DCONFFILELOCATION=\"${CONFFILELOCATION}dansguardian.conf\"
PASSVARS += -DPIDDIR=\"${PIDDIR}\"
-@@ -37,56 +37,86 @@
- .cpp.o:
- $(CPP) $(DEBUG) $(CFLAGS) -c $<
-
--all: $(OBJ)
-+all: $(OBJ)
+@@ -41,52 +41,83 @@
$(CPP) -o dansguardian $(DGCFLAGS) $(DEBUG) $(OBJ) $(LIBS) dansguardian.cpp
install:
- @test -d $I$(SYSVLOCATION) || install -d $I$(SYSVLOCATION)
- @test -d $I$(CONFFILELOCATION) || install -d $I$(CONFFILELOCATION)
- @test -d $I$(CONFFILELOCATION)phraselists || install -d $I$(CONFFILELOCATION)phraselists
-+ @test -d $I$(CONFFILELOCATION)phraselists/chat || install -d $I$(CONFFILELOCATION)phraselists/chat
-+ @test -d $I$(CONFFILELOCATION)phraselists/drugadvocacy || install -d $I$(CONFFILELOCATION)phraselists/drugadvocacy
-+ @test -d $I$(CONFFILELOCATION)phraselists/dutchbadwords || install -d $I$(CONFFILELOCATION)phraselists/dutchbadwords
-+ @test -d $I$(CONFFILELOCATION)phraselists/frenchbadwords || install -d $I$(CONFFILELOCATION)phraselists/frenchbadwords
-+ @test -d $I$(CONFFILELOCATION)phraselists/gambling || install -d $I$(CONFFILELOCATION)phraselists/gambling
-+ @test -d $I$(CONFFILELOCATION)phraselists/goodphrases || install -d $I$(CONFFILELOCATION)phraselists/goodphrases
-+ @test -d $I$(CONFFILELOCATION)phraselists/gore || install -d $I$(CONFFILELOCATION)phraselists/gore
-+ @test -d $I$(CONFFILELOCATION)phraselists/illegaldrugs || install -d $I$(CONFFILELOCATION)phraselists/illegaldrugs
-+ @test -d $I$(CONFFILELOCATION)phraselists/intolerance || install -d $I$(CONFFILELOCATION)phraselists/intolerance
-+ @test -d $I$(CONFFILELOCATION)phraselists/italianbadwords || install -d $I$(CONFFILELOCATION)phraselists/italianbadwords
-+ @test -d $I$(CONFFILELOCATION)phraselists/legaldrugs || install -d $I$(CONFFILELOCATION)phraselists/legaldrugs
-+ @test -d $I$(CONFFILELOCATION)phraselists/personals || install -d $I$(CONFFILELOCATION)phraselists/personals
-+ @test -d $I$(CONFFILELOCATION)phraselists/pornography || install -d $I$(CONFFILELOCATION)phraselists/pornography
-+ @test -d $I$(CONFFILELOCATION)phraselists/violence || install -d $I$(CONFFILELOCATION)phraselists/violence
-+ @test -d $I$(CONFFILELOCATION)phraselists/warezhacking || install -d $I$(CONFFILELOCATION)phraselists/warezhacking
-+ @test -d $I$(CONFFILELOCATION)phraselists/weapons || install -d $I$(CONFFILELOCATION)phraselists/weapons
- @test -d $I$(CGIBINLOCATION) || install -d $I$(CGIBINLOCATION)
- @test -d $I$(MANUALFILES)man8/ || install -d $I$(MANUALFILES)man8/
- @test -d $I$(LOGLOCATION) || install -d $I$(LOGLOCATION)
-- @test -d $I$(BINARYLOCATION) || /usr/sbin/install -d $I$(BINARYLOCATION)
+- @test -d $I$(SYSVLOCATION) || install -d $I$(SYSVLOCATION)
+- @test -d $I$(CONFFILELOCATION) || install -d $I$(CONFFILELOCATION)
+- @test -d $I$(CONFFILELOCATION)phraselists || install -d $I$(CONFFILELOCATION)phraselists
+- @test -d $I$(CGIBINLOCATION) || install -d $I$(CGIBINLOCATION)
+- @test -d $I$(MANUALFILES)man8/ || install -d $I$(MANUALFILES)man8/
+- @test -d $I$(LOGLOCATION) || install -d $I$(LOGLOCATION)
+- @test -d $I$(BINARYLOCATION) || install -d $I$(BINARYLOCATION)
- cp -f ./dansguardian $I$(BINARYLOCATION)dansguardian
- cp -f ./dansguardian.conf $I$(CONFFILELOCATION)dansguardian.conf
- cp -f ./bannedphraselist $I$(CONFFILELOCATION)bannedphraselist
@@ -71,7 +50,29 @@
- chmod -R u+wr $I$(LOGLOCATION)
- chmod u+wrx $I$(LOGLOCATION)
- if [ -d $(LOGROTATELOCATION) ]; then cp -f ./logrotate.dansguardian $I$(LOGROTATELOCATION)dansguardian; fi
-+ @test -d $I$(BINARYLOCATION) || install -d $I$(BINARYLOCATION)
++ install -d $I$(CONFFILELOCATION)
++ install -d $I$(CONFFILELOCATION)phraselists
++ install -d $I$(CONFFILELOCATION)phraselists/chat
++ install -d $I$(CONFFILELOCATION)phraselists/drugadvocacy
++ install -d $I$(CONFFILELOCATION)phraselists/dutchbadwords
++ install -d $I$(CONFFILELOCATION)phraselists/frenchbadwords
++ install -d $I$(CONFFILELOCATION)phraselists/gambling
++ install -d $I$(CONFFILELOCATION)phraselists/germanpornography
++ install -d $I$(CONFFILELOCATION)phraselists/goodphrases
++ install -d $I$(CONFFILELOCATION)phraselists/gore
++ install -d $I$(CONFFILELOCATION)phraselists/illegaldrugs
++ install -d $I$(CONFFILELOCATION)phraselists/intolerance
++ install -d $I$(CONFFILELOCATION)phraselists/italianbadwords
++ install -d $I$(CONFFILELOCATION)phraselists/legaldrugs
++ install -d $I$(CONFFILELOCATION)phraselists/personals
++ install -d $I$(CONFFILELOCATION)phraselists/pornography
++ install -d $I$(CONFFILELOCATION)phraselists/violence
++ install -d $I$(CONFFILELOCATION)phraselists/warezhacking
++ install -d $I$(CONFFILELOCATION)phraselists/weapons
++ install -d $I$(CGIBINLOCATION)
++ install -d $I$(MANUALFILES)man8/
++ install -d $I$(LOGLOCATION)
++ install -d $I$(BINARYLOCATION)
+ install -o root -g wheel -m 755 ./dansguardian $I$(BINARYLOCATION)dansguardian
+ install -o root -g wheel -m 644 ./dansguardian.conf $I$(CONFFILELOCATION)dansguardian.conf
+ install -o root -g wheel -m 644 ./bannedphraselist $I$(CONFFILELOCATION)bannedphraselist
@@ -83,6 +84,7 @@
+ install -o root -g wheel -m 644 ./phraselists/frenchbadwords/weighted $I$(CONFFILELOCATION)phraselists/frenchbadwords/weighted
+ install -o root -g wheel -m 644 ./phraselists/gambling/banned $I$(CONFFILELOCATION)phraselists/gambling/banned
+ install -o root -g wheel -m 644 ./phraselists/gambling/weighted $I$(CONFFILELOCATION)phraselists/gambling/weighted
++ install -o root -g wheel -m 644 ./phraselists/germanpornography/weighted $I$(CONFFILELOCATION)phraselists/germanpornography/weighted
+ install -o root -g wheel -m 644 ./phraselists/goodphrases/exception $I$(CONFFILELOCATION)phraselists/goodphrases/exception
+ install -o root -g wheel -m 644 ./phraselists/goodphrases/weighted $I$(CONFFILELOCATION)phraselists/goodphrases/weighted
+ install -o root -g wheel -m 644 ./phraselists/gore/weighted $I$(CONFFILELOCATION)phraselists/gore/weighted
@@ -127,7 +129,7 @@
rm -fr $(CONFFILELOCATION)
- rm -fr $(LOGLOCATION)
- if [ -f $(LOGROTATELOCATION)dansguardian ]; then rm -f $(LOGROTATELOCATION)dansguardian; fi
-+ rm -f $(LOGLOCATION)/dansguardian.log
++ rm -fr $(LOGLOCATION)dansguardian.log
clean:
rm -f $(OBJ) $(PROG)
diff --git a/www/dansguardian/pkg-plist b/www/dansguardian/pkg-plist
index bac50fba3c09..948bfb7fb59f 100644
--- a/www/dansguardian/pkg-plist
+++ b/www/dansguardian/pkg-plist
@@ -5,6 +5,7 @@
@exec mkdir -p etc/dansguardian/phraselists/dutchbadwords
@exec mkdir -p etc/dansguardian/phraselists/frenchbadwords
@exec mkdir -p etc/dansguardian/phraselists/gambling
+@exec mkdir -p etc/dansguardian/phraselists/germanpornography
@exec mkdir -p etc/dansguardian/phraselists/goodphrases
@exec mkdir -p etc/dansguardian/phraselists/gore
@exec mkdir -p etc/dansguardian/phraselists/illegaldrugs
@@ -28,9 +29,9 @@ etc/dansguardian/contentregexplist
etc/dansguardian/dansguardian.conf
etc/dansguardian/exceptioniplist
etc/dansguardian/exceptionphraselist
+etc/dansguardian/exceptionsitelist
etc/dansguardian/exceptionurllist
etc/dansguardian/exceptionuserlist
-etc/dansguardian/exceptionsitelist
etc/dansguardian/messages
etc/dansguardian/phraselists/chat/weighted
etc/dansguardian/phraselists/drugadvocacy/weighted
@@ -38,6 +39,7 @@ etc/dansguardian/phraselists/dutchbadwords/weighted
etc/dansguardian/phraselists/frenchbadwords/weighted
etc/dansguardian/phraselists/gambling/banned
etc/dansguardian/phraselists/gambling/weighted
+etc/dansguardian/phraselists/germanpornography/weighted
etc/dansguardian/phraselists/goodphrases/exception
etc/dansguardian/phraselists/goodphrases/weighted
etc/dansguardian/phraselists/gore/weighted
@@ -64,6 +66,7 @@ www/cgi-bin/dansguardian.pl
@dirrm etc/dansguardian/phraselists/dutchbadwords
@dirrm etc/dansguardian/phraselists/frenchbadwords
@dirrm etc/dansguardian/phraselists/gambling
+@dirrm etc/dansguardian/phraselists/germanpornography
@dirrm etc/dansguardian/phraselists/goodphrases
@dirrm etc/dansguardian/phraselists/gore
@dirrm etc/dansguardian/phraselists/illegaldrugs
@@ -78,4 +81,3 @@ www/cgi-bin/dansguardian.pl
@dirrm etc/dansguardian/phraselists
@dirrm etc/dansguardian
@unexec echo If permanently deleting this package, /var/log/dansguardian.log must be removed manually
-