aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/tulip/Makefile8
-rw-r--r--graphics/tulip/pkg-plist1
2 files changed, 6 insertions, 3 deletions
diff --git a/graphics/tulip/Makefile b/graphics/tulip/Makefile
index d4c9a61712b1..1442f28e18fc 100644
--- a/graphics/tulip/Makefile
+++ b/graphics/tulip/Makefile
@@ -18,8 +18,6 @@ COMMENT= A system dedicated to the visualization of huge graphs
LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
-BROKEN= Incorrect pkg-plist (does not compile completely?)
-
USE_BZIP2= yes
USE_QT_VER= 3
QT_NONSTANDARD= yes
@@ -32,6 +30,12 @@ CONFIGURE_ENV= MOC="${MOC}" CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --with-qt-includes=${QT_PREFIX}/include \
--with-qt-libraries=${QT_PREFIX}/lib \
--with-extra-libs=${LOCALBASE}/lib
+# libOSMesa, installed by the xorg-libraries-6.9.0 port is causing
+# /usr/X11R6/lib/libOSMesa.so: undefined reference to `driDispatchRemapTable'
+# during the configure step which results in tlprender not being build.
+# So we remove it from pkg-plist and disable it here to make sure it does not
+# get build somehow, causing plist problems
+CONFIGURE_ARGS+= --disable-tlprender
INSTALLS_SHLIB= yes
CPPFLAGS= -I${LOCALBASE}/include -I${PREFIX}/include \
diff --git a/graphics/tulip/pkg-plist b/graphics/tulip/pkg-plist
index 432d35b1ae0b..984f95f02c03 100644
--- a/graphics/tulip/pkg-plist
+++ b/graphics/tulip/pkg-plist
@@ -1,5 +1,4 @@
bin/Tulip
-bin/tlprender
bin/tulip-config
include/tulip/Array.h
include/tulip/Bezier.h