aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/postfix/files/extra-libspf2_and_tls.patch18
-rw-r--r--mail/postfix/scripts/configure.postfix5
-rw-r--r--mail/postfix21/files/extra-libspf2_and_tls.patch18
-rw-r--r--mail/postfix21/scripts/configure.postfix5
-rw-r--r--mail/postfix22/files/extra-libspf2_and_tls.patch18
-rw-r--r--mail/postfix22/scripts/configure.postfix5
-rw-r--r--mail/postfix23/files/extra-libspf2_and_tls.patch18
-rw-r--r--mail/postfix23/scripts/configure.postfix5
-rw-r--r--mail/postfix24/files/extra-libspf2_and_tls.patch18
-rw-r--r--mail/postfix24/scripts/configure.postfix5
-rw-r--r--mail/postfix25/files/extra-libspf2_and_tls.patch18
-rw-r--r--mail/postfix25/scripts/configure.postfix5
-rw-r--r--mail/postfix26/files/extra-libspf2_and_tls.patch18
-rw-r--r--mail/postfix26/scripts/configure.postfix5
-rw-r--r--mail/postfix27/files/extra-libspf2_and_tls.patch18
-rw-r--r--mail/postfix27/scripts/configure.postfix5
-rw-r--r--mail/postfix28/files/extra-libspf2_and_tls.patch18
-rw-r--r--mail/postfix28/scripts/configure.postfix5
18 files changed, 198 insertions, 9 deletions
diff --git a/mail/postfix/files/extra-libspf2_and_tls.patch b/mail/postfix/files/extra-libspf2_and_tls.patch
new file mode 100644
index 000000000000..7753bc77e84c
--- /dev/null
+++ b/mail/postfix/files/extra-libspf2_and_tls.patch
@@ -0,0 +1,18 @@
+--- postfix-2.1.5/src/smtpd/smtpd.c.orig Sat Oct 16 21:44:03 2004
++++ postfix-2.1.5/src/smtpd/smtpd.c Sat Oct 16 21:44:13 2004
+@@ -2749,12 +2749,12 @@
+ VAR_ALLOW_UNTRUST_ROUTE, DEF_ALLOW_UNTRUST_ROUTE, &var_allow_untrust_route,
+ VAR_SMTPD_SASL_ENABLE, DEF_SMTPD_SASL_ENABLE, &var_smtpd_sasl_enable,
+ VAR_BROKEN_AUTH_CLNTS, DEF_BROKEN_AUTH_CLNTS, &var_broken_auth_clients,
+- VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
+- VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
+- VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ VAR_SPF_MARK_ONLY, DEF_SPF_MARK_ONLY, &var_spf_mark_only,
+ VAR_SPF_RCVD_HEADER, DEF_SPF_RCVD_HEADER, &var_spf_rcvd_header,
+ VAR_SPF_GLOBAL_WHITELIST, DEF_SPF_GLOBAL_WHITELIST, &var_spf_global_whitelist,
++ VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
++ VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
++ VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ 0,
+ };
+ static CONFIG_STR_TABLE str_table[] = {
diff --git a/mail/postfix/scripts/configure.postfix b/mail/postfix/scripts/configure.postfix
index aeca9b21793d..a22330259928 100644
--- a/mail/postfix/scripts/configure.postfix
+++ b/mail/postfix/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix/scripts/Attic/configure.postfix,v 1.55 2004-10-26 14:23:33 pav Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix/scripts/Attic/configure.postfix,v 1.56 2004-11-14 19:59:51 pav Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -219,6 +219,9 @@ while [ "$1" ]; do
## echo "README+= SPF_README"
echo ""
SUB_SPF=""
+ if [ X$SUB_TLS != "X" ]; then
+ echo "EXTRA_PATCHES+= ${FILESDIR}/extra-libspf2_and_tls.patch"
+ fi
;;
IPv6)
if [ X$SUB_TLS = "X" ]; then
diff --git a/mail/postfix21/files/extra-libspf2_and_tls.patch b/mail/postfix21/files/extra-libspf2_and_tls.patch
new file mode 100644
index 000000000000..7753bc77e84c
--- /dev/null
+++ b/mail/postfix21/files/extra-libspf2_and_tls.patch
@@ -0,0 +1,18 @@
+--- postfix-2.1.5/src/smtpd/smtpd.c.orig Sat Oct 16 21:44:03 2004
++++ postfix-2.1.5/src/smtpd/smtpd.c Sat Oct 16 21:44:13 2004
+@@ -2749,12 +2749,12 @@
+ VAR_ALLOW_UNTRUST_ROUTE, DEF_ALLOW_UNTRUST_ROUTE, &var_allow_untrust_route,
+ VAR_SMTPD_SASL_ENABLE, DEF_SMTPD_SASL_ENABLE, &var_smtpd_sasl_enable,
+ VAR_BROKEN_AUTH_CLNTS, DEF_BROKEN_AUTH_CLNTS, &var_broken_auth_clients,
+- VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
+- VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
+- VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ VAR_SPF_MARK_ONLY, DEF_SPF_MARK_ONLY, &var_spf_mark_only,
+ VAR_SPF_RCVD_HEADER, DEF_SPF_RCVD_HEADER, &var_spf_rcvd_header,
+ VAR_SPF_GLOBAL_WHITELIST, DEF_SPF_GLOBAL_WHITELIST, &var_spf_global_whitelist,
++ VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
++ VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
++ VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ 0,
+ };
+ static CONFIG_STR_TABLE str_table[] = {
diff --git a/mail/postfix21/scripts/configure.postfix b/mail/postfix21/scripts/configure.postfix
index 6fdf84695bb3..211634b7f24f 100644
--- a/mail/postfix21/scripts/configure.postfix
+++ b/mail/postfix21/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix21/scripts/Attic/configure.postfix,v 1.55 2004-10-26 14:23:33 pav Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix21/scripts/Attic/configure.postfix,v 1.56 2004-11-14 19:59:51 pav Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -219,6 +219,9 @@ while [ "$1" ]; do
## echo "README+= SPF_README"
echo ""
SUB_SPF=""
+ if [ X$SUB_TLS != "X" ]; then
+ echo "EXTRA_PATCHES+= ${FILESDIR}/extra-libspf2_and_tls.patch"
+ fi
;;
IPv6)
if [ X$SUB_TLS = "X" ]; then
diff --git a/mail/postfix22/files/extra-libspf2_and_tls.patch b/mail/postfix22/files/extra-libspf2_and_tls.patch
new file mode 100644
index 000000000000..7753bc77e84c
--- /dev/null
+++ b/mail/postfix22/files/extra-libspf2_and_tls.patch
@@ -0,0 +1,18 @@
+--- postfix-2.1.5/src/smtpd/smtpd.c.orig Sat Oct 16 21:44:03 2004
++++ postfix-2.1.5/src/smtpd/smtpd.c Sat Oct 16 21:44:13 2004
+@@ -2749,12 +2749,12 @@
+ VAR_ALLOW_UNTRUST_ROUTE, DEF_ALLOW_UNTRUST_ROUTE, &var_allow_untrust_route,
+ VAR_SMTPD_SASL_ENABLE, DEF_SMTPD_SASL_ENABLE, &var_smtpd_sasl_enable,
+ VAR_BROKEN_AUTH_CLNTS, DEF_BROKEN_AUTH_CLNTS, &var_broken_auth_clients,
+- VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
+- VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
+- VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ VAR_SPF_MARK_ONLY, DEF_SPF_MARK_ONLY, &var_spf_mark_only,
+ VAR_SPF_RCVD_HEADER, DEF_SPF_RCVD_HEADER, &var_spf_rcvd_header,
+ VAR_SPF_GLOBAL_WHITELIST, DEF_SPF_GLOBAL_WHITELIST, &var_spf_global_whitelist,
++ VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
++ VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
++ VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ 0,
+ };
+ static CONFIG_STR_TABLE str_table[] = {
diff --git a/mail/postfix22/scripts/configure.postfix b/mail/postfix22/scripts/configure.postfix
index 9601c1d43ac9..1a0e528d2ac0 100644
--- a/mail/postfix22/scripts/configure.postfix
+++ b/mail/postfix22/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix22/scripts/Attic/configure.postfix,v 1.55 2004-10-26 14:23:33 pav Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix22/scripts/Attic/configure.postfix,v 1.56 2004-11-14 19:59:51 pav Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -219,6 +219,9 @@ while [ "$1" ]; do
## echo "README+= SPF_README"
echo ""
SUB_SPF=""
+ if [ X$SUB_TLS != "X" ]; then
+ echo "EXTRA_PATCHES+= ${FILESDIR}/extra-libspf2_and_tls.patch"
+ fi
;;
IPv6)
if [ X$SUB_TLS = "X" ]; then
diff --git a/mail/postfix23/files/extra-libspf2_and_tls.patch b/mail/postfix23/files/extra-libspf2_and_tls.patch
new file mode 100644
index 000000000000..7753bc77e84c
--- /dev/null
+++ b/mail/postfix23/files/extra-libspf2_and_tls.patch
@@ -0,0 +1,18 @@
+--- postfix-2.1.5/src/smtpd/smtpd.c.orig Sat Oct 16 21:44:03 2004
++++ postfix-2.1.5/src/smtpd/smtpd.c Sat Oct 16 21:44:13 2004
+@@ -2749,12 +2749,12 @@
+ VAR_ALLOW_UNTRUST_ROUTE, DEF_ALLOW_UNTRUST_ROUTE, &var_allow_untrust_route,
+ VAR_SMTPD_SASL_ENABLE, DEF_SMTPD_SASL_ENABLE, &var_smtpd_sasl_enable,
+ VAR_BROKEN_AUTH_CLNTS, DEF_BROKEN_AUTH_CLNTS, &var_broken_auth_clients,
+- VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
+- VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
+- VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ VAR_SPF_MARK_ONLY, DEF_SPF_MARK_ONLY, &var_spf_mark_only,
+ VAR_SPF_RCVD_HEADER, DEF_SPF_RCVD_HEADER, &var_spf_rcvd_header,
+ VAR_SPF_GLOBAL_WHITELIST, DEF_SPF_GLOBAL_WHITELIST, &var_spf_global_whitelist,
++ VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
++ VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
++ VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ 0,
+ };
+ static CONFIG_STR_TABLE str_table[] = {
diff --git a/mail/postfix23/scripts/configure.postfix b/mail/postfix23/scripts/configure.postfix
index 5dad1e411303..ece7075c75b4 100644
--- a/mail/postfix23/scripts/configure.postfix
+++ b/mail/postfix23/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix23/scripts/Attic/configure.postfix,v 1.55 2004-10-26 14:23:33 pav Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix23/scripts/Attic/configure.postfix,v 1.56 2004-11-14 19:59:51 pav Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -219,6 +219,9 @@ while [ "$1" ]; do
## echo "README+= SPF_README"
echo ""
SUB_SPF=""
+ if [ X$SUB_TLS != "X" ]; then
+ echo "EXTRA_PATCHES+= ${FILESDIR}/extra-libspf2_and_tls.patch"
+ fi
;;
IPv6)
if [ X$SUB_TLS = "X" ]; then
diff --git a/mail/postfix24/files/extra-libspf2_and_tls.patch b/mail/postfix24/files/extra-libspf2_and_tls.patch
new file mode 100644
index 000000000000..7753bc77e84c
--- /dev/null
+++ b/mail/postfix24/files/extra-libspf2_and_tls.patch
@@ -0,0 +1,18 @@
+--- postfix-2.1.5/src/smtpd/smtpd.c.orig Sat Oct 16 21:44:03 2004
++++ postfix-2.1.5/src/smtpd/smtpd.c Sat Oct 16 21:44:13 2004
+@@ -2749,12 +2749,12 @@
+ VAR_ALLOW_UNTRUST_ROUTE, DEF_ALLOW_UNTRUST_ROUTE, &var_allow_untrust_route,
+ VAR_SMTPD_SASL_ENABLE, DEF_SMTPD_SASL_ENABLE, &var_smtpd_sasl_enable,
+ VAR_BROKEN_AUTH_CLNTS, DEF_BROKEN_AUTH_CLNTS, &var_broken_auth_clients,
+- VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
+- VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
+- VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ VAR_SPF_MARK_ONLY, DEF_SPF_MARK_ONLY, &var_spf_mark_only,
+ VAR_SPF_RCVD_HEADER, DEF_SPF_RCVD_HEADER, &var_spf_rcvd_header,
+ VAR_SPF_GLOBAL_WHITELIST, DEF_SPF_GLOBAL_WHITELIST, &var_spf_global_whitelist,
++ VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
++ VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
++ VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ 0,
+ };
+ static CONFIG_STR_TABLE str_table[] = {
diff --git a/mail/postfix24/scripts/configure.postfix b/mail/postfix24/scripts/configure.postfix
index cac2a9f7cbd0..182186186226 100644
--- a/mail/postfix24/scripts/configure.postfix
+++ b/mail/postfix24/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix24/scripts/Attic/configure.postfix,v 1.55 2004-10-26 14:23:33 pav Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix24/scripts/Attic/configure.postfix,v 1.56 2004-11-14 19:59:51 pav Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -219,6 +219,9 @@ while [ "$1" ]; do
## echo "README+= SPF_README"
echo ""
SUB_SPF=""
+ if [ X$SUB_TLS != "X" ]; then
+ echo "EXTRA_PATCHES+= ${FILESDIR}/extra-libspf2_and_tls.patch"
+ fi
;;
IPv6)
if [ X$SUB_TLS = "X" ]; then
diff --git a/mail/postfix25/files/extra-libspf2_and_tls.patch b/mail/postfix25/files/extra-libspf2_and_tls.patch
new file mode 100644
index 000000000000..7753bc77e84c
--- /dev/null
+++ b/mail/postfix25/files/extra-libspf2_and_tls.patch
@@ -0,0 +1,18 @@
+--- postfix-2.1.5/src/smtpd/smtpd.c.orig Sat Oct 16 21:44:03 2004
++++ postfix-2.1.5/src/smtpd/smtpd.c Sat Oct 16 21:44:13 2004
+@@ -2749,12 +2749,12 @@
+ VAR_ALLOW_UNTRUST_ROUTE, DEF_ALLOW_UNTRUST_ROUTE, &var_allow_untrust_route,
+ VAR_SMTPD_SASL_ENABLE, DEF_SMTPD_SASL_ENABLE, &var_smtpd_sasl_enable,
+ VAR_BROKEN_AUTH_CLNTS, DEF_BROKEN_AUTH_CLNTS, &var_broken_auth_clients,
+- VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
+- VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
+- VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ VAR_SPF_MARK_ONLY, DEF_SPF_MARK_ONLY, &var_spf_mark_only,
+ VAR_SPF_RCVD_HEADER, DEF_SPF_RCVD_HEADER, &var_spf_rcvd_header,
+ VAR_SPF_GLOBAL_WHITELIST, DEF_SPF_GLOBAL_WHITELIST, &var_spf_global_whitelist,
++ VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
++ VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
++ VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ 0,
+ };
+ static CONFIG_STR_TABLE str_table[] = {
diff --git a/mail/postfix25/scripts/configure.postfix b/mail/postfix25/scripts/configure.postfix
index 32776a370581..8b7bc08f811e 100644
--- a/mail/postfix25/scripts/configure.postfix
+++ b/mail/postfix25/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix25/scripts/Attic/configure.postfix,v 1.55 2004-10-26 14:23:33 pav Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix25/scripts/Attic/configure.postfix,v 1.56 2004-11-14 19:59:51 pav Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -219,6 +219,9 @@ while [ "$1" ]; do
## echo "README+= SPF_README"
echo ""
SUB_SPF=""
+ if [ X$SUB_TLS != "X" ]; then
+ echo "EXTRA_PATCHES+= ${FILESDIR}/extra-libspf2_and_tls.patch"
+ fi
;;
IPv6)
if [ X$SUB_TLS = "X" ]; then
diff --git a/mail/postfix26/files/extra-libspf2_and_tls.patch b/mail/postfix26/files/extra-libspf2_and_tls.patch
new file mode 100644
index 000000000000..7753bc77e84c
--- /dev/null
+++ b/mail/postfix26/files/extra-libspf2_and_tls.patch
@@ -0,0 +1,18 @@
+--- postfix-2.1.5/src/smtpd/smtpd.c.orig Sat Oct 16 21:44:03 2004
++++ postfix-2.1.5/src/smtpd/smtpd.c Sat Oct 16 21:44:13 2004
+@@ -2749,12 +2749,12 @@
+ VAR_ALLOW_UNTRUST_ROUTE, DEF_ALLOW_UNTRUST_ROUTE, &var_allow_untrust_route,
+ VAR_SMTPD_SASL_ENABLE, DEF_SMTPD_SASL_ENABLE, &var_smtpd_sasl_enable,
+ VAR_BROKEN_AUTH_CLNTS, DEF_BROKEN_AUTH_CLNTS, &var_broken_auth_clients,
+- VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
+- VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
+- VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ VAR_SPF_MARK_ONLY, DEF_SPF_MARK_ONLY, &var_spf_mark_only,
+ VAR_SPF_RCVD_HEADER, DEF_SPF_RCVD_HEADER, &var_spf_rcvd_header,
+ VAR_SPF_GLOBAL_WHITELIST, DEF_SPF_GLOBAL_WHITELIST, &var_spf_global_whitelist,
++ VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
++ VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
++ VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ 0,
+ };
+ static CONFIG_STR_TABLE str_table[] = {
diff --git a/mail/postfix26/scripts/configure.postfix b/mail/postfix26/scripts/configure.postfix
index 4f37abdd9eb4..04c8b3ab7648 100644
--- a/mail/postfix26/scripts/configure.postfix
+++ b/mail/postfix26/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix26/scripts/Attic/configure.postfix,v 1.55 2004-10-26 14:23:33 pav Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix26/scripts/Attic/configure.postfix,v 1.56 2004-11-14 19:59:51 pav Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -219,6 +219,9 @@ while [ "$1" ]; do
## echo "README+= SPF_README"
echo ""
SUB_SPF=""
+ if [ X$SUB_TLS != "X" ]; then
+ echo "EXTRA_PATCHES+= ${FILESDIR}/extra-libspf2_and_tls.patch"
+ fi
;;
IPv6)
if [ X$SUB_TLS = "X" ]; then
diff --git a/mail/postfix27/files/extra-libspf2_and_tls.patch b/mail/postfix27/files/extra-libspf2_and_tls.patch
new file mode 100644
index 000000000000..7753bc77e84c
--- /dev/null
+++ b/mail/postfix27/files/extra-libspf2_and_tls.patch
@@ -0,0 +1,18 @@
+--- postfix-2.1.5/src/smtpd/smtpd.c.orig Sat Oct 16 21:44:03 2004
++++ postfix-2.1.5/src/smtpd/smtpd.c Sat Oct 16 21:44:13 2004
+@@ -2749,12 +2749,12 @@
+ VAR_ALLOW_UNTRUST_ROUTE, DEF_ALLOW_UNTRUST_ROUTE, &var_allow_untrust_route,
+ VAR_SMTPD_SASL_ENABLE, DEF_SMTPD_SASL_ENABLE, &var_smtpd_sasl_enable,
+ VAR_BROKEN_AUTH_CLNTS, DEF_BROKEN_AUTH_CLNTS, &var_broken_auth_clients,
+- VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
+- VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
+- VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ VAR_SPF_MARK_ONLY, DEF_SPF_MARK_ONLY, &var_spf_mark_only,
+ VAR_SPF_RCVD_HEADER, DEF_SPF_RCVD_HEADER, &var_spf_rcvd_header,
+ VAR_SPF_GLOBAL_WHITELIST, DEF_SPF_GLOBAL_WHITELIST, &var_spf_global_whitelist,
++ VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
++ VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
++ VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ 0,
+ };
+ static CONFIG_STR_TABLE str_table[] = {
diff --git a/mail/postfix27/scripts/configure.postfix b/mail/postfix27/scripts/configure.postfix
index b397d4e99647..650235dc6c8b 100644
--- a/mail/postfix27/scripts/configure.postfix
+++ b/mail/postfix27/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix27/scripts/Attic/configure.postfix,v 1.55 2004-10-26 14:23:33 pav Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix27/scripts/Attic/configure.postfix,v 1.56 2004-11-14 19:59:51 pav Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -219,6 +219,9 @@ while [ "$1" ]; do
## echo "README+= SPF_README"
echo ""
SUB_SPF=""
+ if [ X$SUB_TLS != "X" ]; then
+ echo "EXTRA_PATCHES+= ${FILESDIR}/extra-libspf2_and_tls.patch"
+ fi
;;
IPv6)
if [ X$SUB_TLS = "X" ]; then
diff --git a/mail/postfix28/files/extra-libspf2_and_tls.patch b/mail/postfix28/files/extra-libspf2_and_tls.patch
new file mode 100644
index 000000000000..7753bc77e84c
--- /dev/null
+++ b/mail/postfix28/files/extra-libspf2_and_tls.patch
@@ -0,0 +1,18 @@
+--- postfix-2.1.5/src/smtpd/smtpd.c.orig Sat Oct 16 21:44:03 2004
++++ postfix-2.1.5/src/smtpd/smtpd.c Sat Oct 16 21:44:13 2004
+@@ -2749,12 +2749,12 @@
+ VAR_ALLOW_UNTRUST_ROUTE, DEF_ALLOW_UNTRUST_ROUTE, &var_allow_untrust_route,
+ VAR_SMTPD_SASL_ENABLE, DEF_SMTPD_SASL_ENABLE, &var_smtpd_sasl_enable,
+ VAR_BROKEN_AUTH_CLNTS, DEF_BROKEN_AUTH_CLNTS, &var_broken_auth_clients,
+- VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
+- VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
+- VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ VAR_SPF_MARK_ONLY, DEF_SPF_MARK_ONLY, &var_spf_mark_only,
+ VAR_SPF_RCVD_HEADER, DEF_SPF_RCVD_HEADER, &var_spf_rcvd_header,
+ VAR_SPF_GLOBAL_WHITELIST, DEF_SPF_GLOBAL_WHITELIST, &var_spf_global_whitelist,
++ VAR_SHOW_UNK_RCPT_TABLE, DEF_SHOW_UNK_RCPT_TABLE, &var_show_unk_rcpt_table,
++ VAR_SMTPD_REJ_UNL_FROM, DEF_SMTPD_REJ_UNL_FROM, &var_smtpd_rej_unl_from,
++ VAR_SMTPD_REJ_UNL_RCPT, DEF_SMTPD_REJ_UNL_RCPT, &var_smtpd_rej_unl_rcpt,
+ 0,
+ };
+ static CONFIG_STR_TABLE str_table[] = {
diff --git a/mail/postfix28/scripts/configure.postfix b/mail/postfix28/scripts/configure.postfix
index 01d1cc47f16f..947ae63e657b 100644
--- a/mail/postfix28/scripts/configure.postfix
+++ b/mail/postfix28/scripts/configure.postfix
@@ -1,5 +1,5 @@
#!/bin/sh
-# $FreeBSD: /tmp/pcvs/ports/mail/postfix28/scripts/Attic/configure.postfix,v 1.55 2004-10-26 14:23:33 pav Exp $
+# $FreeBSD: /tmp/pcvs/ports/mail/postfix28/scripts/Attic/configure.postfix,v 1.56 2004-11-14 19:59:51 pav Exp $
if [ -f ${WRKDIRPREFIX}${CURDIR}/Makefile.inc ]; then
exit
@@ -219,6 +219,9 @@ while [ "$1" ]; do
## echo "README+= SPF_README"
echo ""
SUB_SPF=""
+ if [ X$SUB_TLS != "X" ]; then
+ echo "EXTRA_PATCHES+= ${FILESDIR}/extra-libspf2_and_tls.patch"
+ fi
;;
IPv6)
if [ X$SUB_TLS = "X" ]; then