aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--textproc/Makefile1
-rw-r--r--textproc/openvanilla-modules/Makefile129
-rw-r--r--textproc/openvanilla-modules/distinfo2
-rw-r--r--textproc/openvanilla-modules/files/patch-Mk::ov.os.mk15
-rw-r--r--textproc/openvanilla-modules/files/patch-Mk::ov.vars.mk14
-rw-r--r--textproc/openvanilla-modules/pkg-descr15
6 files changed, 176 insertions, 0 deletions
diff --git a/textproc/Makefile b/textproc/Makefile
index 4d7017dd5793..ddc302272226 100644
--- a/textproc/Makefile
+++ b/textproc/Makefile
@@ -283,6 +283,7 @@
SUBDIR += opensched
SUBDIR += opensp
SUBDIR += openvanilla-framework
+ SUBDIR += openvanilla-modules
SUBDIR += or-aspell
SUBDIR += p5-Apache-ParseLog
SUBDIR += p5-Apache-XBEL
diff --git a/textproc/openvanilla-modules/Makefile b/textproc/openvanilla-modules/Makefile
new file mode 100644
index 000000000000..899ea4c0c78e
--- /dev/null
+++ b/textproc/openvanilla-modules/Makefile
@@ -0,0 +1,129 @@
+# New ports collection makefile for: openvanilla-modules
+# Date Created: 3 September 2005
+# Whom: Leland Wang <llwang@infor.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= openvanilla-modules
+PORTVERSION= 0.7.1.20050902
+CATEGORIES= textproc
+MASTER_SITES= http://www.csie.org/~llwang/ \
+ http://www.infor.org/~llwang/
+DISTNAME= openvanilla-${PORTVERSION}
+
+MAINTAINER= llwang@infor.org
+COMMENT= Input method modules for OpenVanilla
+
+BUILD_DEPENDS= ${X11BASE}/include/OpenVanilla/OpenVanilla.h:${PORTSDIR}/textproc/openvanilla-framework
+RUN_DEPENDS= ${X11BASE}/lib/scim-1.0/IMEngine/OVLoader-SCIM.so:${PORTSDIR}/textproc/scim-openvanilla
+
+USE_X_PREFIX= yes
+USE_AUTOTOOLS= libtool:15:env
+USE_GMAKE= yes
+
+OPTIONS= OVIMArray "Array Input Module" on \
+ OVIMBig5 "Big5 Input Module" off \
+ OVIMGeneric "Generic Input Module" on \
+ OVIMPOJ_Holo "POJ-Holo Input Module" on \
+ OVIMPhonetic "Phonetic Input Module" on \
+ OVIMRoman "Roman Input Module" off \
+ OVIMTibetan "Tibetan Input Module" on \
+ OVIMUnicode "Unicode Input Module" off
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_OVIMArray)
+PLIST_SUB+= OVIMArray=""
+.else
+PLIST_SUB+= OVIMArray="@comment "
+.endif
+.if defined(WITH_OVIMBig5)
+PLIST_SUB+= OVIMBig5=""
+.else
+PLIST_SUB+= OVIMBig5="@comment "
+.endif
+.if !defined(WITHOUT_OVIMGeneric)
+PLIST_SUB+= OVIMGeneric=""
+.else
+PLIST_SUB+= OVIMGeneric="@comment "
+.endif
+.if !defined(WITHOUT_OVIMPOJ_Holo)
+PLIST_SUB+= OVIMPOJ_Holo=""
+.else
+PLIST_SUB+= OVIMPOJ_Holo="@comment "
+.endif
+.if !defined(WITHOUT_OVIMPhonetic)
+PLIST_SUB+= OVIMPhonetic=""
+.else
+PLIST_SUB+= OVIMPhonetic="@comment "
+.endif
+.if defined(WITH_OVIMRoman)
+PLIST_SUB+= OVIMRoman=""
+.else
+PLIST_SUB+= OVIMRoman="@comment "
+.endif
+.if !defined(WITHOUT_OVIMTibetan)
+PLIST_SUB+= OVIMTibetan=""
+.else
+PLIST_SUB+= OVIMTibetan="@comment "
+.endif
+.if defined(WITH_OVIMUnicode)
+PLIST_SUB+= OVIMUnicode=""
+.else
+PLIST_SUB+= OVIMUnicode="@comment "
+.endif
+
+do-build:
+.if !defined(WITHOUT_OVIMArray)
+ @(cd ${WRKSRC}/Modules/OVIMArray; ${SETENV} ${MAKE_ENV} ${GMAKE} all)
+.endif
+.if defined(WITH_OVIMBig5)
+ @(cd ${WRKSRC}/Modules/OVIMBig5; ${SETENV} ${MAKE_ENV} ${GMAKE} all)
+.endif
+.if !defined(WITHOUT_OVIMGeneric)
+ @(cd ${WRKSRC}/Modules/OVIMGeneric; ${SETENV} ${MAKE_ENV} ${GMAKE} all)
+.endif
+.if !defined(WITHOUT_OVIMPOJ_Holo)
+ @(cd ${WRKSRC}/Modules/OVIMPOJ-Holo; ${SETENV} ${MAKE_ENV} ${GMAKE} all)
+.endif
+.if !defined(WITHOUT_OVIMPhonetic)
+ @(cd ${WRKSRC}/Modules/OVIMPhonetic; ${SETENV} ${MAKE_ENV} ${GMAKE} all)
+.endif
+.if defined(WITH_OVIMRoman)
+ @(cd ${WRKSRC}/Modules/OVIMRoman; ${SETENV} ${MAKE_ENV} ${GMAKE} all)
+.endif
+.if !defined(WITHOUT_OVIMTibetan)
+ @(cd ${WRKSRC}/Modules/OVIMTibetan; ${SETENV} ${MAKE_ENV} ${GMAKE} all)
+.endif
+.if defined(WITH_OVIMUnicode)
+ @(cd ${WRKSRC}/Modules/OVIMUnicode; ${SETENV} ${MAKE_ENV} ${GMAKE} all)
+.endif
+
+do-install:
+.if !defined(WITHOUT_OVIMArray)
+ @(cd ${WRKSRC}/Modules/OVIMArray; ${SETENV} ${MAKE_ENV} ${GMAKE} install)
+.endif
+.if defined(WITH_OVIMBig5)
+ @(cd ${WRKSRC}/Modules/OVIMBig5; ${SETENV} ${MAKE_ENV} ${GMAKE} install)
+.endif
+.if !defined(WITHOUT_OVIMGeneric)
+ @(cd ${WRKSRC}/Modules/OVIMGeneric; ${SETENV} ${MAKE_ENV} ${GMAKE} install)
+.endif
+.if !defined(WITHOUT_OVIMPOJ_Holo)
+ @(cd ${WRKSRC}/Modules/OVIMPOJ-Holo; ${SETENV} ${MAKE_ENV} ${GMAKE} install)
+.endif
+.if !defined(WITHOUT_OVIMPhonetic)
+ @(cd ${WRKSRC}/Modules/OVIMPhonetic; ${SETENV} ${MAKE_ENV} ${GMAKE} install)
+.endif
+.if defined(WITH_OVIMRoman)
+ @(cd ${WRKSRC}/Modules/OVIMRoman; ${SETENV} ${MAKE_ENV} ${GMAKE} install)
+.endif
+.if !defined(WITHOUT_OVIMTibetan)
+ @(cd ${WRKSRC}/Modules/OVIMTibetan; ${SETENV} ${MAKE_ENV} ${GMAKE} install)
+.endif
+.if defined(WITH_OVIMUnicode)
+ @(cd ${WRKSRC}/Modules/OVIMUnicode; ${SETENV} ${MAKE_ENV} ${GMAKE} install)
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/textproc/openvanilla-modules/distinfo b/textproc/openvanilla-modules/distinfo
new file mode 100644
index 000000000000..7d7d9927a8fe
--- /dev/null
+++ b/textproc/openvanilla-modules/distinfo
@@ -0,0 +1,2 @@
+MD5 (openvanilla-0.7.1.20050902.tar.gz) = 65ab030558a8f5a399ef497b8b99d668
+SIZE (openvanilla-0.7.1.20050902.tar.gz) = 11321598
diff --git a/textproc/openvanilla-modules/files/patch-Mk::ov.os.mk b/textproc/openvanilla-modules/files/patch-Mk::ov.os.mk
new file mode 100644
index 000000000000..56b37d9de041
--- /dev/null
+++ b/textproc/openvanilla-modules/files/patch-Mk::ov.os.mk
@@ -0,0 +1,15 @@
+--- Mk/ov.os.mk.orig Sat Sep 3 12:22:17 2005
++++ Mk/ov.os.mk Sun Sep 4 01:51:57 2005
+@@ -16,10 +16,11 @@
+ else
+
+
+- INST_PATH=/usr/local/lib/openvanilla/
++ INST_PATH=${PREFIX}/lib/openvanilla/
+ OBJS=$(patsubst %, %.lo, $(SOURCES))
+ GOALS=$(IMID).la
+ #CFLAGS=-I/usr/local/include/ -I../../Headers/
++ LIBS=-L/usr/local/lib
+
+ $(GOALS): $(OBJS)
+ $(LIBTOOL) --tag=CXX --mode=link $(CPP) $(LDFLAGS) $(LIBS) -module -rpath $(INST_PATH) -avoid-version -o $(GOALS) $(OBJS)
diff --git a/textproc/openvanilla-modules/files/patch-Mk::ov.vars.mk b/textproc/openvanilla-modules/files/patch-Mk::ov.vars.mk
new file mode 100644
index 000000000000..0b0fe1c7b4fb
--- /dev/null
+++ b/textproc/openvanilla-modules/files/patch-Mk::ov.vars.mk
@@ -0,0 +1,14 @@
+--- Mk/ov.vars.mk.orig Sat Sep 3 12:22:17 2005
++++ Mk/ov.vars.mk Sun Sep 4 00:49:19 2005
+@@ -8,9 +8,9 @@
+
+ DATA_INST_PATH?=$(INST_PATH)/$(IMID)
+
+-INC=-I../../Headers -I/usr/local/include
++INC=-I/usr/X11R6/include -I/usr/X11R6/include/OpenVanilla -I/usr/local/include
+
+-CFLAGS=-O2 -Wall $(INC)
++CFLAGS+=-O2 -Wall $(INC)
+
+ GCC=/usr/bin/gcc
+ GPP=/usr/bin/g++
diff --git a/textproc/openvanilla-modules/pkg-descr b/textproc/openvanilla-modules/pkg-descr
new file mode 100644
index 000000000000..d852f53c01b7
--- /dev/null
+++ b/textproc/openvanilla-modules/pkg-descr
@@ -0,0 +1,15 @@
+OpenVanilla (OV) is an input method (IM)/output filter (OF) framework
+designed for better end-user text processing experiences. For example,
+OpenVanilla provides a comprehensive set of Traditional Chinese input
+methods that are lacking or of which counterparts are functionally
+deficient/unsatisfactory in Apple's Mac OS X. Many Simplified Chinese
+users also find this framework useful. A Tibetan IM module is also
+available.
+
+openvanilla-modules installs the input method modules for OpenVanilla.
+The SCIM OpenVanilla loader does not currently support output filters.
+
+WWW: http://openvanilla.org/
+
+-- Leland Wang
+llwang@infor.org