aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/kdepim4-runtime/Makefile2
-rw-r--r--deskutils/kdepim4/Makefile3
-rw-r--r--deskutils/kdepim44-runtime/Makefile4
-rw-r--r--deskutils/kdepim44/Makefile4
-rw-r--r--math/eigen2/Makefile8
-rw-r--r--math/eigen3/Makefile2
6 files changed, 8 insertions, 15 deletions
diff --git a/deskutils/kdepim4-runtime/Makefile b/deskutils/kdepim4-runtime/Makefile
index 02c5552a73f1..e3349f04debc 100644
--- a/deskutils/kdepim4-runtime/Makefile
+++ b/deskutils/kdepim4-runtime/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs \
BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
CONFLICTS= akonadi-google-0.*
-CONFLICTS_INSTALL= kdepim-runtime-4.4.*
+CONFLICTS_INSTALL= kdepim-runtime44-4.*
USE_XZ= yes
USE_GNOME= libxml2
diff --git a/deskutils/kdepim4/Makefile b/deskutils/kdepim4/Makefile
index 2e4ee8db96a0..f0033ea2170d 100644
--- a/deskutils/kdepim4/Makefile
+++ b/deskutils/kdepim4/Makefile
@@ -20,8 +20,7 @@ LIB_DEPENDS= gpgme:${PORTSDIR}/security/gpgme \
BUILD_DEPENDS= xsltproc:${PORTSDIR}/textproc/libxslt
RUN_DEPENDS= ${KDE4_PREFIX}/bin/accountwizard:${PORTSDIR}/deskutils/kdepim4-runtime
-LATEST_LINK= ${PORTNAME}4
-CONFLICTS_INSTALL= kdepim-4.4.*
+CONFLICTS_INSTALL= kdepim44-4.*
USE_XZ= yes
USE_GNOME= libxml2
diff --git a/deskutils/kdepim44-runtime/Makefile b/deskutils/kdepim44-runtime/Makefile
index d66c48627c90..976eddf72841 100644
--- a/deskutils/kdepim44-runtime/Makefile
+++ b/deskutils/kdepim44-runtime/Makefile
@@ -8,14 +8,14 @@ CATEGORIES= deskutils kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/kdepim-${PORTVERSION}/src
DIST_SUBDIR= KDE
+PKGNAMESUFFIX= 44
MAINTAINER= kde@FreeBSD.org
COMMENT= Libraries for KDE-PIM applications
LIB_DEPENDS= boost_thread:${PORTSDIR}/devel/boost-libs
-CONFLICTS_INSTALL= kdepim-runtime-4.[89].*
-LATEST_LINK= ${PORTNAME}44
+CONFLICTS_INSTALL= kdepim-runtime-4.*
USE_KDE4= pimlibs kdeprefix kdehier sharedmime automoc4
USES= cmake:outsource
diff --git a/deskutils/kdepim44/Makefile b/deskutils/kdepim44/Makefile
index 06db8343aeab..3d095c567620 100644
--- a/deskutils/kdepim44/Makefile
+++ b/deskutils/kdepim44/Makefile
@@ -8,6 +8,7 @@ CATEGORIES= deskutils kde ipv6
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/kdepim-${PORTVERSION}/src
DIST_SUBDIR= KDE
+PKGNAMESUFFIX= 44
MAINTAINER= kde@FreeBSD.org
COMMENT= Libraries for KDE-PIM applications
@@ -18,8 +19,7 @@ LIB_DEPENDS= gpgme:${PORTSDIR}/security/gpgme \
qca:${PORTSDIR}/devel/qca
RUN_DEPENDS= ${KDE4_PREFIX}/bin/akonadi_mbox_resource:${PORTSDIR}/deskutils/kdepim44-runtime
-LATEST_LINK= ${PORTNAME}44
-CONFLICTS_INSTALL= kdepim-4.[89].*
+CONFLICTS_INSTALL= kdepim-4.*
USE_KDE4= kdelibs pimlibs \
akonadi kdeprefix kdehier automoc4 oxygen
diff --git a/math/eigen2/Makefile b/math/eigen2/Makefile
index 559351ffb43d..f86fea31f6ea 100644
--- a/math/eigen2/Makefile
+++ b/math/eigen2/Makefile
@@ -1,7 +1,4 @@
-# New ports collection makefile for: eigen
-# Date created: 2008-01-18
-# Whom: arved
-#
+# Created by: arved
# $FreeBSD$
PORTNAME= eigen
@@ -11,6 +8,7 @@ CATEGORIES= math
MASTER_SITES= https://bitbucket.org/eigen/eigen/get/
DISTNAME= ${PORTVERSION}
DIST_SUBDIR= ${PORTNAME}
+PKGNAMESUFFIX= 2
MAINTAINER= kde@FreeBSD.org
COMMENT= Lightweight library for vector and matrix math
@@ -18,8 +16,6 @@ COMMENT= Lightweight library for vector and matrix math
USE_BZIP2= yes
USES= cmake
-LATEST_LINK= ${PORTNAME}2
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-b23437e61a07
post-patch:
diff --git a/math/eigen3/Makefile b/math/eigen3/Makefile
index 9c184d0e7b9a..21982793c795 100644
--- a/math/eigen3/Makefile
+++ b/math/eigen3/Makefile
@@ -18,8 +18,6 @@ USES= cmake:outsource
CMAKE_ENV+= PKG_CONFIG_LIBDIR="${LOCALBASE}/libdata"
NO_BUILD= yes
-LATEST_LINK= ${PORTNAME}3
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTNAME}-ffa86ffb5570
.include <bsd.port.mk>