aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-TheSeer_phpDox/Makefile36
-rw-r--r--devel/pear-TheSeer_phpDox/distinfo2
-rw-r--r--devel/pear-TheSeer_phpDox/pkg-descr4
4 files changed, 43 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index db5f8b573015..83ec6adf140c 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -3054,6 +3054,7 @@
SUBDIR += pear-TheSeer_DirectoryScanner
SUBDIR += pear-TheSeer_fDOMDocument
SUBDIR += pear-TheSeer_fXSL
+ SUBDIR += pear-TheSeer_phpDox
SUBDIR += pear-VFS
SUBDIR += pear-Validate
SUBDIR += pear-Validate_AU
diff --git a/devel/pear-TheSeer_phpDox/Makefile b/devel/pear-TheSeer_phpDox/Makefile
new file mode 100644
index 000000000000..237328b9bb6a
--- /dev/null
+++ b/devel/pear-TheSeer_phpDox/Makefile
@@ -0,0 +1,36 @@
+# Created by: Gasol Wu <gasol.wu@gmail.com>
+# $FreeBSD$
+
+PORTNAME= phpDox
+PORTVERSION= 0.4.0
+CATEGORIES= devel pear
+MASTER_SITES= http://pear.netpirates.net/get/
+PKGNAMEPREFIX= pear-TheSeer_
+
+MAINTAINER= gasol.wu@gmail.com
+COMMENT= PHP Documentation generation framework and tool
+
+LICENSE= BSD
+
+BUILD_DEPENDS= pear>=1.9.2:${PORTSDIR}/devel/pear \
+ pear-TheSeer_DirectoryScanner>=1.1.0:${PORTSDIR}/devel/pear-TheSeer_DirectoryScanner \
+ pear-TheSeer_fDOMDocument>=1.2.3:${PORTSDIR}/devel/pear-TheSeer_fDOMDocument \
+ pear-TheSeer_fXSL>=1.0.4:${PORTSDIR}/devel/pear-TheSeer_fXSL \
+ pear-ezc_ConsoleTools>=1.6:${PORTSDIR}/devel/pear-ezc_ConsoleTools \
+ pear-pdepend_staticReflection>=0.2.1:${PORTSDIR}/devel/pear-pdepend-staticReflection
+RUN_DEPENDS= pear>=1.9.2:${PORTSDIR}/devel/pear \
+ pear-TheSeer_DirectoryScanner>=1.1.0:${PORTSDIR}/devel/pear-TheSeer_DirectoryScanner \
+ pear-TheSeer_fDOMDocument>=1.2.3:${PORTSDIR}/devel/pear-TheSeer_fDOMDocument \
+ pear-TheSeer_fXSL>=1.0.4:${PORTSDIR}/devel/pear-TheSeer_fXSL \
+ pear-ezc_ConsoleTools>=1.6:${PORTSDIR}/devel/pear-ezc_ConsoleTools \
+ pear-pdepend_staticReflection>=0.2.1:${PORTSDIR}/devel/pear-pdepend-staticReflection
+
+USE_PHP= dom tokenizer xsl iconv
+PEAR_CHANNEL= theseer
+PEAR_AUTOINSTALL= yes
+
+IGNORE_WITH_PHP=52
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear/bsd.pear.mk"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-TheSeer_phpDox/distinfo b/devel/pear-TheSeer_phpDox/distinfo
new file mode 100644
index 000000000000..1bcdc7951cb5
--- /dev/null
+++ b/devel/pear-TheSeer_phpDox/distinfo
@@ -0,0 +1,2 @@
+SHA256 (PEAR/phpDox-0.4.0.tgz) = f167b7269097bd354a3faaa430081b351dced2741236e14f4e9fd68025e69693
+SIZE (PEAR/phpDox-0.4.0.tgz) = 55733
diff --git a/devel/pear-TheSeer_phpDox/pkg-descr b/devel/pear-TheSeer_phpDox/pkg-descr
new file mode 100644
index 000000000000..d0866afc9986
--- /dev/null
+++ b/devel/pear-TheSeer_phpDox/pkg-descr
@@ -0,0 +1,4 @@
+A fast Documentation generator for PHP Code using standard technology (SRC,
+DOCBLOCK, XML and XSLT) with event based processing.
+
+WWW: http://phpdox.de/