aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/quake2-3zb2/Makefile16
-rw-r--r--games/quake2-ctf/Makefile10
-rw-r--r--games/quake2-extras/Makefile17
-rw-r--r--games/quake2-lights/Makefile2
-rw-r--r--games/quake2-lights/pkg-descr2
-rw-r--r--games/quake2-matrix/Makefile7
-rw-r--r--games/quake2-psychomod/Makefile12
-rw-r--r--games/quake2-relay/Makefile9
-rw-r--r--games/quake2-relay/pkg-descr2
-rw-r--r--games/quake2-rogue/Makefile5
-rw-r--r--games/quake2-source/Makefile12
-rw-r--r--games/quake2-source/pkg-descr6
-rw-r--r--games/quake2-xatrix/Makefile5
-rw-r--r--games/quake2lnx/Makefile4
14 files changed, 54 insertions, 55 deletions
diff --git a/games/quake2-3zb2/Makefile b/games/quake2-3zb2/Makefile
index ea1ae36ec933..b5f68a6cab32 100644
--- a/games/quake2-3zb2/Makefile
+++ b/games/quake2-3zb2/Makefile
@@ -13,7 +13,7 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:prog \
${PORTNAME}src${PORTVERSION:S/0.//}${EXTRACT_SUFX}:prog
DIST_SUBDIR= ${PKGNAMEPREFIX}${PORTNAME}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= 3rd Zigock II bots for Quake II
USES= dos2unix zip
@@ -55,20 +55,22 @@ post-extract:
do-install:
.for f in chctf chdtm
@${MKDIR} ${STAGEDIR}${Q2DIR}/${PORTNAME}/${f}
- ${INSTALL_DATA} ${WRKSRC}/3zb2/${f}/* ${STAGEDIR}${Q2DIR}/${PORTNAME}/${f}
+ ${INSTALL_DATA} ${WRKSRC}/3zb2/${f}/* \
+ ${STAGEDIR}${Q2DIR}/${PORTNAME}/${f}
.endfor
- ${INSTALL_PROGRAM} ${WRKSRC}/game.so ${STAGEDIR}${Q2DIR}/${PORTNAME}
+ ${INSTALL_PROGRAM} ${WRKSRC}/game.so \
+ ${STAGEDIR}${Q2DIR}/${PORTNAME}
cd ${WRKSRC}/3zb2 && ${INSTALL_DATA} *.cfg 3ZBMaps.lst pak6.pak \
${STAGEDIR}${Q2DIR}/${PORTNAME}
.if ${PORT_OPTIONS:MROUTES}
${INSTALL_DATA} ${WRKSRC}/*.chn ${STAGEDIR}${Q2DIR}/${PORTNAME}/chdtm
${INSTALL_DATA} ${WRKSRC}/*.chf ${STAGEDIR}${Q2DIR}/${PORTNAME}/chctf
.endif
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
cd ${WRKSRC}/3zb2 && ${CP} -a *.txt "User Guide" ${STAGEDIR}${DOCSDIR}
- @${FIND} ${STAGEDIR}${DOCSDIR} -type d -print0 | ${XARGS} -0 ${CHMOD} ${BINMODE}
- @${FIND} ${STAGEDIR}${DOCSDIR} -type f -print0 | ${XARGS} -0 ${CHMOD} ${SHAREMODE}
-.endif
+ @${FIND} ${STAGEDIR}${DOCSDIR} -type d -print0 | \
+ ${XARGS} -0 ${CHMOD} ${BINMODE}
+ @${FIND} ${STAGEDIR}${DOCSDIR} -type f -print0 | \
+ ${XARGS} -0 ${CHMOD} ${SHAREMODE}
.include <bsd.port.mk>
diff --git a/games/quake2-ctf/Makefile b/games/quake2-ctf/Makefile
index 58b9817c976a..623da296713a 100644
--- a/games/quake2-ctf/Makefile
+++ b/games/quake2-ctf/Makefile
@@ -4,15 +4,13 @@
PORTNAME= ctf
PORTVERSION= 1.52
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_IDSOFTWARE:S|$|:data|} \
+MASTER_SITES= IDSOFTWARE/quake2/ctf/:data \
http://offload1.icculus.org/quake2/files/:src
-MASTER_SITE_SUBDIR= quake2/ctf/:data
PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
-DISTFILES= ${CTF_DATA}:data \
- ${CTF_SRC}:src
+DISTFILES= ${CTF_DATA}:data ${CTF_SRC}:src
DIST_SUBDIR= quake2lnx
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Quake II CTF (Capture The Flag) mod
USES= dos2unix zip:infozip
@@ -46,10 +44,8 @@ do-install:
.for f in *.cfg *.pak
${INSTALL_DATA} ${WRKDIR}/ctf/${f} ${STAGEDIR}${Q2DIR}/ctf
.endfor
-.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/* ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKDIR}/ctf/readme.txt ${STAGEDIR}${DOCSDIR}
-.endif
.include <bsd.port.mk>
diff --git a/games/quake2-extras/Makefile b/games/quake2-extras/Makefile
index 4741d848fedf..b47ff12b3418 100644
--- a/games/quake2-extras/Makefile
+++ b/games/quake2-extras/Makefile
@@ -13,12 +13,18 @@ DISTFILES= #
DIST_SUBDIR= ${LATEST_LINK}
EXTRACT_ONLY= #
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Quake II extras (high quality textures and skins)
USES= zip
NO_WRKSUBDIR= yes
+LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}
+
+RETEX_PAKS= 10 11 12 13 14 16 17 19
+RETEX_FULL= all_q2_textures_07_17_2006zip
+SKINS= models.zip
+
OPTIONS_DEFINE= RETEXTURE RETEXTURE_FULL SKINS
OPTIONS_DEFAULT= RETEXTURE
@@ -26,12 +32,6 @@ RETEXTURE_DESC= Install high quality textures
RETEXTURE_FULL_DESC= Install more textures (120MB)
SKINS_DESC= Install high quality skins
-LATEST_LINK= ${PKGNAMEPREFIX}${PORTNAME}
-
-RETEX_PAKS= 10 11 12 13 14 16 17 19
-RETEX_FULL= all_q2_textures_07_17_2006zip
-SKINS= models.zip
-
.include "${.CURDIR}/../quake2-data/Makefile.include"
.include <bsd.port.options.mk>
@@ -84,7 +84,8 @@ do-install:
@${MKDIR} ${STAGEDIR}${Q2DIR}/baseq2
.if ${PORT_OPTIONS:MRETEXTURE} && empty(PORT_OPTIONS:MRETEXTURE_FULL)
. for i in ${RETEX_PAKS}
- ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/pak${i}.pak ${STAGEDIR}${Q2DIR}/baseq2
+ ${INSTALL_DATA} ${DISTDIR}/${DIST_SUBDIR}/pak${i}.pak \
+ ${STAGEDIR}${Q2DIR}/baseq2
. endfor
.endif
.if ${PORT_OPTIONS:MRETEXTURE_FULL}
diff --git a/games/quake2-lights/Makefile b/games/quake2-lights/Makefile
index f2f2acda133e..5f12bada4af5 100644
--- a/games/quake2-lights/Makefile
+++ b/games/quake2-lights/Makefile
@@ -12,7 +12,7 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:data,src \
Lights-Bots${EXTRACT_SUFX}:src
MAINTAINER= danfe@FreeBSD.org
-COMMENT= Lights modification for Quake II
+COMMENT= Lights and weapon effects modification for Quake II
USES= gmake tar:bzip2
NO_WRKSUBDIR= yes
diff --git a/games/quake2-lights/pkg-descr b/games/quake2-lights/pkg-descr
index 9dacadcbc635..0c0e027affad 100644
--- a/games/quake2-lights/pkg-descr
+++ b/games/quake2-lights/pkg-descr
@@ -4,7 +4,7 @@ for the weapons shots.
This mod is intended to play it with Quake2Max supported binaries because
the lights and effects are better saw compared to original Quake2 binaries.
-There are already a lot of new commands, scanner, flashlight, decoys,
+This mod introduces a lot of new commands, scanner, flashlight, decoys,
defense laser, chasecam, hook, etc. Some keys in the autoexec.cfg are set
by default.
diff --git a/games/quake2-matrix/Makefile b/games/quake2-matrix/Makefile
index c9c5cc396bf3..8abba9ef4f96 100644
--- a/games/quake2-matrix/Makefile
+++ b/games/quake2-matrix/Makefile
@@ -1,4 +1,4 @@
-# Created by: alepulver
+# Created by: Alejandro Pulver <alepulver@FreeBSD.org>
# $FreeBSD$
PORTNAME= matrix
@@ -8,7 +8,7 @@ MASTER_SITES= http://qudos.quakedev.com/linux/quake2/mods/
PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
DISTNAME= Matrix-v${PORTVERSION}.fixed.Linux
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Matrix modification for Quake II
USES= gmake tar:bzip2
@@ -30,7 +30,8 @@ do-install:
@${MKDIR} ${STAGEDIR}${Q2DIR}/${PORTNAME}
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/matrix/game.so \
${STAGEDIR}${Q2DIR}/${PORTNAME}
- cd ${WRKSRC} && ${INSTALL_DATA} *.cfg *.ini *.pak ${STAGEDIR}${Q2DIR}/${PORTNAME}
+ cd ${WRKSRC} && ${INSTALL_DATA} *.cfg *.ini *.pak \
+ ${STAGEDIR}${Q2DIR}/${PORTNAME}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/docs/* ${STAGEDIR}${DOCSDIR}
diff --git a/games/quake2-psychomod/Makefile b/games/quake2-psychomod/Makefile
index d30255582787..3e93f1d5d9e0 100644
--- a/games/quake2-psychomod/Makefile
+++ b/games/quake2-psychomod/Makefile
@@ -1,14 +1,13 @@
-# Created by: alepulver
+# Created by: Alejandro Pulver <alepulver@FreeBSD.org>
# $FreeBSD$
PORTNAME= psychomod
PORTVERSION= 3.1
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= alepulver
+MASTER_SITES= LOCAL/alepulver
PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Psychomod modification for Quake II
USES= gmake tar:bzip2
@@ -18,6 +17,8 @@ ALL_TARGET= release
DOCSDIR= ${PREFIX}/share/doc/${LATEST_LINK}
+OPTIONS_DEFINE= DOCS
+
.include "${.CURDIR}/../quake2-data/Makefile.include"
post-patch:
@@ -28,7 +29,8 @@ do-install:
@${MKDIR} ${STAGEDIR}${Q2DIR}/${PORTNAME}
${INSTALL_PROGRAM} ${BUILD_WRKSRC}/release/psychomod/game.so \
${STAGEDIR}${Q2DIR}/${PORTNAME}
- cd ${WRKSRC} && ${INSTALL_DATA} *.cfg pak0.pak ${STAGEDIR}${Q2DIR}/${PORTNAME}
+ cd ${WRKSRC} && ${INSTALL_DATA} *.cfg pak0.pak \
+ ${STAGEDIR}${Q2DIR}/${PORTNAME}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/readme.txt ${STAGEDIR}${DOCSDIR}
diff --git a/games/quake2-relay/Makefile b/games/quake2-relay/Makefile
index 93a42844f709..0593f89d62cb 100644
--- a/games/quake2-relay/Makefile
+++ b/games/quake2-relay/Makefile
@@ -8,21 +8,20 @@ MASTER_SITES= LOCAL/danfe http://freebsd.nsu.ru/distfiles/
PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
DISTNAME= relay-${PORTVERSION}.src
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Quake II multi-view demo recording facility
LICENSE= GPLv2
USES= gmake
MAKE_ARGS= MODE=release OBJ_DIR=. OUT_DIR=. Q2MODULE=game.so \
- QUAKE2_DIR="${STAGEDIR}${Q2DIR}" BIN_DIR="${STAGEDIR}${PREFIX}/bin" \
+ QUAKE2_DIR="${STAGEDIR}${Q2DIR}" \
+ BIN_DIR="${STAGEDIR}${PREFIX}/bin" \
CC="${CC}" LD="${CC}" CFLAGS="${CFLAGS}"
WRKSRC= ${WRKDIR}/relay-${PORTVERSION}
PORTDOCS= FAQ README
-ED?= /bin/ed
-
OPTIONS_DEFINE= DOCS
.include "${.CURDIR}/../quake2-data/Makefile.include"
@@ -48,4 +47,6 @@ post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${PORTDOCS:S,^,${WRKSRC}/,} ${STAGEDIR}${DOCSDIR}
+ED?= /bin/ed
+
.include <bsd.port.mk>
diff --git a/games/quake2-relay/pkg-descr b/games/quake2-relay/pkg-descr
index 0851aa7b758a..281b020e7e6a 100644
--- a/games/quake2-relay/pkg-descr
+++ b/games/quake2-relay/pkg-descr
@@ -7,7 +7,7 @@ player's view, relay demos can record everything in the level for the
entire duration of the match. With Replay, you can watch these matches
through any player's perspective, chase-cam mode, or free-fly mode.
-Benefits of Relay:
+Benefits of Quake2 Relay:
- Every player's perspective is recorded
- No lag
diff --git a/games/quake2-rogue/Makefile b/games/quake2-rogue/Makefile
index f7c3728dc9ff..52476622005f 100644
--- a/games/quake2-rogue/Makefile
+++ b/games/quake2-rogue/Makefile
@@ -4,13 +4,12 @@
PORTNAME= rogue
PORTVERSION= 3.20
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_IDSOFTWARE}
-MASTER_SITE_SUBDIR= quake2/source
+MASTER_SITES= IDSOFTWARE/quake2/source
PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}src${PORTVERSION:S/.//}
EXTRACT_SUFX= .shar.Z
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Quake II: Ground Zero (Rogue) official mission pack
NO_WRKSUBDIR= yes
diff --git a/games/quake2-source/Makefile b/games/quake2-source/Makefile
index 45c0a0022d9a..ec91bc9fc443 100644
--- a/games/quake2-source/Makefile
+++ b/games/quake2-source/Makefile
@@ -13,7 +13,7 @@ DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:icc
DIST_SUBDIR= quake2lnx
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Quake II game source
NO_BUILD= yes
@@ -46,19 +46,19 @@ XATRIX_OFF= 441
post-extract:
.for f in rogue xatrix
-. if ${PORT_OPTIONS:M${f:tu}}
+. if ${PORT_OPTIONS:M${f:tu}}
@${MKDIR} ${WRKSRC}/src/${f}
@(cd ${WRKSRC}/src/${f} && ${GUNZIP_CMD} -c \
${DISTDIR}/${DIST_SUBDIR}/${f}src320.shar.Z > \
${f}src320.shar && \
${TAIL} +${${f:tu}_OFF} ${f}src320.shar | ${SH})
-. endif
+. endif
.endfor
pre-install:
- @${FIND} -E ${WRKSRC} -type f \
- -iregex "(Makefile|.*\.(def|dsp|orig|shar))" -print0 | \
- ${XARGS} -0 ${RM}
+ @${FIND} -E ${WRKSRC} -type f -iregex \
+ "(Makefile|.*\.(def|dsp|orig|shar))" -print0 | \
+ ${XARGS} -0 ${RM}
do-install:
@${MKDIR} ${STAGEDIR}${DATADIR}
diff --git a/games/quake2-source/pkg-descr b/games/quake2-source/pkg-descr
index 4b82f4c49328..ee2535073fd7 100644
--- a/games/quake2-source/pkg-descr
+++ b/games/quake2-source/pkg-descr
@@ -1,5 +1,3 @@
-Quake II game source.
-
This port installs the Quake II game source, together with BSD Makefiles, for
-building modifications. It can also install the Capture the Flag mod, Rogue
-and Xatrix game source.
+building modifications. It can also install the Capture the Flag mod, Rogue,
+and Xatrix game sources.
diff --git a/games/quake2-xatrix/Makefile b/games/quake2-xatrix/Makefile
index 3f1b09e476a5..b10ff66b5d5b 100644
--- a/games/quake2-xatrix/Makefile
+++ b/games/quake2-xatrix/Makefile
@@ -4,13 +4,12 @@
PORTNAME= xatrix
PORTVERSION= 3.20
CATEGORIES= games
-MASTER_SITES= ${MASTER_SITE_IDSOFTWARE}
-MASTER_SITE_SUBDIR= quake2/source
+MASTER_SITES= IDSOFTWARE/quake2/source
PKGNAMEPREFIX= ${Q2PKGNAMEPREFIX}
DISTNAME= ${PORTNAME}src${PORTVERSION:S/.//}
EXTRACT_SUFX= .shar.Z
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danfe@FreeBSD.org
COMMENT= Quake II: The Reckoning (Xatrix) official mission pack
NO_WRKSUBDIR= yes
diff --git a/games/quake2lnx/Makefile b/games/quake2lnx/Makefile
index 999cb59aa68b..0357430bacfa 100644
--- a/games/quake2lnx/Makefile
+++ b/games/quake2lnx/Makefile
@@ -207,13 +207,13 @@ do-install:
.for tgt in ${EXE_TARGETS}
${INSTALL_PROGRAM} ${WRKSRC}/release/${tgt} ${STAGEDIR}${PREFIX}/bin
.endfor
- @${MKDIR} ${LIBDIR}/baseq2
+ @${MKDIR} ${STAGEDIR}${LIBDIR}/baseq2
.for tgt in ${REF_TARGETS}
${INSTALL_PROGRAM} ${WRKSRC}/release/ref_${tgt}.so \
${STAGEDIR}${LIBDIR}
.endfor
.if ${PORT_OPTIONS:MCTF}
- @${MKDIR} ${LIBDIR}/ctf
+ @${MKDIR} ${STAGEDIR}${LIBDIR}/ctf
${INSTALL_PROGRAM} ${WRKSRC}/release/ctf/game.so \
${STAGEDIR}${LIBDIR}/ctf
.endif