aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/rtty/Makefile9
-rw-r--r--sysutils/rtty/distinfo2
-rw-r--r--sysutils/rtty/files/patch-aa21
3 files changed, 16 insertions, 16 deletions
diff --git a/sysutils/rtty/Makefile b/sysutils/rtty/Makefile
index 097fe8bd8052..04723d9410c9 100644
--- a/sysutils/rtty/Makefile
+++ b/sysutils/rtty/Makefile
@@ -6,13 +6,16 @@
#
PORTNAME= rtty
-PORTVERSION= 3.2
+PORTVERSION= 4.0
CATEGORIES= sysutils
-MASTER_SITES= ftp://ftp.vix.com/pub/vixie/ \
- ftp://ftp.digital.com/pub/misc/vixie/
+MASTER_SITES= ftp://ftp.vix.com/pub/vixie/
+EXTRACT_SUFX= .shar.gz
MAINTAINER= ports@FreeBSD.org
+EXTRACT_CMD= ${GZCAT}
+EXTRACT_BEFORE_ARGS=
+EXTRACT_AFTER_ARGS= |sh
NO_WRKSUBDIR= yes
.include <bsd.port.mk>
diff --git a/sysutils/rtty/distinfo b/sysutils/rtty/distinfo
index a2e1eb7cb35b..e1d98bec8d6c 100644
--- a/sysutils/rtty/distinfo
+++ b/sysutils/rtty/distinfo
@@ -1 +1 @@
-MD5 (rtty-3.2.tar.gz) = cb16df2f8eed6f1d97cd9ef125e056e3
+MD5 (rtty-4.0.shar.gz) = 1b9eba3dbb0fb5a11c15275977f2d7ac
diff --git a/sysutils/rtty/files/patch-aa b/sysutils/rtty/files/patch-aa
index 6fbb161fcf3b..f5067b84b617 100644
--- a/sysutils/rtty/files/patch-aa
+++ b/sysutils/rtty/files/patch-aa
@@ -1,5 +1,5 @@
---- Makefile.orig Sat Aug 24 08:46:42 1996
-+++ Makefile Fri Jan 21 23:09:45 2000
+--- Makefile.orig Fri Nov 9 15:30:45 2001
++++ Makefile Fri Nov 9 15:32:24 2001
@@ -19,12 +19,12 @@
VPATH = ../src
@@ -10,25 +10,22 @@
+DESTPATH = $(DESTROOT)/rtty
DESTBIN = $(DESTPATH)/bin
--CC = cc
--CDEBUG = -O -g
-+CC ?= cc
-+#CDEBUG = -O -g
+ #CC = cc
+-CDEBUG = -O
++#CDEBUG = -O
#
# use -U to undefine, -D to define
# DEBUG include code to help debug this software
-@@ -38,8 +38,8 @@
- CDEFS = -DDEBUG -UWANT_TCPIP -UNEED_BITYPES_H -UNEED_STRDUP -UNEED_INET_ATON \
+@@ -37,7 +37,7 @@
+ CDEFS = -DDEBUG -UWANT_TCPIP -UNEED_BITYPES_H -UNEED_INET_ATON \
-UNO_SOCKADDR_LEN -UNO_HSTRERROR
#
-CFLAGS = $(CDEBUG) $(CDEFS) -I/usr/local/include
--LIBS =
+CFLAGS += $(CDEBUG) $(CDEFS)
-+LIBS = -lcrypt
+ LIBS = -lcrypt
#(if WANT_TCPIP defined and this isn't in your libc)
# -lresolv
- #(if the resolver needs it, which BIND>=4.9's will on BSD>=4.4 systems)
-@@ -63,7 +63,7 @@
+@@ -64,7 +64,7 @@
test -d $(DESTPATH)/$$x || mkdir $(DESTPATH)/$$x; \
done
set -x; for x in $(BINARY); do \