aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/tkcon/Makefile27
-rw-r--r--devel/tkcon/distinfo6
-rw-r--r--devel/tkcon/files/patch-aa10
-rw-r--r--devel/tkcon/files/patch-tkcon.tcl22
-rw-r--r--devel/tkcon/pkg-plist21
5 files changed, 37 insertions, 49 deletions
diff --git a/devel/tkcon/Makefile b/devel/tkcon/Makefile
index 20c6e9ecbca3..6f081faa9f9e 100644
--- a/devel/tkcon/Makefile
+++ b/devel/tkcon/Makefile
@@ -6,32 +6,29 @@
#
PORTNAME= tkcon
-PORTVERSION= 2.4
-PORTREVISION= 1
+PORTVERSION= 2.5
CATEGORIES= devel tcl tk
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR=${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= ports@FreeBSD.org
COMMENT= Tk console for Tcl
-RUN_DEPENDS= wish8.4:${PORTSDIR}/x11-toolkits/tk84
-
NO_BUILD= yes
-REINPLACE_ARGS= -i.bak -E
+USE_TK_WRAPPER= yes
+
+PORTDOCS= *
+PLIST_FILES= bin/${PORTNAME}
post-patch:
- @${REINPLACE_CMD} \
- -e 's,docs\s+"([^"]+)",docs "file:${PREFIX}/share/doc/tkcon/index.html\\n\1",' ${WRKSRC}/tkcon.tcl
+ @${REINPLACE_CMD} -e \
+ 's|%%DOCSDIR%%|${DOCSDIR}|g' ${WRKSRC}/${PORTNAME}.tcl
do-install:
- ${INSTALL_SCRIPT} ${WRKSRC}/tkcon.tcl ${PREFIX}/bin/tkcon
-
+ ${INSTALL_SCRIPT} ${WRKSRC}/${PORTNAME}.tcl ${PREFIX}/bin/${PORTNAME}
.if !defined(NOPORTDOCS)
-post-install:
- ${MKDIR} ${PREFIX}/share/doc/tkcon
- ${INSTALL_DATA} ${WRKSRC}/README.txt $(PREFIX)/share/doc/tkcon/README.tkcon
- ${INSTALL_DATA} ${WRKSRC}/docs/* $(PREFIX)/share/doc/tkcon
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}/README.${PORTNAME}
+ ${INSTALL_DATA} ${WRKSRC}/docs/* ${DOCSDIR}
.endif
.include <bsd.port.mk>
diff --git a/devel/tkcon/distinfo b/devel/tkcon/distinfo
index f37aeb120a1f..c2d440c7b749 100644
--- a/devel/tkcon/distinfo
+++ b/devel/tkcon/distinfo
@@ -1,3 +1,3 @@
-MD5 (tkcon-2.4.tar.gz) = 415905fe3d81aa957f9c4424c219784e
-SHA256 (tkcon-2.4.tar.gz) = ebfa18474216d7df856fadf5778f66371dae8a79be1ca57200b7f5ba22920c6a
-SIZE (tkcon-2.4.tar.gz) = 107436
+MD5 (tkcon-2.5.tar.gz) = 7d8e83727b8f9630d1b7e233cda145af
+SHA256 (tkcon-2.5.tar.gz) = 3ff3eb7198b060d2c3bdc195c1f7d8532e63742447179fbb6091a3886bab42a9
+SIZE (tkcon-2.5.tar.gz) = 139834
diff --git a/devel/tkcon/files/patch-aa b/devel/tkcon/files/patch-aa
deleted file mode 100644
index a10f271297c1..000000000000
--- a/devel/tkcon/files/patch-aa
+++ /dev/null
@@ -1,10 +0,0 @@
---- tkcon.tcl Thu Apr 1 05:49:22 1999
-+++ tkcon.tcl Mon Jun 28 21:35:52 1999
-@@ -1,6 +1,6 @@
- #!/bin/sh
- # \
--exec wish "$0" ${1+"$@"}
-+if [ X$WISH != X ]; then exec $WISH "$0" -- "$@"; else exec wish8.4 "$0" -- "$@"; fi;
-
- #
- ## tkcon.tcl
diff --git a/devel/tkcon/files/patch-tkcon.tcl b/devel/tkcon/files/patch-tkcon.tcl
new file mode 100644
index 000000000000..ab3f7864c9ed
--- /dev/null
+++ b/devel/tkcon/files/patch-tkcon.tcl
@@ -0,0 +1,22 @@
+--- tkcon.tcl.orig 2009-02-27 09:17:21.000000000 +0900
++++ tkcon.tcl 2009-05-16 18:38:23.000000000 +0900
+@@ -194,7 +194,7 @@
+ RCS {RCS: @(#) $Id: tkcon.tcl,v 1.102 2008/02/07 21:02:53 hobbs Exp $}
+ HEADURL {http://tkcon.cvs.sourceforge.net/tkcon/tkcon/tkcon.tcl?rev=HEAD}
+
+- docs "http://tkcon.sourceforge.net/"
++ docs "file:%%DOCSDIR%%/index.html"
+ email {jeff(a)hobbs(.)org}
+ root .
+ uid 0
+@@ -1586,8 +1586,8 @@
+ foreach m [list [menu $w.help] [menu $w.pop.help]] {
+ $m add command -label "About " -underline 0 -accel Ctrl-A \
+ -command ::tkcon::About
+- $m add command -label "Retrieve Latest Version" -underline 0 \
+- -command ::tkcon::Retrieve
++ # $m add command -label "Retrieve Latest Version" -underline 0 \
++ # -command ::tkcon::Retrieve
+ if {![catch {package require ActiveTcl} ver]} {
+ set cmd ""
+ if {$tcl_platform(platform) == "windows"} {
diff --git a/devel/tkcon/pkg-plist b/devel/tkcon/pkg-plist
deleted file mode 100644
index e7841ff5b80d..000000000000
--- a/devel/tkcon/pkg-plist
+++ /dev/null
@@ -1,21 +0,0 @@
-bin/tkcon
-%%PORTDOCS%%share/doc/tkcon/README.tkcon
-%%PORTDOCS%%share/doc/tkcon/bindings.html
-%%PORTDOCS%%share/doc/tkcon/changes.txt
-%%PORTDOCS%%share/doc/tkcon/demopic.gif
-%%PORTDOCS%%share/doc/tkcon/dump.html
-%%PORTDOCS%%share/doc/tkcon/idebug.html
-%%PORTDOCS%%share/doc/tkcon/index.html
-%%PORTDOCS%%share/doc/tkcon/license.terms
-%%PORTDOCS%%share/doc/tkcon/limits.html
-%%PORTDOCS%%share/doc/tkcon/nontcl.html
-%%PORTDOCS%%share/doc/tkcon/observe.html
-%%PORTDOCS%%share/doc/tkcon/perl.txt
-%%PORTDOCS%%share/doc/tkcon/plugin.html
-%%PORTDOCS%%share/doc/tkcon/procs.html
-%%PORTDOCS%%share/doc/tkcon/purpose.html
-%%PORTDOCS%%share/doc/tkcon/start.html
-%%PORTDOCS%%share/doc/tkcon/tkcon.html
-%%PORTDOCS%%share/doc/tkcon/todo.html
-%%PORTDOCS%%share/doc/tkcon/style.css
-%%PORTDOCS%%@dirrm share/doc/tkcon