aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/cppi/Makefile30
-rw-r--r--devel/cppi/distinfo6
-rw-r--r--devel/cppi/pkg-descr3
4 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1d4865402cd5..9e82dd0b8343 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -171,6 +171,7 @@
SUBDIR += cook
SUBDIR += cpan-upload
SUBDIR += cppadvio
+ SUBDIR += cppi
SUBDIR += cppunit
SUBDIR += cproto
SUBDIR += crossgo32
diff --git a/devel/cppi/Makefile b/devel/cppi/Makefile
new file mode 100644
index 000000000000..75d819fcc72d
--- /dev/null
+++ b/devel/cppi/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: cppi
+# Date created: 2006-11-05
+# Whom: trasz <trasz@pin.if.uz.zgora.pl>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cppi
+PORTVERSION= 1.12
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= coreutils
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} ${DISTNAME}${EXTRACT_SUFX}.sig
+EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= A tool to indent the C preprocessor directives
+
+USE_GPG?= yes
+SIG_FILES= ${DISTNAME}${EXTRACT_SUFX}.sig
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --mandir=${PREFIX}/man
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LIBS="-L${LOCALBASE}/lib"
+
+PLIST_FILES= bin/cppi
+MAN1= cppi.1
+
+.include <bsd.port.mk>
diff --git a/devel/cppi/distinfo b/devel/cppi/distinfo
new file mode 100644
index 000000000000..528059be7c3d
--- /dev/null
+++ b/devel/cppi/distinfo
@@ -0,0 +1,6 @@
+MD5 (cppi-1.12.tar.bz2) = 3a9b8fa70cae2fb36b089a5f2ef4326f
+SHA256 (cppi-1.12.tar.bz2) = 8cde71a6f9c2555969deb2a691ca2b5b67b350a3ce15025e38754cee247c1f78
+SIZE (cppi-1.12.tar.bz2) = 272977
+MD5 (cppi-1.12.tar.bz2.sig) = 59729a91216b131c06c1e867883e42f8
+SHA256 (cppi-1.12.tar.bz2.sig) = 6cdd7869f3742e502adf9f3fe5ade720e0d8afb17328d6511bb3b9f691658576
+SIZE (cppi-1.12.tar.bz2.sig) = 189
diff --git a/devel/cppi/pkg-descr b/devel/cppi/pkg-descr
new file mode 100644
index 000000000000..d33bdc82026f
--- /dev/null
+++ b/devel/cppi/pkg-descr
@@ -0,0 +1,3 @@
+A tool to indent the C preprocessor directives to reflect their
+nesting and ensure that there is exactly one space character between
+each #if, #elif, #define directive and the following token.