aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--graphics/cimg/Makefile12
-rw-r--r--graphics/cimg/distinfo6
-rw-r--r--graphics/cimg/files/patch-examples::Makefile71
-rw-r--r--graphics/cimg/pkg-descr4
-rw-r--r--graphics/cimg/pkg-plist15
5 files changed, 36 insertions, 72 deletions
diff --git a/graphics/cimg/Makefile b/graphics/cimg/Makefile
index cd54af352bd2..09d1db127eae 100644
--- a/graphics/cimg/Makefile
+++ b/graphics/cimg/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= cimg
-PORTVERSION= 1.3.0
+PORTVERSION= 1.3.1
PORTEPOCH= 2
CATEGORIES= graphics devel
MASTER_SITES= SF
@@ -33,21 +33,17 @@ USE_FORTRAN= yes
LIB_DEPENDS+= png:${PORTSDIR}/graphics/png \
jpeg:${PORTSDIR}/graphics/jpeg \
tiff:${PORTSDIR}/graphics/tiff \
- Magick:${PORTSDIR}/graphics/ImageMagick \
gimp-2.0:${PORTSDIR}/graphics/gimp-app \
- fftw3:${PORTSDIR}/math/fftw3
+ fftw3:${PORTSDIR}/math/fftw3 \
+ GraphicsMagick++:${PORTSDIR}/graphics/GraphicsMagick
ALL_TARGET= oFreeBSD
. else
ALL_TARGET= dFreeBSD
-WITHOUT_GM= yes
WITHOUT_MEDCON= yes
WITHOUT_FFMPEG= yes
WITHOUT_LAPACK= yes
. endif
-. if !defined(WITHOUT_GM)
-RUN_DEPENDS+= gm:${PORTSDIR}/graphics/GraphicsMagick
-. endif
. if !defined(WITHOUT_MEDCON)
RUN_DEPENDS+= medcon:${PORTSDIR}/graphics/xmedcon
. endif
@@ -56,7 +52,7 @@ LIB_DEPENDS+= avformat.1:${PORTSDIR}/multimedia/ffmpeg
. endif
DOCBASE= CHANGES.txt README.txt
-PROGS= CImg_demo gmic use_jpeg_buffer greycstoration4gimp gmic4gimp
+PROGS= CImg_demo gmic use_jpeg_buffer
.else
NO_BUILD= yes
.endif
diff --git a/graphics/cimg/distinfo b/graphics/cimg/distinfo
index 5b44b17a2e3c..1dfc39e8970e 100644
--- a/graphics/cimg/distinfo
+++ b/graphics/cimg/distinfo
@@ -1,3 +1,3 @@
-MD5 (cimg-1.3.0,2/CImg_1.3.0.tar.gz) = af434dcaee6b940f5796fe2fa729c6cd
-SHA256 (cimg-1.3.0,2/CImg_1.3.0.tar.gz) = 804e024c01a55b61bd0128845f5ff1afe4d6037e9c711a616daf12e0b80e9348
-SIZE (cimg-1.3.0,2/CImg_1.3.0.tar.gz) = 7679999
+MD5 (cimg-1.3.1,2/CImg_1.3.1.tar.gz) = 834129e4dd4c18858bdfbab2a21fd520
+SHA256 (cimg-1.3.1,2/CImg_1.3.1.tar.gz) = 650f1ebdef5e3633d227cf6d6ec1c0292377827d9ccbec208521bf0e9972d651
+SIZE (cimg-1.3.1,2/CImg_1.3.1.tar.gz) = 8002209
diff --git a/graphics/cimg/files/patch-examples::Makefile b/graphics/cimg/files/patch-examples::Makefile
index 1ba85c216a23..1c2db223ef9d 100644
--- a/graphics/cimg/files/patch-examples::Makefile
+++ b/graphics/cimg/files/patch-examples::Makefile
@@ -1,17 +1,17 @@
---- examples/Makefile.orig 2009-02-17 13:08:45.000000000 +0100
-+++ examples/Makefile 2009-02-21 15:02:01.000000000 +0100
-@@ -78,8 +78,8 @@
+--- examples/Makefile.orig 2009-05-26 18:27:25.000000000 +0200
++++ examples/Makefile 2009-05-29 21:57:25.000000000 +0200
+@@ -77,8 +77,8 @@
# Set correct variables and paths
#---------------------------------
- CIMG_VERSION = 1.30
+ CIMG_VERSION = 1.31
-X11PATH = /usr/X11R6
-CC = g++
+#X11PATH = /usr/X11R6
-+#CC = g++
++CC = $(CXX)
CCVER = `$(CC) -v 2>&1 | tail -n 1`
EXEPFX =
-@@ -106,7 +106,7 @@
+@@ -105,7 +105,7 @@
ifeq ($(CC),icc)
CIMG_OPT_CFLAGS = -O3 -ipo -no-prec-div
else
@@ -20,7 +20,7 @@
endif
# Flags to enable OpenMP support.
-@@ -158,8 +158,8 @@
+@@ -157,8 +157,8 @@
# Flags to enable native support for various video files, using the FFMPEG library.
# ( http://www.ffmpeg.org/ )
@@ -31,7 +31,18 @@
# Flags to enable native support for compressed .cimgz files, using the Zlib library.
# ( http://www.zlib.net/ )
-@@ -182,14 +182,17 @@
+@@ -167,8 +167,8 @@
+
+ # Flags to enable native support of most classical image file formats, using the Magick++ library.
+ # ( http://www.imagemagick.org/Magick++/ )
+-CIMG_MAGICK_CFLAGS = -Dcimg_use_magick `Magick++-config --cppflags` `Magick++-config --cxxflags`
+-CIMG_MAGICK_LDFLAGS = `Magick++-config --ldflags` `Magick++-config --libs`
++CIMG_MAGICK_CFLAGS = -Dcimg_use_magick `GraphicsMagick++-config --cppflags` `GraphicsMagick++-config --cxxflags`
++CIMG_MAGICK_LDFLAGS = `GraphicsMagick++-config --ldflags` `GraphicsMagick++-config --libs`
+
+ # Flags to enable faster Discrete Fourier Transform computation, using the FFTW3 library
+ # ( http://www.fftw.org/ )
+@@ -181,14 +181,17 @@
# Flags to enable the use of LAPACK routines for matrix computation
# ( http://www.netlib.org/lapack/ )
@@ -52,16 +63,7 @@
# Flags to compile on Sun Solaris
CIMG_SOLARIS_LDFLAGS = -R$(X11PATH)/lib -lrt -lnsl -lsocket
-@@ -205,7 +208,7 @@
- @echo
- @echo "** Compiling '$* ($(CIMG_VERSION))' with '`$(CC) -v 2>&1 | tail -n 1`'"
- @echo
-- $(CC) -o $(EXEPFX)$* $< $(CFLAGS) $(LDFLAGS) $(CONF_CFLAGS) $(CONF_LDFLAGS)
-+ $(CXX) -o $(EXEPFX)$* $< $(CFLAGS) $(LDFLAGS) $(CONF_CFLAGS) $(CONF_LDFLAGS)
- ifeq ($(MACOSX_APP),true)
- mkdir -p $(EXEPFX)${*}.app/Contents/MacOS
- mv $(EXEPFX)${*} $(EXEPFX)${*}.app/Contents/MacOS
-@@ -227,6 +230,9 @@
+@@ -226,6 +229,9 @@
@echo " > mlinux : Linus/BSD/MacOSX target, no display, minimal features, optimizations enabled."
@echo " > Mlinux : Linux/BSD/MacOSX target, X11 display, maximal features, optimizations enabled."
@echo
@@ -71,36 +73,9 @@
@echo " > solaris : Sun Solaris target, X11 display, optimizations disabled."
@echo " > dsolaris : Sun Solaris target, X11 display, debug mode."
@echo " > osolaris : Sun Solaris target, X11 display, optimizations enabled."
-@@ -270,7 +276,7 @@
- @echo
- @echo "** Compiling 'greycstoration4gimp ($(CIMG_VERSION))' with '$(CCVER)'"
- @echo
-- $(CC) -I.. -I./plugins -o $(EXEPFX)greycstoration4gimp greycstoration4gimp.cpp `gimptool-2.0 --cflags` `gimptool-2.0 --libs` -lpthread $(CIMG_OPT_CFLAGS) $(CIMG_GIMP_CFLAGS)
-+ $(CXX) -I.. -I./plugins -o $(EXEPFX)greycstoration4gimp greycstoration4gimp.cpp `gimptool-2.0 --cflags` `gimptool-2.0 --libs` -lpthread $(CIMG_OPT_CFLAGS) $(CIMG_GIMP_CFLAGS)
-
- # Specific targets for the 'gmic4gimp' plug-in for GIMP.
- gmic4gimp_def: gmic4gimp_def.raw
-@@ -281,7 +287,7 @@
- $(CC) -I.. -o gmic4gimp.o -c gmic.cpp -Dgmic_minimal $(CIMG_OPT_CFLAGS) $(CIMG_FFTW3_CFLAGS)
-
- gmic4gimp: gmic4gimp.o gmic4gimp.cpp
-- $(CC) -I.. -I./plugins -o $(EXEPFX)gmic4gimp gmic4gimp.cpp gmic4gimp.o `gimptool-2.0 --cflags` `gimptool-2.0 --libs` -lpthread $(CIMG_OPT_FLAGS) $(CIMG_FFTW3_LDFLAGS) $(CIMG_GIMP_CFLAGS)
-+ $(CXX) -I.. -I./plugins -o $(EXEPFX)gmic4gimp gmic4gimp.cpp gmic4gimp.o `gimptool-2.0 --cflags` `gimptool-2.0 --libs` -lpthread $(CIMG_OPT_CFLAGS) $(CIMG_FFTW3_LDFLAGS) $(CIMG_GIMP_CFLAGS)
-
- # Specific targets for 'gmic'.
- gmic_def: gmic_def.raw
-@@ -309,7 +315,7 @@
- gmic_double.o: gmic.cpp
- $(CC) -o gmic_double.o -c gmic.cpp -I. -Dgmic_separate_compilation -Dgmic_double $(CFLAGS) $(CONF_CFLAGS)
- gmic: gmic_bool.o gmic_uchar.o gmic_char.o gmic_ushort.o gmic_short.o gmic_uint.o gmic_int.o gmic_float.o gmic_double.o gmic.cpp
-- $(CC) -o $(EXEPFX)gmic gmic.cpp -I. -Dgmic_separate_compilation -Dgmic_main \
-+ $(CXX) -o $(EXEPFX)gmic gmic.cpp -I. -Dgmic_separate_compilation -Dgmic_main \
- gmic_bool.o gmic_uchar.o gmic_char.o gmic_ushort.o gmic_short.o \
- gmic_uint.o gmic_int.o gmic_float.o gmic_double.o $(CFLAGS) $(LDFLAGS) $(CONF_CFLAGS) $(CONF_LDFLAGS)
-
-@@ -399,6 +405,56 @@
+@@ -393,6 +399,56 @@
"STRIP_EXE=true" \
- all use_jpeg_buffer greycstoration4gimp gmic4gimp
+ all use_jpeg_buffer gmic4gimp gmic
+# FreeBSD targets
+dFreeBSD:
@@ -150,7 +125,7 @@
+$(CIMG_LAPACK_LDFLAGS) \
+$(CIMG_FFTW3_LDFLAGS)" \
+"STRIP_EXE=true" \
-+all use_jpeg_buffer greycstoration4gimp gmic4gimp
++all use_jpeg_buffer gmic
+
# Sun Solaris targets, with X11 display.
solaris:
diff --git a/graphics/cimg/pkg-descr b/graphics/cimg/pkg-descr
index b5c5a5737541..ea8ce3d19ac8 100644
--- a/graphics/cimg/pkg-descr
+++ b/graphics/cimg/pkg-descr
@@ -14,8 +14,8 @@ CImg stands for Cool Image: it is simple to use and efficient.
template pixel types.
. It depends on a minimal number of libraries: you can compile it with only
standard C libraries. No need for exotic libraries and complex dependencies.
-. Additional features appear with the use of ImageMagick: install the
- ImageMagick package to be able to load and save compressed image formats
+. Additional features appear with the use of GraphicsMagick: install the
+ GraphicsMagick package to be able to load and save compressed image formats
(GIF,BMP,TIF,JPG,PNG,...).
. Additional features appear with the use of LAPACK: link your code with the
lapack library to be able to compute eigenvalues or eigenvectors of big
diff --git a/graphics/cimg/pkg-plist b/graphics/cimg/pkg-plist
index 07445ac24b83..36db8246e885 100644
--- a/graphics/cimg/pkg-plist
+++ b/graphics/cimg/pkg-plist
@@ -1,7 +1,5 @@
%%PORTDOCS%%bin/CImg_demo
%%PORTDOCS%%bin/gmic
-%%PORTDOCS%%bin/gmic4gimp
-%%PORTDOCS%%bin/greycstoration4gimp
%%PORTDOCS%%bin/use_jpeg_buffer
include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/CHANGES.txt
@@ -58,6 +56,8 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/img/logoODYSSEE.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard1.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard10.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard11.jpg
+%%PORTDOCS%%%%DOCSDIR%%/img/postcard12.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard2.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard3.jpg
%%PORTDOCS%%%%DOCSDIR%%/img/postcard4.jpg
@@ -148,7 +148,6 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/news.shtml
%%PORTDOCS%%%%DOCSDIR%%/reference/annotated.html
%%PORTDOCS%%%%DOCSDIR%%/reference/classes.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/closed.gif
%%PORTDOCS%%%%DOCSDIR%%/reference/doxygen.css
%%PORTDOCS%%%%DOCSDIR%%/reference/doxygen.png
%%PORTDOCS%%%%DOCSDIR%%/reference/form_0.png
@@ -156,7 +155,6 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/form_2.png
%%PORTDOCS%%%%DOCSDIR%%/reference/formula.repository
%%PORTDOCS%%%%DOCSDIR%%/reference/functions.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x61.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x62.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x63.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x64.html
@@ -182,7 +180,6 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x79.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_0x7e.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x61.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x62.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x63.html
%%PORTDOCS%%%%DOCSDIR%%/reference/functions_func_0x64.html
@@ -233,7 +230,6 @@ include/CImg.h
%%PORTDOCS%%%%DOCSDIR%%/reference/namespacemembers_func.html
%%PORTDOCS%%%%DOCSDIR%%/reference/namespacemembers_vars.html
%%PORTDOCS%%%%DOCSDIR%%/reference/namespaces.html
-%%PORTDOCS%%%%DOCSDIR%%/reference/open.gif
%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImg-members.html
%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImg.html
%%PORTDOCS%%%%DOCSDIR%%/reference/structcimg__library_1_1CImgDisplay-members.html
@@ -255,16 +251,13 @@ include/CImg.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/dtmri_view.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/edge_explorer.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fade_images.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gaussian_fit.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/generate_loop_macros.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gmic.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gmic.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gmic4gimp.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gmic4gimp_def.h
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gmic4gimp_def.raw
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gmic_def.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/gmic_def.raw
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/greycstoration.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/greycstoration4gimp.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/hough_transform.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/image2ascii.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/image_registration.cpp
@@ -285,6 +278,7 @@ include/CImg.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/odykill.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pde_TschumperleDeriche2d.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/pde_heatflow2d.cpp
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/plotter.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/radon_transform.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/scene3d.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tetris.cpp
@@ -295,7 +289,6 @@ include/CImg.h
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_cimgmatlab.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_cimgmatlab.m
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_draw_gradient.cpp
-%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_greycstoration.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_jpeg_buffer.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_nlmeans.cpp
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/use_skeleton.cpp