aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/entity/Makefile3
-rw-r--r--devel/gcvs/Makefile3
-rw-r--r--devel/glg/Makefile6
-rw-r--r--devel/gnome-devel/Makefile3
-rw-r--r--devel/mico/Makefile3
-rw-r--r--devel/ruby-gconf/Makefile3
-rw-r--r--devel/ruby-gconf2/Makefile3
-rw-r--r--devel/sdl12/Makefile3
-rw-r--r--devel/titano/Makefile3
-rw-r--r--devel/veepee/Makefile3
10 files changed, 21 insertions, 12 deletions
diff --git a/devel/entity/Makefile b/devel/entity/Makefile
index 5551a1af829a..40b237e38f76 100644
--- a/devel/entity/Makefile
+++ b/devel/entity/Makefile
@@ -19,7 +19,8 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-tcl=no
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
INSTALLS_SHLIB= yes
MAN1= entity.1
diff --git a/devel/gcvs/Makefile b/devel/gcvs/Makefile
index dd153e131f90..840108010a19 100644
--- a/devel/gcvs/Makefile
+++ b/devel/gcvs/Makefile
@@ -21,7 +21,8 @@ BUILD_DEPENDS+= wish8.3:${PORTSDIR}/x11-toolkits/tk83
RUN_DEPENDS+= wish8.3:${PORTSDIR}/x11-toolkits/tk83
USE_X_PREFIX= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
GNU_CONFIGURE= yes
USE_GMAKE= yes
BREAKS_IF_PEDANTIC= yes
diff --git a/devel/glg/Makefile b/devel/glg/Makefile
index 82e206cc22df..41424c966118 100644
--- a/devel/glg/Makefile
+++ b/devel/glg/Makefile
@@ -17,13 +17,13 @@ MASTER_SITE_SUBDIR= kris
MAINTAINER= lo_gafet@users.sourceforge.net
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
WANT_GNOME= yes
.include <bsd.port.pre.mk>
-.if defined(HAVE_GNOME)
-USE_GNOME= yes
+.if ${HAVE_GNOME:Mgnomelibs}!=""
+USE_GNOME= gtk12
.endif
pre-build:
diff --git a/devel/gnome-devel/Makefile b/devel/gnome-devel/Makefile
index 266495915a05..270bd6dbc15a 100644
--- a/devel/gnome-devel/Makefile
+++ b/devel/gnome-devel/Makefile
@@ -21,7 +21,8 @@ LIB_DEPENDS= gal:${PORTSDIR}/x11-toolkits/gal \
BROKEN= "Needs more work on the dependency chain"
NO_BUILD= yes
-USE_GNOMELIBS= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomelibs
USE_PYTHON= yes
do-install: # empty
diff --git a/devel/mico/Makefile b/devel/mico/Makefile
index 6ee1bf3cf6e9..186c19b44cad 100644
--- a/devel/mico/Makefile
+++ b/devel/mico/Makefile
@@ -34,7 +34,8 @@ BROKEN= "Needs someone to test with Qt2 support as Qt1 is gone."
INSTALLS_SHLIB= yes
USE_NEWGCC= yes
USE_GMAKE= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
USE_AUTOCONF= yes
CONFIGURE_ARGS= --with-qt --with-gtk --with-tcl --disable-mini-stl \
--enable-static --enable-shared
diff --git a/devel/ruby-gconf/Makefile b/devel/ruby-gconf/Makefile
index 73294a36c710..9a121a2c5dca 100644
--- a/devel/ruby-gconf/Makefile
+++ b/devel/ruby-gconf/Makefile
@@ -20,7 +20,8 @@ LIB_DEPENDS= gconf-gtk-1.1:${PORTSDIR}/devel/gconf
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
CONFIGURE_ARGS= --with-gtk-config=${GTK_CONFIG}
INSTALL_TARGET= site-install
diff --git a/devel/ruby-gconf2/Makefile b/devel/ruby-gconf2/Makefile
index 73294a36c710..9a121a2c5dca 100644
--- a/devel/ruby-gconf2/Makefile
+++ b/devel/ruby-gconf2/Makefile
@@ -20,7 +20,8 @@ LIB_DEPENDS= gconf-gtk-1.1:${PORTSDIR}/devel/gconf
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
-USE_GTK= yes
+USE_GNOMENG= yes
+USE_GNOME= gtk12
CONFIGURE_ARGS= --with-gtk-config=${GTK_CONFIG}
INSTALL_TARGET= site-install
diff --git a/devel/sdl12/Makefile b/devel/sdl12/Makefile
index 8b6536285a3f..e343e127098d 100644
--- a/devel/sdl12/Makefile
+++ b/devel/sdl12/Makefile
@@ -41,7 +41,8 @@ DISPLAY_MSG= ${DO_NADA}
USE_XLIB= yes
.endif
.if !defined(WITHOUT_ESOUND)
-USE_ESOUND= yes
+USE_GNOMENG= yes
+USE_GNOME= esound
.endif
.if defined(WITHOUT_GL)
CONFIGURE_ARGS+=--disable-video-opengl
diff --git a/devel/titano/Makefile b/devel/titano/Makefile
index 85dbe96d78c6..c9aed73067a3 100644
--- a/devel/titano/Makefile
+++ b/devel/titano/Makefile
@@ -19,7 +19,8 @@ LIB_DEPENDS= gtkeditor.0:${PORTSDIR}/x11-toolkits/libgtkeditor
WRKSRC= ${WRKDIR}/${DISTNAME:S/b//}
USE_REINPLACE= yes
-USE_GNOMELIBS= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomelibs
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_LIBTOOL= yes
diff --git a/devel/veepee/Makefile b/devel/veepee/Makefile
index c6b4b4d763f6..7e98949881ad 100644
--- a/devel/veepee/Makefile
+++ b/devel/veepee/Makefile
@@ -18,7 +18,8 @@ BROKEN= "Does not build"
LIB_DEPENDS= gd.2:${PORTSDIR}/graphics/gd
-USE_GNOMELIBS= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomelibs
USE_XLIB= yes
USE_PYTHON= yes
USE_LIBTOOL= yes