aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/tclxml/Makefile21
-rw-r--r--devel/tclxml/distinfo6
-rw-r--r--devel/tclxml/files/patch-configure15
-rw-r--r--devel/tclxml/files/patch-library-pkgIndex.tcl.in14
-rw-r--r--devel/tclxml/pkg-descr3
-rw-r--r--devel/tclxml/pkg-plist4
6 files changed, 46 insertions, 17 deletions
diff --git a/devel/tclxml/Makefile b/devel/tclxml/Makefile
index 0c57ebdf38d7..1b8983d07bc5 100644
--- a/devel/tclxml/Makefile
+++ b/devel/tclxml/Makefile
@@ -6,22 +6,23 @@
#
PORTNAME= tclxml
-PORTVERSION= 2.6
-CATEGORIES= devel
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+PORTVERSION= 3.1
+CATEGORIES= devel tcl
+MASTER_SITES= SF
MASTER_SITE_SUBDIR= tclxml
-MAINTAINER= dyeske@gmail.com
+MAINTAINER?= dyeske@gmail.com
COMMENT= API for parsing XML documents using Tcl
-BUILD_DEPENDS= tclsh8.4:${PORTSDIR}/lang/tcl84
-RUN_DEPENDS= tclsh8.4:${PORTSDIR}/lang/tcl84 \
- dtplite:${PORTSDIR}/devel/tcllib
+RUN_DEPENDS?= dtplite:${PORTSDIR}/devel/tcllib
+USE_TCL= 82+
GNU_CONFIGURE= yes
-USE_LDCONFIG= yes
-CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl8.4 \
- --with-tclinclude=${LOCALBASE}/include/tcl8.4
+USE_LDCONFIG?= ${PREFIX}/lib/Tclxml${PORTVERSION}
+CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
+ --with-tclinclude=${TCL_INCLUDEDIR}
+PLIST= ${PKGDIR}${PKGNAMESUFFIX}/pkg-plist
+PATCHDIR= ${PKGDIR}${PKGNAMESUFFIX}/files/
PLIST_SUB= VER=${PORTVERSION}
.include <bsd.port.mk>
diff --git a/devel/tclxml/distinfo b/devel/tclxml/distinfo
index 99a154da7ba7..64aa02e00472 100644
--- a/devel/tclxml/distinfo
+++ b/devel/tclxml/distinfo
@@ -1,3 +1,3 @@
-MD5 (tclxml-2.6.tar.gz) = a54d1d6965e2123529e80d2a7ed251ec
-SHA256 (tclxml-2.6.tar.gz) = 50cce1212cb496fa27bb2ad8950fef726317cee762665fdfd08e352bd6a76bcd
-SIZE (tclxml-2.6.tar.gz) = 423406
+MD5 (tclxml-3.1.tar.gz) = 35de63a4ceba7a6fdb85dd1a62f2e881
+SHA256 (tclxml-3.1.tar.gz) = 9b017f29c7a06fa1a57d1658bd1d3867297c26013604bdcc4d7b0ca2333552c9
+SIZE (tclxml-3.1.tar.gz) = 489568
diff --git a/devel/tclxml/files/patch-configure b/devel/tclxml/files/patch-configure
new file mode 100644
index 000000000000..b8fdfc038b79
--- /dev/null
+++ b/devel/tclxml/files/patch-configure
@@ -0,0 +1,15 @@
+Due to the portbuildmechanism, the original TCL_SRC_DIR is not available
+at buildtime of this port, but the private headers that we are actually
+looking for can also be found in the include directory.
+
+--- configure.orig 2005-11-04 07:26:33.000000000 +0100
++++ configure 2008-04-27 23:30:44.000000000 +0200
+@@ -3183,7 +3183,7 @@
+
+ TCL_INCLUDES=-I\"${INCLUDE_DIR_NATIVE}\"
+
+-
++ TCL_SRC_DIR=${with_tclinclude}
+
+
+ echo $ac_n "checking for Tcl private include files""... $ac_c" 1>&6
diff --git a/devel/tclxml/files/patch-library-pkgIndex.tcl.in b/devel/tclxml/files/patch-library-pkgIndex.tcl.in
new file mode 100644
index 000000000000..037688168956
--- /dev/null
+++ b/devel/tclxml/files/patch-library-pkgIndex.tcl.in
@@ -0,0 +1,14 @@
+No clue what went wrong here..
+This patch just avoids the warning message, it would work without it aswell.
+
+--- library/pkgIndex.tcl.in.orig 2008-04-27 23:48:07.000000000 +0200
++++ library/pkgIndex.tcl.in 2008-04-27 23:48:13.000000000 +0200
+@@ -4,7 +4,7 @@
+
+ package ifneeded xml::c @VERSION@ [list load [file join $dir @Tclxml_LIB_FILE@]]
+ package ifneeded xml::tcl @VERSION@ [list source [file join $dir xml__tcl.tcl]]
+-package ifneeded sgmlparser 1.1 [list source [file join $dir sgmlparser.tcl]]
++package ifneeded sgmlparser 1.0 [list source [file join $dir sgmlparser.tcl]]
+ package ifneeded xpath 1.0 [list source [file join $dir xpath.tcl]]
+ package ifneeded xmldep 1.0 [list source [file join $dir xmldep.tcl]]
+
diff --git a/devel/tclxml/pkg-descr b/devel/tclxml/pkg-descr
index 23e19060b099..032c8060e3e3 100644
--- a/devel/tclxml/pkg-descr
+++ b/devel/tclxml/pkg-descr
@@ -6,6 +6,3 @@ will be able to use different parser implementations without change
to the application code.
WWW: http://tclxml.sourceforge.net/
-
-- David
-dyeske@gmail.com
diff --git a/devel/tclxml/pkg-plist b/devel/tclxml/pkg-plist
index 91a226e92e78..c6c471f4a024 100644
--- a/devel/tclxml/pkg-plist
+++ b/devel/tclxml/pkg-plist
@@ -1,4 +1,5 @@
-include/tclxml.h
+include/tclxml/tclxml.h
+include/tclxml/tclxmlDecls.h
lib/TclxmlConfig.sh
lib/Tclxml%%VER%%/libTclxml%%VER%%.so
lib/Tclxml%%VER%%/libTclxmlstub%%VER%%.a
@@ -13,3 +14,4 @@ lib/Tclxml%%VER%%/xml-8.0.tcl
lib/Tclxml%%VER%%/xml-8.1.tcl
lib/Tclxml%%VER%%/xpath.tcl
@dirrm lib/Tclxml%%VER%%
+@dirrm include/tclxml