aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--games/warzone2100/Makefile5
-rw-r--r--games/warzone2100/distinfo6
-rw-r--r--games/warzone2100/files/patch-lib_exceptionhandler_exceptionhandler.cpp10
-rw-r--r--games/warzone2100/files/patch-lib_netplay_netplay.cpp11
-rw-r--r--games/warzone2100/files/patch-src_scripttabs.cpp11
-rw-r--r--games/warzone2100/pkg-plist1
6 files changed, 27 insertions, 17 deletions
diff --git a/games/warzone2100/Makefile b/games/warzone2100/Makefile
index ec6b531dd977..633a59e54457 100644
--- a/games/warzone2100/Makefile
+++ b/games/warzone2100/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= warzone2100
-PORTVERSION= 3.2.2
-PORTREVISION= 1
+PORTVERSION= 3.2.3
CATEGORIES= games
MASTER_SITES= SF/${PORTNAME}/releases/${PORTVERSION}/
@@ -53,6 +52,6 @@ post-patch:
@${REINPLACE_CMD} -e '/INSTALL_DATA.*warzone2100.appdata.xml/d' ${WRKSRC}/icons/Makefile.*
post-install:
- @${RMDIR} ${STAGEDIR}${PREFIX}/share/appdata
+ @${RMDIR} ${STAGEDIR}${PREFIX}/share/metainfo
.include <bsd.port.mk>
diff --git a/games/warzone2100/distinfo b/games/warzone2100/distinfo
index 63dd9a9f144c..4e07ea74b597 100644
--- a/games/warzone2100/distinfo
+++ b/games/warzone2100/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1481277103
-SHA256 (warzone2100-3.2.2.tar.xz) = af5a8dfe9e9df3505ef2543e4e62afb1f61a4ee4cc903f8ff7785f3c79779d18
-SIZE (warzone2100-3.2.2.tar.xz) = 81296832
+TIMESTAMP = 1493412166
+SHA256 (warzone2100-3.2.3.tar.xz) = fcab9e860203e7dacda6ee60384da490a9d44aeafc07aa31ff25f9c548be7582
+SIZE (warzone2100-3.2.3.tar.xz) = 81314060
diff --git a/games/warzone2100/files/patch-lib_exceptionhandler_exceptionhandler.cpp b/games/warzone2100/files/patch-lib_exceptionhandler_exceptionhandler.cpp
new file mode 100644
index 000000000000..adf5a53fe39d
--- /dev/null
+++ b/games/warzone2100/files/patch-lib_exceptionhandler_exceptionhandler.cpp
@@ -0,0 +1,10 @@
+--- lib/exceptionhandler/exceptionhandler.cpp.orig 2017-04-23 13:12:16 UTC
++++ lib/exceptionhandler/exceptionhandler.cpp
+@@ -120,6 +120,7 @@ static LONG WINAPI windowsExceptionHandl
+
+ // POSIX headers:
+ # include <unistd.h>
++# include <errno.h>
+ # include <fcntl.h>
+ # include <time.h>
+ # include <sys/types.h>
diff --git a/games/warzone2100/files/patch-lib_netplay_netplay.cpp b/games/warzone2100/files/patch-lib_netplay_netplay.cpp
new file mode 100644
index 000000000000..3b1d7917a9ae
--- /dev/null
+++ b/games/warzone2100/files/patch-lib_netplay_netplay.cpp
@@ -0,0 +1,11 @@
+--- lib/netplay/netplay.cpp.orig 2017-04-23 13:12:16 UTC
++++ lib/netplay/netplay.cpp
+@@ -1783,7 +1783,7 @@ static void NETcheckPlayers(void)
+ // We should not block here.
+ bool NETrecvNet(NETQUEUE *queue, uint8_t *type)
+ {
+- switch (upnp_status)
++ switch ((int)upnp_status)
+ {
+ case UPNP_ERROR_CONTROL_NOT_AVAILABLE:
+ case UPNP_ERROR_DEVICE_NOT_FOUND:
diff --git a/games/warzone2100/files/patch-src_scripttabs.cpp b/games/warzone2100/files/patch-src_scripttabs.cpp
deleted file mode 100644
index 450b8650a4ef..000000000000
--- a/games/warzone2100/files/patch-src_scripttabs.cpp
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/scripttabs.cpp.orig 2016-05-07 17:45:17 UTC
-+++ src/scripttabs.cpp
-@@ -108,7 +108,7 @@ TYPE_SYMBOL asTypeTable[] =
- { "", (INTERP_TYPE)ST_POINTER_STRUCTSTAT, AT_SIMPLE, NULL, NULL }, //for NULLSTRUCTURESTAT
-
- /* This final entry marks the end of the type list */
-- { "END OF TYPE LIST", (INTERP_TYPE)NULL, AT_SIMPLE, NULL, NULL },
-+ { "END OF TYPE LIST", (INTERP_TYPE)0, AT_SIMPLE, NULL, NULL },
- };
-
-
diff --git a/games/warzone2100/pkg-plist b/games/warzone2100/pkg-plist
index 7c99c1ed388e..68ff1be6d45a 100644
--- a/games/warzone2100/pkg-plist
+++ b/games/warzone2100/pkg-plist
@@ -8,6 +8,7 @@ share/icons/warzone2100.png
%%NLS%%share/locale/de/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/el/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/en_GB/LC_MESSAGES/warzone2100.mo
+%%NLS%%share/locale/eo/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/es/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/et_EE/LC_MESSAGES/warzone2100.mo
%%NLS%%share/locale/fi/LC_MESSAGES/warzone2100.mo