aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--audio/streamripper/Makefile3
-rw-r--r--lang/munger/Makefile4
-rw-r--r--mail/crm114/Makefile3
-rw-r--r--mail/dkim-milter/Makefile1
-rw-r--r--mail/lmtpd/Makefile1
-rw-r--r--mail/opendkim/Makefile1
-rw-r--r--textproc/msort/Makefile18
-rw-r--r--www/drood/Makefile3
8 files changed, 28 insertions, 6 deletions
diff --git a/audio/streamripper/Makefile b/audio/streamripper/Makefile
index 49bf35a6f77f..3096a37ad2c7 100644
--- a/audio/streamripper/Makefile
+++ b/audio/streamripper/Makefile
@@ -7,6 +7,7 @@
PORTNAME= streamripper
PORTVERSION= 1.64.6
+PORTREVISION= 1
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}%20%28current%29/${PORTVERSION} \
http://gd.tuwien.ac.at/hci/cdk/:cdk
@@ -18,7 +19,7 @@ MAINTAINER= sylvio@FreeBSD.org
COMMENT= Splits SHOUTcast stream into tracks
LIB_DEPENDS= mad.2:${PORTSDIR}/audio/libmad \
- tre.6:${PORTSDIR}/textproc/libtre
+ tre.5:${PORTSDIR}/textproc/libtre
OPTIONS= FAAD "Include FAAD mpeg4 codec support" on \
VORBIS "Include Ogg Vorbis codec support" on
diff --git a/lang/munger/Makefile b/lang/munger/Makefile
index 1c71e3c87b3d..e944318edd06 100644
--- a/lang/munger/Makefile
+++ b/lang/munger/Makefile
@@ -7,12 +7,14 @@
PORTNAME= munger
PORTVERSION= 4.173
+PORTREVISION= 1
CATEGORIES= lang
MASTER_SITES= http://www.mammothcheese.ca/
MAINTAINER= jimmy@mammothcheese.ca
COMMENT= Static lisp interpreter with text processing abilities
-LIB_DEPENDS= tre.6:${PORTSDIR}/textproc/libtre
+
+LIB_DEPENDS= tre.5:${PORTSDIR}/textproc/libtre
DATADIR= ${PREFIX}/share/${PORTNAME}-${PORTVERSION}
diff --git a/mail/crm114/Makefile b/mail/crm114/Makefile
index 43c9c0c5f097..5a884cbc3c7b 100644
--- a/mail/crm114/Makefile
+++ b/mail/crm114/Makefile
@@ -6,6 +6,7 @@
PORTNAME= crm114
PORTVERSION= 20090423
+PORTREVISION= 1
# WARNING change versionname in CRM114RELEASENAME too.
# portlint didn't like this variable at this place.
# So I have to put it down in this file.
@@ -19,7 +20,7 @@ DISTNAME= ${PORTNAME}-200904023-${CRM114RELEASENAME}.src
MAINTAINER= chalpin@cs.wisc.edu
COMMENT= A Markov based SpamFilter
-LIB_DEPENDS= tre.6:${PORTSDIR}/textproc/libtre
+LIB_DEPENDS= tre.5:${PORTSDIR}/textproc/libtre
CRM114RELEASENAME=BlameSteveJobs
diff --git a/mail/dkim-milter/Makefile b/mail/dkim-milter/Makefile
index f7eb582d859c..8bd4386db59e 100644
--- a/mail/dkim-milter/Makefile
+++ b/mail/dkim-milter/Makefile
@@ -14,6 +14,7 @@
PORTNAME= dkim-milter
PORTVERSION= 2.8.3
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= SF/${PORTNAME}/DKIM%20Milter/${PORTVERSION}
diff --git a/mail/lmtpd/Makefile b/mail/lmtpd/Makefile
index 55dd2ddb0175..95ce19a26d62 100644
--- a/mail/lmtpd/Makefile
+++ b/mail/lmtpd/Makefile
@@ -7,6 +7,7 @@
PORTNAME= lmtpd
PORTVERSION= 0.10.6
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= ftp://ftp.oav.net/pll/ SF/pll/${PORTNAME}/${PORTVERSION}
diff --git a/mail/opendkim/Makefile b/mail/opendkim/Makefile
index 16a20d98801a..ed607b5af877 100644
--- a/mail/opendkim/Makefile
+++ b/mail/opendkim/Makefile
@@ -7,6 +7,7 @@
PORTNAME= opendkim
PORTVERSION= 1.1.2
+PORTREVISION= 1
CATEGORIES= mail security
MASTER_SITES= SF/opendkim
diff --git a/textproc/msort/Makefile b/textproc/msort/Makefile
index 53fbf9f246dd..2318632574b9 100644
--- a/textproc/msort/Makefile
+++ b/textproc/msort/Makefile
@@ -7,7 +7,7 @@
PORTNAME= msort
PORTVERSION= 8.52
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= http://billposer.org/Software/Downloads/
@@ -19,7 +19,8 @@ LIB_DEPENDS= tre:${PORTSDIR}/textproc/libtre \
utf8proc:${PORTSDIR}/textproc/utf8proc
RUN_DEPENDS= iwidgets>=0:${PORTSDIR}/x11-toolkits/iwidgets
-CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include"
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib" CPPFLAGS="-I${LOCALBASE}/include" \
+ ac_cv_lib_tre_regwcomp=yes
MAKE_ENV+= INCLUDES="-I${LOCALBASE}/include"
GNU_CONFIGURE= yes
USE_TK_RUN= yes
@@ -30,4 +31,17 @@ PLIST_FILES= bin/msg bin/msort
MAN1= msort.1
+.ifdef(MAINTAINER_MODE)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/bash:${PORTSDIR}/shells/bash
+
+post-patch:
+ ${REINPLACE_CMD} -e "s|bash|${LOCALBASE}/bin/bash|g" ${WRKSRC}/RegressionTests/Makefile
+ ${REINPLACE_CMD} -e "s|msort|../&|g" ${WRKSRC}/RegressionTests/RunTests.sh \
+ ${WRKSRC}/RegressionTests/RunLocaleTests.sh
+
+test: build
+ @(cd ${WRKSRC} ; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_ARGS} test)
+
+.endif
+
.include <bsd.port.mk>
diff --git a/www/drood/Makefile b/www/drood/Makefile
index a925e03310af..84725d70cc75 100644
--- a/www/drood/Makefile
+++ b/www/drood/Makefile
@@ -7,12 +7,13 @@
PORTNAME= drood
PORTVERSION= 1.51
+PORTREVISION= 1
CATEGORIES= www
MASTER_SITES= http://www.mammothcheese.ca/
MAINTAINER= jimmy@mammothcheese.ca
COMMENT= Lightweight kqueue-based http/1.1 server
-LIB_DEPENDS= tre.6:${PORTSDIR}/textproc/libtre
+LIB_DEPENDS= tre.5:${PORTSDIR}/textproc/libtre
MAN8= drood.8 scgid.8