aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/linux-understand_ada/Makefile2
-rw-r--r--devel/linux-understand_c/Makefile2
-rw-r--r--devel/understand_ada/Makefile2
-rw-r--r--devel/understand_c/Makefile2
4 files changed, 8 insertions, 0 deletions
diff --git a/devel/linux-understand_ada/Makefile b/devel/linux-understand_ada/Makefile
index b018cd72421e..af645c890826 100644
--- a/devel/linux-understand_ada/Makefile
+++ b/devel/linux-understand_ada/Makefile
@@ -21,6 +21,7 @@ NO_BUILD= yes
PREFIX_LINUX?= ${LINUXBASE}
STRIP= ${LINUXBASE}/usr/bin/strip
+BRANDELF?= /usr/bin/brandelf
FMT?= /usr/bin/fmt
INSTALL_DATA_DIR?= ${INSTALL} -d -o ${SHAREOWN} \
-g ${SHAREGRP} -m 755
@@ -103,6 +104,7 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/bin/pc-linux_elf/${file} \
${PREFIX}/lib/${PORTNAME}/bin/pc-linux_elf
@${STRIP} ${PREFIX}/lib/${PORTNAME}/bin/pc-linux_elf/${file}
+ @${BRANDELF} -t Linux ${PREFIX}/lib/${PORTNAME}/bin/pc-linux_elf/${file}
@if [ ! -f ${PREFIX}/bin/${file} ]; \
then \
${LN} -sf ${PORTNAME} ${PREFIX}/bin/${file} ; \
diff --git a/devel/linux-understand_c/Makefile b/devel/linux-understand_c/Makefile
index 0ccbda883580..f6187dc59742 100644
--- a/devel/linux-understand_c/Makefile
+++ b/devel/linux-understand_c/Makefile
@@ -22,6 +22,7 @@ NO_BUILD= yes
PREFIX_LINUX?= ${LINUXBASE}
STRIP= ${LINUXBASE}/usr/bin/strip
+BRANDELF?= /usr/bin/brandelf
FMT?= /usr/bin/fmt
CONF_DIRS= compilers configs fonts license
@@ -100,6 +101,7 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/bin/pc-linux_elf/${file} \
${PREFIX}/lib/understand_c/bin/pc-linux_elf
@${STRIP} ${PREFIX}/lib/understand_c/bin/pc-linux_elf/${file}
+ @${BRANDELF} -t Linux ${PREFIX}/lib/understand_c/bin/pc-linux_elf/${file}
@if [ ! -f ${PREFIX}/bin/${file} ]; \
then \
${LN} -sf understand_c ${PREFIX}/bin/${file} ; \
diff --git a/devel/understand_ada/Makefile b/devel/understand_ada/Makefile
index b018cd72421e..af645c890826 100644
--- a/devel/understand_ada/Makefile
+++ b/devel/understand_ada/Makefile
@@ -21,6 +21,7 @@ NO_BUILD= yes
PREFIX_LINUX?= ${LINUXBASE}
STRIP= ${LINUXBASE}/usr/bin/strip
+BRANDELF?= /usr/bin/brandelf
FMT?= /usr/bin/fmt
INSTALL_DATA_DIR?= ${INSTALL} -d -o ${SHAREOWN} \
-g ${SHAREGRP} -m 755
@@ -103,6 +104,7 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/bin/pc-linux_elf/${file} \
${PREFIX}/lib/${PORTNAME}/bin/pc-linux_elf
@${STRIP} ${PREFIX}/lib/${PORTNAME}/bin/pc-linux_elf/${file}
+ @${BRANDELF} -t Linux ${PREFIX}/lib/${PORTNAME}/bin/pc-linux_elf/${file}
@if [ ! -f ${PREFIX}/bin/${file} ]; \
then \
${LN} -sf ${PORTNAME} ${PREFIX}/bin/${file} ; \
diff --git a/devel/understand_c/Makefile b/devel/understand_c/Makefile
index 0ccbda883580..f6187dc59742 100644
--- a/devel/understand_c/Makefile
+++ b/devel/understand_c/Makefile
@@ -22,6 +22,7 @@ NO_BUILD= yes
PREFIX_LINUX?= ${LINUXBASE}
STRIP= ${LINUXBASE}/usr/bin/strip
+BRANDELF?= /usr/bin/brandelf
FMT?= /usr/bin/fmt
CONF_DIRS= compilers configs fonts license
@@ -100,6 +101,7 @@ do-install:
@${INSTALL_SCRIPT} ${WRKSRC}/bin/pc-linux_elf/${file} \
${PREFIX}/lib/understand_c/bin/pc-linux_elf
@${STRIP} ${PREFIX}/lib/understand_c/bin/pc-linux_elf/${file}
+ @${BRANDELF} -t Linux ${PREFIX}/lib/understand_c/bin/pc-linux_elf/${file}
@if [ ! -f ${PREFIX}/bin/${file} ]; \
then \
${LN} -sf understand_c ${PREFIX}/bin/${file} ; \