aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/otrs/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/devel/otrs/Makefile b/devel/otrs/Makefile
index 59486c711fab..fe533fef4f9a 100644
--- a/devel/otrs/Makefile
+++ b/devel/otrs/Makefile
@@ -7,6 +7,7 @@
PORTNAME= otrs
PORTVERSION= 3.0.5
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= http://ftp.otrs.org/pub/otrs/ \
ftp://ftp.samurai.com/pub/otrs/ \
@@ -41,6 +42,7 @@ RUN_DEPENDS= ${BUILD_DEPENDS}
OPTIONS= MYSQL "MySQL database support" on \
PGSQL "PostgreSQL database support" off \
+ MODPERL2 "ModPerl2 support" on \
REPORTS_MODULES "Reports support" on \
SMTP "Send email via SMTP" on \
POP3 "Fetch email via POP3" on \
@@ -73,7 +75,6 @@ CLEAN_FILES= scripts/suse* scripts/redhat* \
var/httpd/htdocs/js/thirdparty/ckeditor-3.4.2/_source \
var/httpd/htdocs/skins/Agent/*/img/source
-USE_APACHE= 1.3+
USE_PERL5= yes
.include <bsd.port.pre.mk>
@@ -88,6 +89,13 @@ RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBD/Pg.pm:${PORTSDIR}/databases/p5-DBD-P
USE_PGSQL= yes
.endif
+.ifdef WITH_MODPERL2
+USE_APACHE= 2.2+
+RUN_DEPENDS+= mod_perl>=2.0:${PORTSDIR}/www/mod_perl2
+.else
+USE_APACHE= 1.3+
+.endif
+
.ifdef WITH_REPORTS_MODULES
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/GD.pm:${PORTSDIR}/graphics/p5-GD \
${SITE_PERL}/GD/Graph.pm:${PORTSDIR}/graphics/p5-GD-Graph \