aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--mail/spamoracle/Makefile23
1 files changed, 13 insertions, 10 deletions
diff --git a/mail/spamoracle/Makefile b/mail/spamoracle/Makefile
index 4ffab371cf25..d62caad41382 100644
--- a/mail/spamoracle/Makefile
+++ b/mail/spamoracle/Makefile
@@ -12,26 +12,29 @@ COMMENT= procmail spam filter written in ML using Bayesian classification
BUILD_DEPENDS= ocaml:${PORTSDIR}/lang/ocaml
-MAN1= spamoracle.1
-MAN5= spamoracle.conf.5
-
PLIST_FILES= bin/spamoracle
-.ifndef(NOPORTDOCS)
+PLIST_FILES+= man/man1/spamoracle.1.gz
+PLIST_FILES+= man/man5/spamoracle.conf.5.gz
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
PORTDOCS= Changes README
.endif
-NO_STAGE= yes
do-configure:
@${REINPLACE_CMD} -E -e 's|^(CPP=)gcc[[:space:]]+-E|\1${CPP}|' \
- -e 's|^(MANDIR=).*$$|\1${MANPREFIX}/man|' \
- -e 's|^(BINDIR=).*$$|\1${PREFIX}/bin|' \
+ -e 's|^(MANDIR=).*$$|\1${STAGEDIR}${MANPREFIX}/man|' \
+ -e 's|^(BINDIR=).*$$|\1${STAGEDIR}${PREFIX}/bin|' \
${WRKSRC}/Makefile
post-install:
-.ifndef(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
.for file in ${PORTDOCS}
- @${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/${file} ${STAGEDIR}${DOCSDIR}/
.endfor
.endif