aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.options.mk19
-rw-r--r--audio/musicpc/Makefile6
-rw-r--r--audio/musicpd/Makefile88
-rw-r--r--audio/ncmpc/Makefile3
-rw-r--r--graphics/libplacebo/Makefile12
-rw-r--r--x11-toolkits/wlroots/Makefile3
-rw-r--r--x11-wm/sway/Makefile9
-rw-r--r--x11/grim/Makefile6
-rw-r--r--x11/slurp/Makefile3
-rw-r--r--x11/swayidle/Makefile3
-rw-r--r--x11/swaylock/Makefile6
11 files changed, 80 insertions, 78 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index a2f0d31b402c..56eb4f026715 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -131,6 +131,13 @@
# Option enabled -D${content}=no
# Option disabled -D${content}=yes
#
+# ${opt}_MESON_ENABLED Will add to MESON_ARGS:
+# Option enabled -D${content}=enabled
+# Option disabled -D${content}=disabled
+# ${opt}_MESON_DISABLED Will add to MESON_ARGS:
+# Option enabled -D${content}=disabled
+# Option disabled -D${content}=enabled
+#
# ${opt}_IMPLIES When opt is enabled, options named in IMPLIES will
# get enabled too.
# ${opt}_PREVENTS When opt is enabled, if any options in PREVENTS are
@@ -503,6 +510,12 @@ MESON_ARGS+= ${${opt}_MESON_YES:C/.*/-D&=yes/}
. if defined(${opt}_MESON_NO)
MESON_ARGS+= ${${opt}_MESON_NO:C/.*/-D&=no/}
. endif
+. if defined(${opt}_MESON_ENABLED)
+MESON_ARGS+= ${${opt}_MESON_ENABLED:C/.*/-D&=enabled/}
+. endif
+. if defined(${opt}_MESON_DISABLED)
+MESON_ARGS+= ${${opt}_MESON_DISABLED:C/.*/-D&=disabled/}
+. endif
. for configure in CONFIGURE CMAKE MESON QMAKE
. if defined(${opt}_${configure}_ON)
${configure}_ARGS+= ${${opt}_${configure}_ON}
@@ -565,6 +578,12 @@ MESON_ARGS+= ${${opt}_MESON_YES:C/.*/-D&=no/}
. if defined(${opt}_MESON_NO)
MESON_ARGS+= ${${opt}_MESON_NO:C/.*/-D&=yes/}
. endif
+. if defined(${opt}_MESON_ENABLED)
+MESON_ARGS+= ${${opt}_MESON_ENABLED:C/.*/-D&=disabled/}
+. endif
+. if defined(${opt}_MESON_DISABLED)
+MESON_ARGS+= ${${opt}_MESON_DISABLED:C/.*/-D&=enabled/}
+. endif
. for configure in CONFIGURE CMAKE MESON QMAKE
. if defined(${opt}_${configure}_OFF)
${configure}_ARGS+= ${${opt}_${configure}_OFF}
diff --git a/audio/musicpc/Makefile b/audio/musicpc/Makefile
index 83db35fb09af..38e4bd6944ed 100644
--- a/audio/musicpc/Makefile
+++ b/audio/musicpc/Makefile
@@ -23,13 +23,11 @@ OPTIONS_DEFAULT= DOCS ICONV
DOCS_USES= python:env
DOCS_BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sphinx>0:textproc/py-sphinx@${PY_FLAVOR}
-DOCS_MESON_ON= -Ddocumentation=enabled
-DOCS_MESON_OFF= -Ddocumentation=disabled
+DOCS_MESON_ENABLED= documentation
ICONV_USES= iconv
ICONV_LDFLAGS= -L${ICONV_PREFIX}/lib ${ICONV_LIB}
-ICONV_MESON_ON= -Diconv=enabled
-ICONV_MESON_OFF= -Diconv=disabled
+ICONV_MESON_ENABLED= iconv
PORTDOCS= AUTHORS README.rst NEWS
diff --git a/audio/musicpd/Makefile b/audio/musicpd/Makefile
index 796ed04c9d55..748f0cc45d40 100644
--- a/audio/musicpd/Makefile
+++ b/audio/musicpd/Makefile
@@ -79,114 +79,114 @@ OPTIONS_DEFAULT=AUDIOFILE CURL FFMPEG FLAC ID3TAG MAD PLAYLISTS SNDFILE \
VORBIS VORBISENC
# Decoder plugins
-ADPLUG_MESON_ON= -Dadplug=enabled
+ADPLUG_MESON_ENABLED= adplug
ADPLUG_LIB_DEPENDS= libadplug.so:audio/libadplug
-AUDIOFILE_MESON_ON= -Daudiofile=enabled
+AUDIOFILE_MESON_ENABLED=audiofile
AUDIOFILE_LIB_DEPENDS= libaudiofile.so:audio/libaudiofile
-FAAD_MESON_ON= -Dfaad=enabled
+FAAD_MESON_ENABLED= faad
FAAD_LIB_DEPENDS= libfaad.so:audio/faad
-FFMPEG_MESON_ON= -Dffmpeg=enabled
+FFMPEG_MESON_ENABLED= ffmpeg
FFMPEG_LIB_DEPENDS= libavcodec.so:multimedia/ffmpeg \
libavformat.so:multimedia/ffmpeg \
libavutil.so:multimedia/ffmpeg
-FLAC_MESON_ON= -Dflac=enabled
+FLAC_MESON_ENABLED= flac
FLAC_LIB_DEPENDS= libFLAC.so:audio/flac
-FLUIDSYNTH_MESON_ON= -Dfluidsynth=enabled
+FLUIDSYNTH_MESON_ENABLED= fluidsynth
FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
-GME_MESON_ON= -Dgme=enabled
+GME_MESON_ENABLED= gme
GME_LIB_DEPENDS= libgme.so:audio/libgme
-MAD_MESON_ON= -Dmad=enabled
+MAD_MESON_ENABLED= mad
MAD_LIB_DEPENDS= libmad.so:audio/libmad
-MIKMOD_MESON_ON= -Dmikmod=enabled
+MIKMOD_MESON_ENABLED= mikmod
MIKMOD_LIB_DEPENDS= libmikmod.so:audio/libmikmod
-MODPLUG_MESON_ON= -Dmodplug=enabled
+MODPLUG_MESON_ENABLED= modplug
MODPLUG_LIB_DEPENDS= libmodplug.so:audio/libmodplug
-MPG123_MESON_ON= -Dmpg123=enabled
+MPG123_MESON_ENABLED= mpg123
MPG123_LIB_DEPENDS= libmpg123.so:audio/mpg123
-MUSEPACK_MESON_ON= -Dmpcdec=enabled
+MUSEPACK_MESON_ENABLED= mpcdec
MUSEPACK_LIB_DEPENDS= libmpcdec.so:audio/musepack
-OPUS_MESON_ON= -Dopus=enabled
+OPUS_MESON_ENABLED= opus
OPUS_LIB_DEPENDS= libopus.so:audio/opus \
libogg.so:audio/libogg
-PLAYLISTS_MESON_ON= -Dexpat=enabled
+PLAYLISTS_MESON_ENABLED=expat
PLAYLISTS_LIB_DEPENDS= libexpat.so:textproc/expat2
-SIDPLAY2_MESON_ON= -Dsidplay=enabled
+SIDPLAY2_MESON_ENABLED= sidplay
SIDPLAY2_LIB_DEPENDS= libsidplay2.so:audio/libsidplay2
SIDPLAY2_LDFLAGS= -L${LOCALBASE}/lib/sidplay/builders
-SNDFILE_MESON_ON= -Dsndfile=enabled
+SNDFILE_MESON_ENABLED= sndfile
SNDFILE_LIB_DEPENDS= libsndfile.so:audio/libsndfile
-VORBIS_MESON_ON= -Dvorbis=enabled
+VORBIS_MESON_ENABLED= vorbis
VORBIS_LIB_DEPENDS= libvorbis.so:audio/libvorbis
-WAVPACK_MESON_ON= -Dwavpack=enabled
+WAVPACK_MESON_ENABLED= wavpack
WAVPACK_LIB_DEPENDS= libwavpack.so:audio/wavpack
-WILDMIDI_MESON_ON= -Dwildmidi=enabled
+WILDMIDI_MESON_ENABLED= wildmidi
WILDMIDI_LIB_DEPENDS= libWildMidi.so:audio/wildmidi
# Encoder plugins
-VORBISENC_MESON_ON= -Dvorbisenc=enabled
+VORBISENC_MESON_ENABLED= vorbisenc
VORBISENC_LIB_DEPENDS= libvorbisenc.so:audio/libvorbis
-LAME_MESON_ON= -Dlame=enabled
+LAME_MESON_ENABLED= lame
LAME_LIB_DEPENDS= libmp3lame.so:audio/lame
-TWOLAME_MESON_ON= -Dtwolame=enabled
+TWOLAME_MESON_ENABLED= twolame
TWOLAME_LIB_DEPENDS= libtwolame.so:audio/twolame
# Filter plugins
-SAMPLERATE_MESON_ON= -Dlibsamplerate=enabled
+SAMPLERATE_MESON_ENABLED= libsamplerate
SAMPLERATE_LIB_DEPENDS= libsamplerate.so:audio/libsamplerate
-SOXR_MESON_ON= -Dsoxr=enabled
+SOXR_MESON_ENABLED= soxr
SOXR_LIB_DEPENDS= libsoxr.so:audio/libsoxr
# Output plugins
-AO_MESON_ON= -Dao=enabled
+AO_MESON_ENABLED= ao
AO_LIB_DEPENDS= libao.so:audio/libao
-JACK_MESON_ON= -Djack=enabled
+JACK_MESON_ENABLED= jack
JACK_LIB_DEPENDS= libjack.so:audio/jack
-OPENAL_MESON_ON= -Dopenal=enabled
+OPENAL_MESON_ENABLED= openal
OPENAL_USES= openal
-PULSEAUDIO_MESON_ON= -Dpulse=enabled
+PULSEAUDIO_MESON_ENABLED= pulse
PULSEAUDIO_LIB_DEPENDS= libpulse.so:audio/pulseaudio
-SHOUTCAST_MESON_ON= -Dshout=enabled
+SHOUTCAST_MESON_ENABLED=shout
SHOUTCAST_LIB_DEPENDS= libshout.so:audio/libshout
SHOUTCAST_IMPLIES= VORBIS
-SNDIO_MESON_ON= -Dsndio=enabled
+SNDIO_MESON_ENABLED= sndio
SNDIO_LIB_DEPENDS= libsndio.so:audio/sndio
# Input plugins
-CDPARANOIA_MESON_ON= -Dcdio_paranoia=enabled
+CDPARANOIA_MESON_ENABLED= cdio_paranoia
CDPARANOIA_LIB_DEPENDS= libcdda_paranoia.so:audio/cdparanoia
-CURL_MESON_ON= -Dcurl=enabled
+CURL_MESON_ENABLED= curl
CURL_LIB_DEPENDS= libcurl.so:ftp/curl
-MMS_MESON_ON= -Dmms=enabled
+MMS_MESON_ENABLED= mms
MMS_LIB_DEPENDS= libmms.so:net/libmms
-SMB_MESON_ON= -Dsmbclient=enabled
+SMB_MESON_ENABLED= smbclient
SMB_USES= samba:lib
# Archive plugins
-ZZIP_MESON_ON= -Dzzip=enabled
+ZZIP_MESON_ENABLED= zzip
ZZIP_LIB_DEPENDS= libzzip.so:devel/zziplib
-ISO9660_MESON_ON= -Diso9660=enabled
+ISO9660_MESON_ENABLED= iso9660
ISO9660_LIB_DEPENDS= libcdio_paranoia.so:sysutils/libcdio-paranoia
# Database plugins
-SQLITE3_MESON_ON= -Dsqlite=enabled
+SQLITE3_MESON_ENABLED= sqlite
SQLITE3_LIB_DEPENDS= libsqlite3.so:databases/sqlite3
-PROXYDB_MESON_ON= -Dlibmpdclient=enabled
+PROXYDB_MESON_ENABLED= libmpdclient
PROXYDB_LIB_DEPENDS= libmpdclient.so:audio/libmpdclient
# Tag plugins
-ID3TAG_MESON_ON= -Did3tag=enabled
+ID3TAG_MESON_ENABLED= id3tag
ID3TAG_LIB_DEPENDS= libid3tag.so:audio/libid3tag
# Network support
-IPV6_MESON_ON= -Dipv6=enabled
+IPV6_MESON_ENABLED= ipv6
# Commercial service support
-QOBUZ_MESON_ON= -Dqobuz=enabled
+QOBUZ_MESON_ENABLED= qobuz
QOBUZ_LIB_DEPENDS= libgcrypt.so:security/libgcrypt
QOBUZ_IMPLIES= CURL YAJL
-SOUNDCLOUD_MESON_ON= -Dsoundcloud=enabled
+SOUNDCLOUD_MESON_ENABLED= soundcloud
SOUNDCLOUD_IMPLIES= CURL YAJL
-TIDAL_MESON_ON= -Dtidal=enabled
+TIDAL_MESON_ENABLED= tidal
TIDAL_IMPLIES= CURL YAJL
# Misc library suppore
@@ -194,7 +194,7 @@ AVAHI_MESON_ON= -Dzeroconf=avahi
AVAHI_LIB_DEPENDS= libavahi-client.so:net/avahi-app
MDNSRESPONDER_MESON_ON= -Dzeroconf=bonjour
MDNSRESPONDER_LIB_DEPENDS= libdns_sd.so:net/mDNSResponder
-YAJL_MESON_ON= -Dyajl=enabled
+YAJL_MESON_ENABLED= yajl
YAJL_LIB_DEPENDS= libyajl.so:devel/yajl
MPDUSER?= mpd
diff --git a/audio/ncmpc/Makefile b/audio/ncmpc/Makefile
index a57cebd252b0..4cc975f5d745 100644
--- a/audio/ncmpc/Makefile
+++ b/audio/ncmpc/Makefile
@@ -41,8 +41,7 @@ MANPAGES_MESON_TRUE= manual
MANPAGES_USES= python:build
NLS_LDFLAGS= -lintl
-NLS_MESON_OFF= -Dnls=disabled
-NLS_MESON_ON= -Dnls=enabled
+NLS_MESON_ENABLED= nls
NLS_USES= gettext
.include <bsd.port.mk>
diff --git a/graphics/libplacebo/Makefile b/graphics/libplacebo/Makefile
index ca38dd255bde..2f09765b5899 100644
--- a/graphics/libplacebo/Makefile
+++ b/graphics/libplacebo/Makefile
@@ -27,18 +27,15 @@ OPTIONS_SINGLE_VULKAN= GLSLANG SHADERC
GLSLANG_DESC= glslang SPIR-V compiler
GLSLANG_BUILD_DEPENDS= glslang>0:devel/glslang
-GLSLANG_MESON_ON= -Dglslang=enabled
-GLSLANG_MESON_OFF= -Dglslang=disabled
+GLSLANG_MESON_ENABLED= glslang
GLSLANG_IMPLIES= VULKAN
LCMS2_LIB_DEPENDS= liblcms2.so:graphics/lcms2
-LCMS2_MESON_ON= -Dlcms=enabled
-LCMS2_MESON_OFF= -Dlcms=disabled
+LCMS2_MESON_ENABLED= lcms
SHADERC_DESC= libshaderc SPIR-V compiler
SHADERC_LIB_DEPENDS= libshaderc_shared.so:graphics/shaderc
-SHADERC_MESON_ON= -Dshaderc=enabled
-SHADERC_MESON_OFF= -Dshaderc=disabled
+SHADERC_MESON_ENABLED= shaderc
SHADERC_IMPLIES= VULKAN
TEST_MESON_TRUE= tests
@@ -46,8 +43,7 @@ TEST_MESON_TRUE= tests
VULKAN_DESC= Vulkan-based renderer
VULKAN_BUILD_DEPENDS= ${LOCALBASE}/include/vulkan/vulkan.h:devel/vulkan-headers
VULKAN_LIB_DEPENDS= libvulkan.so:graphics/vulkan-loader
-VULKAN_MESON_ON= -Dvulkan=enabled
-VULKAN_MESON_OFF= -Dvulkan=disabled
+VULKAN_MESON_ENABLED= vulkan
post-patch:
# Extract (snapshot) version from port version instead of meson.build
diff --git a/x11-toolkits/wlroots/Makefile b/x11-toolkits/wlroots/Makefile
index c0b8f3a7ba35..35595ab19108 100644
--- a/x11-toolkits/wlroots/Makefile
+++ b/x11-toolkits/wlroots/Makefile
@@ -40,8 +40,7 @@ X11_LIB_DEPENDS=libxcb-errors.so:x11/xcb-util-errors \
libxcb-icccm.so:x11/xcb-util-wm
X11_RUN_DEPENDS=Xwayland:x11-servers/xwayland
X11_USE= XORG=x11,xcb
-X11_MESON_ON= -Dx11-backend=enabled -Dxcb-icccm=enabled -Dxwayland=enabled
-X11_MESON_OFF= -Dx11-backend=disabled -Dxcb-icccm=disabled -Dxwayland=disabled
+X11_MESON_ENABLED=x11-backend xcb-icccm xwayland
post-patch:
# Ignore unused dependencies
diff --git a/x11-wm/sway/Makefile b/x11-wm/sway/Makefile
index 04747cacb65a..7e18aa3a37b1 100644
--- a/x11-wm/sway/Makefile
+++ b/x11-wm/sway/Makefile
@@ -35,20 +35,17 @@ OPTIONS_DEFAULT=MANPAGES PIXBUF SUID X11
OPTIONS_SUB= yes
MANPAGES_BUILD_DEPENDS= scdoc>=1.8.1:textproc/scdoc
-MANPAGES_MESON_ON= -Dman-pages=enabled
-MANPAGES_MESON_OFF= -Dman-pages=disabled
+MANPAGES_MESON_ENABLED= man-pages
PIXBUF_USE= GNOME=gdkpixbuf2
-PIXBUF_MESON_ON= -Dgdk-pixbuf=enabled
-PIXBUF_MESON_OFF= -Dgdk-pixbuf=disabled
+PIXBUF_MESON_ENABLED= gdk-pixbuf
SUID_DESC= setuid bit on "sway" binary (required for DRM session)
SUID_PLIST_SUB= MAYBE_SUID="@(,,4755) "
SUID_PLIST_SUB_OFF= MAYBE_SUID=""
X11_USE= XORG=xcb
-X11_MESON_ON= -Dxwayland=enabled
-X11_MESON_OFF= -Dxwayland=disabled
+X11_MESON_ENABLED= xwayland
post-patch:
# Let @sample handle default files under etc/
diff --git a/x11/grim/Makefile b/x11/grim/Makefile
index 79cb63a06db6..8fe16b305baf 100644
--- a/x11/grim/Makefile
+++ b/x11/grim/Makefile
@@ -28,12 +28,10 @@ OPTIONS_DEFINE= JPEG MANPAGES
OPTIONS_DEFAULT=JPEG MANPAGES
MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
-MANPAGES_MESON_ON= -Dman-pages=enabled
-MANPAGES_MESON_OFF= -Dman-pages=disabled
+MANPAGES_MESON_ENABLED= man-pages
MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
JPEG_USES= jpeg
-JPEG_MESON_ON= -Djpeg=enabled
-JPEG_MESON_OFF= -Djpeg=disabled
+JPEG_MESON_ENABLED= jpeg
.include <bsd.port.mk>
diff --git a/x11/slurp/Makefile b/x11/slurp/Makefile
index f2e46c307d7c..5b31db306692 100644
--- a/x11/slurp/Makefile
+++ b/x11/slurp/Makefile
@@ -25,8 +25,7 @@ OPTIONS_DEFINE= MANPAGES
OPTIONS_DEFAULT=MANPAGES
MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
-MANPAGES_MESON_ON= -Dman-pages=enabled
-MANPAGES_MESON_OFF= -Dman-pages=disabled
+MANPAGES_MESON_ENABLED= man-pages
MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
.include <bsd.port.mk>
diff --git a/x11/swayidle/Makefile b/x11/swayidle/Makefile
index 85150f7f2ffa..6f825edada67 100644
--- a/x11/swayidle/Makefile
+++ b/x11/swayidle/Makefile
@@ -25,8 +25,7 @@ OPTIONS_DEFINE= MANPAGES
OPTIONS_DEFAULT=MANPAGES
MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
-MANPAGES_MESON_ON= -Dman-pages=enabled
-MANPAGES_MESON_OFF= -Dman-pages=disabled
+MANPAGES_MESON_ENABLED= man-pages
MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
.include <bsd.port.mk>
diff --git a/x11/swaylock/Makefile b/x11/swaylock/Makefile
index 237f209bf411..1e31d1d9e632 100644
--- a/x11/swaylock/Makefile
+++ b/x11/swaylock/Makefile
@@ -29,12 +29,10 @@ OPTIONS_DEFINE= MANPAGES PIXBUF
OPTIONS_DEFAULT=MANPAGES PIXBUF
MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
-MANPAGES_MESON_ON= -Dman-pages=enabled
-MANPAGES_MESON_OFF= -Dman-pages=disabled
+MANPAGES_MESON_ENABLED= man-pages
MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
PIXBUF_USE= GNOME=gdkpixbuf2
-PIXBUF_MESON_ON= -Dgdk-pixbuf=enabled
-PIXBUF_MESON_OFF= -Dgdk-pixbuf=disabled
+PIXBUF_MESON_ENABLED= gdk-pixbuf
.include <bsd.port.mk>