aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--editors/emacs23/Makefile18
-rw-r--r--editors/gobby/Makefile2
-rw-r--r--editors/lazarus/Makefile2
-rw-r--r--emulators/darcnes/Makefile2
-rw-r--r--games/quakeforge/Makefile4
-rw-r--r--games/ufoai/Makefile2
-rw-r--r--games/wesnoth/Makefile4
-rw-r--r--graphics/bugle/Makefile4
-rw-r--r--graphics/eog/Makefile4
-rw-r--r--graphics/goom/Makefile2
-rw-r--r--graphics/libggi/Makefile4
-rw-r--r--graphics/opendx/Makefile2
12 files changed, 25 insertions, 25 deletions
diff --git a/editors/emacs23/Makefile b/editors/emacs23/Makefile
index 8f6b0420b0e7..b3155667eaba 100644
--- a/editors/emacs23/Makefile
+++ b/editors/emacs23/Makefile
@@ -86,7 +86,7 @@ SVG_CONFIGURE_WITH= rsvg
GTK2_USE= GNOME=gtk20
GTK2_CONFIGURE_ON= --with-x-toolkit=gtk
-XAW3D_LIB_DEPENDS= Xaw3d:${PORTSDIR}/x11-toolkits/Xaw3d
+XAW3D_LIB_DEPENDS= libXaw3d.so:${PORTSDIR}/x11-toolkits/Xaw3d
XAW3D_CONFIGURE_ON= --with-x-toolkit=athena
XAW_USE= XORG=xaw
@@ -99,29 +99,29 @@ SCROLLBARS_CONFIGURE_WITH= toolkit-scroll-bars
SYNC_INPUT_CONFIGURE_WITH= sync-input
-JPEG_LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg
+JPEG_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
JPEG_CONFIGURE_WITH= jpeg
-TIFF_LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff
+TIFF_LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff
TIFF_CONFIGURE_WITH= tiff
-GIF_LIB_DEPENDS= gif:${PORTSDIR}/graphics/giflib
+GIF_LIB_DEPENDS= libgif.so:${PORTSDIR}/graphics/giflib
GIF_CONFIGURE_WITH= gif
-PNG_LIB_DEPENDS+= png15:${PORTSDIR}/graphics/png
+PNG_LIB_DEPENDS+= libpng15.so:${PORTSDIR}/graphics/png
PNG_CONFIGURE_WITH= png
XPM_USE= XORG=xpm
XPM_CONFIGURE_WITH= xpm
XFT_USE= XORG=xft
-XFT_LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
+XFT_LIB_DEPENDS= libfreetype.so:${PORTSDIR}/print/freetype2
XFT_CONFIGURE_WITH= xft
-M17N_LIB_DEPENDS= m17n:${PORTSDIR}/devel/m17n-lib
+M17N_LIB_DEPENDS= libm17n.so:${PORTSDIR}/devel/m17n-lib
M17N_CONFIGURE_WITH= m17n-flt
-OTF_LIB_DEPENDS= otf:${PORTSDIR}/print/libotf
+OTF_LIB_DEPENDS= libotf.so:${PORTSDIR}/print/libotf
OTF_CONFIGURE_WITH= libotf
GCONF_USE= gnome=gconf2
@@ -134,7 +134,7 @@ CANNA_CONFIGURE_ON= --with-canna \
--with-canna-libraries=${LOCALBASE}/lib
CANNA_PATCHFILES= emacs23.3canna-20110316.diff.gz
CANNA_PATCH_SITES= http://distfiles.pirateparty.in/%SUBDIR%/ ${MASTER_SITE_LOCAL}
-CANNA_LIB_DEPENDS= canna:${PORTSDIR}/japanese/canna-lib
+CANNA_LIB_DEPENDS= libcanna.so:${PORTSDIR}/japanese/canna-lib
X11_CONFIGURE_WITH= x
X11_USE= XORG=x11
diff --git a/editors/gobby/Makefile b/editors/gobby/Makefile
index e85445f4320c..92727713285b 100644
--- a/editors/gobby/Makefile
+++ b/editors/gobby/Makefile
@@ -27,7 +27,7 @@ INSTALLS_ICONS= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MGTKSPELL}
-LIB_DEPENDS+= gtkspell:${PORTSDIR}/textproc/gtkspell
+LIB_DEPENDS+= libgtkspell.so:${PORTSDIR}/textproc/gtkspell
CONFIGURE_ARGS+=--with-gtkspell
.else
CONFIGURE_ARGS+=--without-gtkspell
diff --git a/editors/lazarus/Makefile b/editors/lazarus/Makefile
index d08d4e6bc29e..8a3e99fb6524 100644
--- a/editors/lazarus/Makefile
+++ b/editors/lazarus/Makefile
@@ -88,7 +88,7 @@ RUN_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:${PORTSDIR}/editor
.endif
.if ${PORT_OPTIONS:MQT4}
-LIB_DEPENDS+= Qt4Pas.5:${PORTSDIR}/x11-toolkits/qt4pas
+LIB_DEPENDS+= libQt4Pas.so:${PORTSDIR}/x11-toolkits/qt4pas
LCL_PLATFORM= qt
BUILD_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:${PORTSDIR}/editors/lazarus-lcl-qt
RUN_DEPENDS+= ${LCL_UNITS_DIR}/${LCL_PLATFORM}/interfaces.ppu:${PORTSDIR}/editors/lazarus-lcl-qt
diff --git a/emulators/darcnes/Makefile b/emulators/darcnes/Makefile
index 872ecdd373bb..19ac69e5260d 100644
--- a/emulators/darcnes/Makefile
+++ b/emulators/darcnes/Makefile
@@ -39,7 +39,7 @@ MAKE_ARGS+= TARGET=Linux_GTK
PKGNAMESUFFIX= -gtk
.else
.if defined(WITH_SVGALIB)
-LIB_DEPENDS+= vga:${PORTSDIR}/graphics/svgalib
+LIB_DEPENDS+= libvga.so:${PORTSDIR}/graphics/svgalib
MAKE_ARGS+= TARGET=Linux_svgalib
PKGNAMESUFFIX= -svgalib
.else
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index 8c84f99c9079..abbdef985073 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -62,7 +62,7 @@ PLIST_SUB+= SDL="@comment "
.endif
.if ${PORT_OPTIONS:MVORBIS}
-LIB_DEPENDS+= vorbis.4:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= libvorbis.so:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+=--with-ogg=${LOCALBASE} --with-vorbis=${LOCALBASE}
PLIST_SUB+= VORBIS=""
.else
@@ -71,7 +71,7 @@ PLIST_SUB+= VORBIS="@comment "
.endif
.if ${PORT_OPTIONS:MXMMS}
-LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+LIB_DEPENDS+= libxmms.so:${PORTSDIR}/multimedia/xmms
CONFIGURE_ARGS+=--with-xmms-prefix=${LOCALBASE}
PLIST_SUB+= XMMS=""
.else
diff --git a/games/ufoai/Makefile b/games/ufoai/Makefile
index 7f2ae60701aa..9e3a659c933f 100644
--- a/games/ufoai/Makefile
+++ b/games/ufoai/Makefile
@@ -70,7 +70,7 @@ PLIST_SUB+= UFO2MAP="@comment "
.if $(PORT_OPTIONS:MUFORADIANT)
CONFIGURE_ARGS+=--enable-uforadiant
USE_GNOME+= gtk20 glib20 gtksourceview2 libxml2
-LIB_DEPENDS+= gtkglext-x11-1.0.0:${PORTSDIR}/x11-toolkits/gtkglext
+LIB_DEPENDS+= libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext
RADIANT_FILE= uforadiant
RADIANT_DIRS= bitmaps i18n prefabs sourceviewer
PLIST_SUB+= UFORADIANT=""
diff --git a/games/wesnoth/Makefile b/games/wesnoth/Makefile
index 65a5cb69d10b..6fe287d053fa 100644
--- a/games/wesnoth/Makefile
+++ b/games/wesnoth/Makefile
@@ -70,7 +70,7 @@ PLIST_SUB+= CAMPAIGN="@comment "
.if ${PORT_OPTIONS:MFRIBIDI}
CMAKE_ARGS+= -DENABLE_FRIBIDI=on
-LIB_DEPENDS+= fribidi:${PORTSDIR}/converters/fribidi
+LIB_DEPENDS+= libfribidi.so:${PORTSDIR}/converters/fribidi
.else
CMAKE_ARGS+= -DENABLE_FRIBIDI=off
.endif
@@ -83,7 +83,7 @@ CMAKE_ARGS+= -DENABLE_LOW_MEM=off
.if ${PORT_OPTIONS:MNOTIFY}
CMAKE_ARGS+= -DENABLE_NOTIFICATIONS=on
-LIB_DEPENDS+= dbus-1:${PORTSDIR}/devel/dbus
+LIB_DEPENDS+= libdbus-1.so:${PORTSDIR}/devel/dbus
.else
CMAKE_ARGS+= -DENABLE_NOTIFICATIONS=off
.endif
diff --git a/graphics/bugle/Makefile b/graphics/bugle/Makefile
index 0c78354ea85b..e30a2d6a59f7 100644
--- a/graphics/bugle/Makefile
+++ b/graphics/bugle/Makefile
@@ -39,13 +39,13 @@ NO_STAGE= yes
.if ${PORT_OPTIONS:MAVCODEC}
CONFIGURE_ARGS+=--with-lavc
-LIB_DEPENDS+= avcodec.1:${PORTSDIR}/multimedia/ffmpeg
+LIB_DEPENDS+= libavcodec.so.1:${PORTSDIR}/multimedia/ffmpeg
.else
CONFIGURE_ARGS+=--without-lavc
.endif
.if ${PORT_OPTIONS:MGUI}
-LIB_DEPENDS+= gtkglext-x11-1.0:${PORTSDIR}/x11-toolkits/gtkglext
+LIB_DEPENDS+= libgtkglext-x11-1.0.so:${PORTSDIR}/x11-toolkits/gtkglext
CONFIGURE_ARGS+=--with-gtk --with-gtkglext
.else
CONFIGURE_ARGS+=--without-gtk --without-gtkglext
diff --git a/graphics/eog/Makefile b/graphics/eog/Makefile
index 90f7ac58acc8..d31958f6b460 100644
--- a/graphics/eog/Makefile
+++ b/graphics/eog/Makefile
@@ -36,7 +36,7 @@ _WITH_EXEMPI= no
.if !defined(WITHOUT_EXIF) || (exists(${LOCALBASE}/lib/libexif.so.12) || \
defined(WITH_EXIF))
-LIB_DEPENDS+= exif.12:${PORTSDIR}/graphics/libexif
+LIB_DEPENDS+= libexif.so:${PORTSDIR}/graphics/libexif
PLIST_SUB+= EXIF=""
_WITH_EXIF= yes
.else
@@ -45,7 +45,7 @@ PLIST_SUB+= EXIF="@comment "
.if !defined(WITHOUT_EXEMPI) || (exists(${LOCALBASE}/lib/libexempi.so)) || \
defined(WITH_EXEMPI)
-LIB_DEPENDS+= exempi.3:${PORTSDIR}/textproc/exempi
+LIB_DEPENDS+= libexempi.so:${PORTSDIR}/textproc/exempi
_WITH_EXEMPI= yes
.endif
diff --git a/graphics/goom/Makefile b/graphics/goom/Makefile
index 7c834deb4764..820991b357a6 100644
--- a/graphics/goom/Makefile
+++ b/graphics/goom/Makefile
@@ -21,7 +21,7 @@ INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
.if exists(${X11R6}/bin/xmms) || defined(WITH_XMMS)
-LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
+LIB_DEPENDS+= libxmms.so:${PORTSDIR}/multimedia/xmms
PLIST_SUB+= XMMS=""
.else
PLIST_SUB+= XMMS="@comment "
diff --git a/graphics/libggi/Makefile b/graphics/libggi/Makefile
index 78300396dbe4..cbdf504ae1a9 100644
--- a/graphics/libggi/Makefile
+++ b/graphics/libggi/Makefile
@@ -53,7 +53,7 @@ PLIST_SUB+= WITH_VGL="@comment "
.if ${PORT_OPTIONS:MAALIB}
CONFIGURE_ARGS+=--enable-aa
-LIB_DEPENDS+= aa:${PORTSDIR}/graphics/aalib
+LIB_DEPENDS+= libaa.so:${PORTSDIR}/graphics/aalib
PLIST_SUB+= WITH_AALIB=""
.else
CONFIGURE_ARGS+=--disable-aa
@@ -62,7 +62,7 @@ PLIST_SUB+= WITH_AALIB="@comment "
.if ${PORT_OPTIONS:MSVGALIB}
CONFIGURE_ARGS+=--enable-vgagl --enable-svga
-LIB_DEPENDS+= vga:${PORTSDIR}/graphics/svgalib
+LIB_DEPENDS+= libvga.so:${PORTSDIR}/graphics/svgalib
PLIST_SUB+= WITH_SVGALIB=""
.else
CONFIGURE_ARGS+=--disable-vgagl --disable-svga
diff --git a/graphics/opendx/Makefile b/graphics/opendx/Makefile
index c70a7af50a36..b696087c3a5b 100644
--- a/graphics/opendx/Makefile
+++ b/graphics/opendx/Makefile
@@ -35,7 +35,7 @@ IGNORE= HDF and NETCDF are conflicting
.endif
.if defined(WITH_HDF)
-LIB_DEPENDS+= mfhdf:${PORTSDIR}/science/hdf
+LIB_DEPENDS+= libmfhdf.so:${PORTSDIR}/science/hdf
.else
CONFIGURE_ARGS+= --without-hdf
.endif