aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sysutils/Makefile1
-rw-r--r--sysutils/p5-File-Listing/Makefile24
-rw-r--r--sysutils/p5-File-Listing/distinfo2
-rw-r--r--sysutils/p5-File-Listing/pkg-descr3
-rw-r--r--sysutils/p5-File-Listing/pkg-plist5
5 files changed, 35 insertions, 0 deletions
diff --git a/sysutils/Makefile b/sysutils/Makefile
index c79f2cd7df0d..c30ce50462f0 100644
--- a/sysutils/Makefile
+++ b/sysutils/Makefile
@@ -569,6 +569,7 @@
SUBDIR += p5-Brackup
SUBDIR += p5-Dir-Purge
SUBDIR += p5-File-DirCompare
+ SUBDIR += p5-File-Listing
SUBDIR += p5-File-Log
SUBDIR += p5-File-Next
SUBDIR += p5-File-Signature
diff --git a/sysutils/p5-File-Listing/Makefile b/sysutils/p5-File-Listing/Makefile
new file mode 100644
index 000000000000..480040360b6c
--- /dev/null
+++ b/sysutils/p5-File-Listing/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: p5-File-Listing
+# Date created: 2011-04-14
+# Whom: Frederic Culot <culot@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= File-Listing
+PORTVERSION= 6.02
+CATEGORIES= sysutils perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= perl@FreeBSD.org
+COMMENT= Parse directory listings
+
+RUN_DEPENDS= p5-HTTP-Date>=6:${PORTSDIR}/www/p5-HTTP-Date
+BUILD_DEPENDS:= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= File::Listing.3
+
+.include <bsd.port.mk>
diff --git a/sysutils/p5-File-Listing/distinfo b/sysutils/p5-File-Listing/distinfo
new file mode 100644
index 000000000000..8bf7a1915aec
--- /dev/null
+++ b/sysutils/p5-File-Listing/distinfo
@@ -0,0 +1,2 @@
+SHA256 (File-Listing-6.02.tar.gz) = 10d74be7373c1719363876c146f1f1730264585e74b6ddb7b7cb36cbc7b1ed19
+SIZE (File-Listing-6.02.tar.gz) = 24234
diff --git a/sysutils/p5-File-Listing/pkg-descr b/sysutils/p5-File-Listing/pkg-descr
new file mode 100644
index 000000000000..f8c55c8488f7
--- /dev/null
+++ b/sysutils/p5-File-Listing/pkg-descr
@@ -0,0 +1,3 @@
+This module can be used to parse directory listings.
+
+WWW: http://search.cpan.org/dist/File-Listing/
diff --git a/sysutils/p5-File-Listing/pkg-plist b/sysutils/p5-File-Listing/pkg-plist
new file mode 100644
index 000000000000..34a9dce6a5fd
--- /dev/null
+++ b/sysutils/p5-File-Listing/pkg-plist
@@ -0,0 +1,5 @@
+%%SITE_PERL%%/File/Listing.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Listing/.packlist
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/File/Listing
+@dirrmtry %%SITE_PERL%%/File
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/File