aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/deforaos-player/Makefile24
-rw-r--r--multimedia/deforaos-player/distinfo2
-rw-r--r--multimedia/deforaos-player/pkg-descr3
-rw-r--r--multimedia/deforaos-player/pkg-plist5
5 files changed, 35 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index c61d1b4afda1..29ec3511c1a3 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -35,6 +35,7 @@
SUBDIR += clutter-gst
SUBDIR += cuse4bsd-kmod
SUBDIR += cx88
+ SUBDIR += deforaos-player
SUBDIR += despotify
SUBDIR += devede
SUBDIR += dirac
diff --git a/multimedia/deforaos-player/Makefile b/multimedia/deforaos-player/Makefile
new file mode 100644
index 000000000000..00aff3377a98
--- /dev/null
+++ b/multimedia/deforaos-player/Makefile
@@ -0,0 +1,24 @@
+# Created by: Olivier Cochard-Labbe <olivier@cochard.me>
+# $FreeBSD$
+
+PORTNAME= player
+PORTVERSION= 0.1.4
+CATEGORIES= multimedia
+MASTER_SITES= http://www.defora.org/os/download/download/3708/
+DISTNAME= Player-${PORTVERSION}
+PKGNAMEPREFIX= deforaos-
+
+MAINTAINER= olivier@cochard.me
+COMMENT= DeforaOS desktop media player
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= System:${PORTSDIR}/devel/deforaos-libsystem \
+ Desktop:${PORTSDIR}/x11/deforaos-libdesktop
+RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
+
+USE_GNOME= gtk20 desktopfileutils
+USE_PKGCONFIG= build
+USE_GETTEXT= yes
+
+.include <bsd.port.mk>
diff --git a/multimedia/deforaos-player/distinfo b/multimedia/deforaos-player/distinfo
new file mode 100644
index 000000000000..e7213c6f75be
--- /dev/null
+++ b/multimedia/deforaos-player/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Player-0.1.4.tar.gz) = 4b8b50f252895b47669c304ede8e7e218d7ce4774fc495008371284269e5bfd7
+SIZE (Player-0.1.4.tar.gz) = 37215
diff --git a/multimedia/deforaos-player/pkg-descr b/multimedia/deforaos-player/pkg-descr
new file mode 100644
index 000000000000..4e5cad8e7a9f
--- /dev/null
+++ b/multimedia/deforaos-player/pkg-descr
@@ -0,0 +1,3 @@
+DeforaOS Desktop multimedia player
+
+WWW: http://www.defora.org/
diff --git a/multimedia/deforaos-player/pkg-plist b/multimedia/deforaos-player/pkg-plist
new file mode 100644
index 000000000000..3385e1fb5c92
--- /dev/null
+++ b/multimedia/deforaos-player/pkg-plist
@@ -0,0 +1,5 @@
+bin/player
+share/Player/splash.png
+share/applications/player.desktop
+share/locale/fr/LC_MESSAGES/Player.mo
+@dirrm share/Player