aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--deskutils/kompose/Makefile3
-rw-r--r--mail/kbiff/Makefile1
-rw-r--r--mail/kbiff/files/patch-configure222
-rw-r--r--net-p2p/kmldonkey/Makefile3
-rw-r--r--net/kmldonkey/Makefile3
-rw-r--r--sysutils/eventwatcher/Makefile3
-rw-r--r--x11-themes/baghira/Makefile3
-rw-r--r--x11-themes/phase/Makefile1
-rw-r--r--x11/kde3/files/extrapatch-old_configure102
-rw-r--r--x11/kde4/files/extrapatch-old_configure102
10 files changed, 443 insertions, 0 deletions
diff --git a/deskutils/kompose/Makefile b/deskutils/kompose/Makefile
index 6dda58fe27af..2794939dfc80 100644
--- a/deskutils/kompose/Makefile
+++ b/deskutils/kompose/Makefile
@@ -7,12 +7,15 @@
PORTNAME= kompose
PORTVERSION= 0.4.2
+PORTREVISION= 1
CATEGORIES= deskutils kde
MASTER_SITES= http://download.berlios.de/kompose/
MAINTAINER= lauri@kde.org
COMMENT= Full-screen task manager similar to Exposé(tm)
+EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
+
LIB_DEPENDS= Imlib2:${PORTSDIR}/graphics/imlib2
USE_BZIP2= yes
diff --git a/mail/kbiff/Makefile b/mail/kbiff/Makefile
index 1d8f4734f648..f71d427b2f87 100644
--- a/mail/kbiff/Makefile
+++ b/mail/kbiff/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kbiff
PORTVERSION= 3.7.1
+PORTREVISION= 1
CATEGORIES= mail kde
MASTER_SITES= http://devel-home.kde.org/~granroth/kbiff/
diff --git a/mail/kbiff/files/patch-configure b/mail/kbiff/files/patch-configure
new file mode 100644
index 000000000000..d5710b2478d7
--- /dev/null
+++ b/mail/kbiff/files/patch-configure
@@ -0,0 +1,222 @@
+--- configure.orig Wed Nov 10 15:52:42 2004
++++ configure Wed Nov 10 15:53:45 2004
+@@ -21035,7 +21035,103 @@
+
+
+
+-echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
++ LIBPTHREAD=""
++
++ if test -n "$PTHREAD_LIBS"; then
++ if test "x$PTHREAD_LIBS" = "x-pthread" ; then
++ LIBPTHREAD="PTHREAD"
++ else
++ PTHREAD_LIBS_save="$PTHREAD_LIBS"
++ PTHREAD_LIBS=`echo "$PTHREAD_LIBS_save" | sed -e 's,^-l,,g'`
++ echo "$as_me:$LINENO: checking for pthread_create in $PTHREAD_LIBS" >&5
++echo $ECHO_N "checking for pthread_create in $PTHREAD_LIBS... $ECHO_C" >&6
++
++ kde_save_LDFLAGS="$LDFLAGS"
++ kde_save_LIBS="$LIBS"
++ LDFLAGS="$LDFLAGS $all_libraries"
++ case $host_os in
++ aix*) LDFLAGS="-brtl $LDFLAGS"
++ test "$GCC" = yes && LDFLAGS="-Wl,$LDFLAGS"
++ ;;
++ esac
++ as_ac_Lib=`echo "ac_cv_lib_$PTHREAD_LIBS''_pthread_create" | $as_tr_sh`
++echo "$as_me:$LINENO: checking for pthread_create in -l$PTHREAD_LIBS" >&5
++echo $ECHO_N "checking for pthread_create in -l$PTHREAD_LIBS... $ECHO_C" >&6
++if eval "test \"\${$as_ac_Lib+set}\" = set"; then
++ echo $ECHO_N "(cached) $ECHO_C" >&6
++else
++ ac_check_lib_save_LIBS=$LIBS
++LIBS="-l$PTHREAD_LIBS $LIBS"
++cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++
++/* Override any gcc2 internal prototype to avoid an error. */
++#ifdef __cplusplus
++extern "C"
++#endif
++/* We use char because int might match the return type of a gcc2
++ builtin and then its argument prototype would still apply. */
++char pthread_create ();
++int
++main ()
++{
++pthread_create ();
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++ eval "$as_ac_Lib=yes"
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++eval "$as_ac_Lib=no"
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++LIBS=$ac_check_lib_save_LIBS
++fi
++echo "$as_me:$LINENO: result: `eval echo '${'$as_ac_Lib'}'`" >&5
++echo "${ECHO_T}`eval echo '${'$as_ac_Lib'}'`" >&6
++if test `eval echo '${'$as_ac_Lib'}'` = yes; then
++ LIBPTHREAD="$PTHREAD_LIBS_save"
++fi
++
++ LDFLAGS="$kde_save_LDFLAGS"
++ LIBS="$kde_save_LIBS"
++
++ PTHREAD_LIBS="$PTHREAD_LIBS_save"
++ fi
++ fi
++
++ if test -z "$LIBPTHREAD"; then
++ echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
+ echo $ECHO_N "checking for pthread_create in -lpthread... $ECHO_C" >&6
+ if test "${ac_cv_lib_pthread_pthread_create+set}" = set; then
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+@@ -21043,7 +21139,6 @@
+ ac_check_lib_save_LIBS=$LIBS
+ LIBS="-lpthread $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+-/* #line $LINENO "configure" */
+ /* confdefs.h. */
+ _ACEOF
+ cat confdefs.h >>conftest.$ac_ext
+@@ -21067,11 +21162,21 @@
+ _ACEOF
+ rm -f conftest.$ac_objext conftest$ac_exeext
+ if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
+- (eval $ac_link) 2>&5
++ (eval $ac_link) 2>conftest.er1
+ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
+ echo "$as_me:$LINENO: \$? = $ac_status" >&5
+ (exit $ac_status); } &&
+- { ac_try='test -s conftest$ac_exeext'
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
+ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
+ (eval $ac_try) 2>&5
+ ac_status=$?
+@@ -21084,7 +21189,8 @@
+
+ ac_cv_lib_pthread_pthread_create=no
+ fi
+-rm -f conftest.$ac_objext conftest$ac_exeext conftest.$ac_ext
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
+ LIBS=$ac_check_lib_save_LIBS
+ fi
+ echo "$as_me:$LINENO: result: $ac_cv_lib_pthread_pthread_create" >&5
+@@ -21092,6 +21198,72 @@
+ if test $ac_cv_lib_pthread_pthread_create = yes; then
+ LIBPTHREAD="-lpthread"
+ fi
++
++ fi
++
++ if test -z "$LIBPTHREAD" ; then
++ echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
++echo $ECHO_N "checking for pthread_create in -lpthread... $ECHO_C" >&6
++ kde_safe_libs=$LIBS
++ LIBS="$LIBS -lpthread"
++ cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++#include <pthread.h>
++int
++main ()
++{
++(void)pthread_create(0,0,0,0);
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++
++ echo "$as_me:$LINENO: result: yes" >&5
++echo "${ECHO_T}yes" >&6
++ LIBPTHREAD="-lpthread"
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++ LIBS=$kde_safe_libs
++ fi
++
++ if test "x$LIBPTHREAD" = "xPTHREAD" ; then
++ LIBPTHREAD=""
++ fi
++
+
+
+
diff --git a/net-p2p/kmldonkey/Makefile b/net-p2p/kmldonkey/Makefile
index dd2e2e6b2da2..cdb68799c7f4 100644
--- a/net-p2p/kmldonkey/Makefile
+++ b/net-p2p/kmldonkey/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kmldonkey
PORTVERSION= 0.10.pre4
+PORTREVISION= 1
CATEGORIES= net kde
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,6 +16,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.pre/pre/}
MAINTAINER= lioux@FreeBSD.org
COMMENT= KDE integration for MLDonkey eDonkey P2P client
+EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-configure
+
USE_KDELIBS_VER=3
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/net/kmldonkey/Makefile b/net/kmldonkey/Makefile
index dd2e2e6b2da2..cdb68799c7f4 100644
--- a/net/kmldonkey/Makefile
+++ b/net/kmldonkey/Makefile
@@ -7,6 +7,7 @@
PORTNAME= kmldonkey
PORTVERSION= 0.10.pre4
+PORTREVISION= 1
CATEGORIES= net kde
MASTER_SITES= ${MASTER_SITE_SAVANNAH}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,6 +16,8 @@ DISTNAME= ${PORTNAME}-${PORTVERSION:S/.pre/pre/}
MAINTAINER= lioux@FreeBSD.org
COMMENT= KDE integration for MLDonkey eDonkey P2P client
+EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-configure
+
USE_KDELIBS_VER=3
USE_BZIP2= yes
USE_GMAKE= yes
diff --git a/sysutils/eventwatcher/Makefile b/sysutils/eventwatcher/Makefile
index 0ac6ae49cd26..e3d0dc644755 100644
--- a/sysutils/eventwatcher/Makefile
+++ b/sysutils/eventwatcher/Makefile
@@ -7,6 +7,7 @@
PORTNAME= eventwatcher
PORTVERSION= 0.4.1
+PORTREVISION= 1
CATEGORIES= sysutils kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= eventwatcher
@@ -14,6 +15,8 @@ MASTER_SITE_SUBDIR= eventwatcher
MAINTAINER= lauri@kde.org
COMMENT= KDE log file/event viewer
+EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
+
USE_BZIP2= yes
USE_GMAKE= yes
USE_REINPLACE= yes
diff --git a/x11-themes/baghira/Makefile b/x11-themes/baghira/Makefile
index 626ff7871e2c..e84f591896a5 100644
--- a/x11-themes/baghira/Makefile
+++ b/x11-themes/baghira/Makefile
@@ -7,6 +7,7 @@
PORTNAME= baghira
PORTVERSION= 0.5e
+PORTREVISION= 1
CATEGORIES= x11-themes kde
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,6 +15,8 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= flynn@energyhq.es.eu.org
COMMENT= An Aqua like window decoration and widget style for KDE
+EXTRA_PATCHES= ${.CURDIR}/../../x11/kde3/files/extrapatch-old_configure
+
USE_BZIP2= yes
USE_KDEBASE_VER=3
GNU_CONFIGURE= yes
diff --git a/x11-themes/phase/Makefile b/x11-themes/phase/Makefile
index e6c3e1321257..53c037f2a5df 100644
--- a/x11-themes/phase/Makefile
+++ b/x11-themes/phase/Makefile
@@ -7,6 +7,7 @@
PORTNAME= phase
PORTVERSION= 0.6
+PORTREVISION= 1
CATEGORIES= x11-themes kde
MASTER_SITES= http://www.usermode.org/code/
diff --git a/x11/kde3/files/extrapatch-old_configure b/x11/kde3/files/extrapatch-old_configure
new file mode 100644
index 000000000000..fd5047a727e7
--- /dev/null
+++ b/x11/kde3/files/extrapatch-old_configure
@@ -0,0 +1,102 @@
+--- configure.orig Wed Nov 10 12:14:47 2004
++++ configure Wed Nov 10 12:14:52 2004
+@@ -27215,11 +27215,16 @@
+
+
+
+- LIBPTHREAD=""
++ LIBPTHREAD=""
+
+ if test -n "$PTHREAD_LIBS"; then
+- PTHREAD_LIBS_save="$PTHREAD_LIBS"
+- PTHREAD_LIBS=`echo "$PTHREAD_LIBS_save" | sed -e 's,^-l,,g'`
++ if test "x$PTHREAD_LIBS" = "x-pthread" ; then
++ LIBPTHREAD="PTHREAD"
++ else
++ PTHREAD_LIBS_save="$PTHREAD_LIBS"
++ PTHREAD_LIBS=`echo "$PTHREAD_LIBS_save" | sed -e 's,^-l,,g'`
++ echo "$as_me:$LINENO: checking for pthread_create in $PTHREAD_LIBS" >&5
++echo $ECHO_N "checking for pthread_create in $PTHREAD_LIBS... $ECHO_C" >&6
+
+ kde_save_LDFLAGS="$LDFLAGS"
+ kde_save_LIBS="$LIBS"
+@@ -27301,7 +27306,8 @@
+ LDFLAGS="$kde_save_LDFLAGS"
+ LIBS="$kde_save_LIBS"
+
+- PTHREAD_LIBS="$PTHREAD_LIBS_save"
++ PTHREAD_LIBS="$PTHREAD_LIBS_save"
++ fi
+ fi
+
+ if test -z "$LIBPTHREAD"; then
+@@ -27373,6 +27379,69 @@
+ LIBPTHREAD="-lpthread"
+ fi
+
++ fi
++
++ if test -z "$LIBPTHREAD" ; then
++ echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
++echo $ECHO_N "checking for pthread_create in -lpthread... $ECHO_C" >&6
++ kde_safe_libs=$LIBS
++ LIBS="$LIBS -lpthread"
++ cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++#include <pthread.h>
++int
++main ()
++{
++(void)pthread_create(0,0,0,0);
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++
++ echo "$as_me:$LINENO: result: yes" >&5
++echo "${ECHO_T}yes" >&6
++ LIBPTHREAD="-lpthread"
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++ LIBS=$kde_safe_libs
++ fi
++
++ if test "x$LIBPTHREAD" = "xPTHREAD" ; then
++ LIBPTHREAD=""
+ fi
+
+
diff --git a/x11/kde4/files/extrapatch-old_configure b/x11/kde4/files/extrapatch-old_configure
new file mode 100644
index 000000000000..fd5047a727e7
--- /dev/null
+++ b/x11/kde4/files/extrapatch-old_configure
@@ -0,0 +1,102 @@
+--- configure.orig Wed Nov 10 12:14:47 2004
++++ configure Wed Nov 10 12:14:52 2004
+@@ -27215,11 +27215,16 @@
+
+
+
+- LIBPTHREAD=""
++ LIBPTHREAD=""
+
+ if test -n "$PTHREAD_LIBS"; then
+- PTHREAD_LIBS_save="$PTHREAD_LIBS"
+- PTHREAD_LIBS=`echo "$PTHREAD_LIBS_save" | sed -e 's,^-l,,g'`
++ if test "x$PTHREAD_LIBS" = "x-pthread" ; then
++ LIBPTHREAD="PTHREAD"
++ else
++ PTHREAD_LIBS_save="$PTHREAD_LIBS"
++ PTHREAD_LIBS=`echo "$PTHREAD_LIBS_save" | sed -e 's,^-l,,g'`
++ echo "$as_me:$LINENO: checking for pthread_create in $PTHREAD_LIBS" >&5
++echo $ECHO_N "checking for pthread_create in $PTHREAD_LIBS... $ECHO_C" >&6
+
+ kde_save_LDFLAGS="$LDFLAGS"
+ kde_save_LIBS="$LIBS"
+@@ -27301,7 +27306,8 @@
+ LDFLAGS="$kde_save_LDFLAGS"
+ LIBS="$kde_save_LIBS"
+
+- PTHREAD_LIBS="$PTHREAD_LIBS_save"
++ PTHREAD_LIBS="$PTHREAD_LIBS_save"
++ fi
+ fi
+
+ if test -z "$LIBPTHREAD"; then
+@@ -27373,6 +27379,69 @@
+ LIBPTHREAD="-lpthread"
+ fi
+
++ fi
++
++ if test -z "$LIBPTHREAD" ; then
++ echo "$as_me:$LINENO: checking for pthread_create in -lpthread" >&5
++echo $ECHO_N "checking for pthread_create in -lpthread... $ECHO_C" >&6
++ kde_safe_libs=$LIBS
++ LIBS="$LIBS -lpthread"
++ cat >conftest.$ac_ext <<_ACEOF
++/* confdefs.h. */
++_ACEOF
++cat confdefs.h >>conftest.$ac_ext
++cat >>conftest.$ac_ext <<_ACEOF
++/* end confdefs.h. */
++#include <pthread.h>
++int
++main ()
++{
++(void)pthread_create(0,0,0,0);
++ ;
++ return 0;
++}
++_ACEOF
++rm -f conftest.$ac_objext conftest$ac_exeext
++if { (eval echo "$as_me:$LINENO: \"$ac_link\"") >&5
++ (eval $ac_link) 2>conftest.er1
++ ac_status=$?
++ grep -v '^ *+' conftest.er1 >conftest.err
++ rm -f conftest.er1
++ cat conftest.err >&5
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); } &&
++ { ac_try='test -z "$ac_c_werror_flag"
++ || test ! -s conftest.err'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; } &&
++ { ac_try='test -s conftest$ac_exeext'
++ { (eval echo "$as_me:$LINENO: \"$ac_try\"") >&5
++ (eval $ac_try) 2>&5
++ ac_status=$?
++ echo "$as_me:$LINENO: \$? = $ac_status" >&5
++ (exit $ac_status); }; }; then
++
++ echo "$as_me:$LINENO: result: yes" >&5
++echo "${ECHO_T}yes" >&6
++ LIBPTHREAD="-lpthread"
++else
++ echo "$as_me: failed program was:" >&5
++sed 's/^/| /' conftest.$ac_ext >&5
++
++
++ echo "$as_me:$LINENO: result: no" >&5
++echo "${ECHO_T}no" >&6
++fi
++rm -f conftest.err conftest.$ac_objext \
++ conftest$ac_exeext conftest.$ac_ext
++ LIBS=$kde_safe_libs
++ fi
++
++ if test "x$LIBPTHREAD" = "xPTHREAD" ; then
++ LIBPTHREAD=""
+ fi
+
+