aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/art/Makefile40
-rw-r--r--devel/art/distinfo2
-rw-r--r--devel/art/pkg-descr8
-rw-r--r--devel/art/pkg-plist6
5 files changed, 57 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 14b6cb77da12..76cafd4b2e2a 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -59,6 +59,7 @@
SUBDIR += arm-rtems-gcc
SUBDIR += arm-rtems-gdb
SUBDIR += aros-sdk
+ SUBDIR += art
SUBDIR += as31
SUBDIR += asdlgen
SUBDIR += asl
diff --git a/devel/art/Makefile b/devel/art/Makefile
new file mode 100644
index 000000000000..a6e493ee49c0
--- /dev/null
+++ b/devel/art/Makefile
@@ -0,0 +1,40 @@
+# New ports collection makefile for: art
+# Date created: 2011-11-05
+# Whom: Vladimir Gorelov <virtual.lark@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= art
+PORTVERSION= 0.9.01
+CATEGORIES= devel
+MASTER_SITES= http://skylark.tsu.ru/art/0.9/download/src/ \
+ SF/art-project/src/
+
+MAINTAINER= virtual.lark@gmail.com
+COMMENT= A resource tracing, debugging and profiling tool
+
+LICENSE= GPLv3
+
+LIB_DEPENDS= xml++-2.6:${PORTSDIR}/textproc/libxml++26
+
+USE_GMAKE= yes
+MAKE_JOBS_SAFE= yes
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/artlibgen/src/artlibgen ${PREFIX}/bin
+ @${INSTALL_PROGRAM} ${WRKSRC}/artrepgen/artrepgen ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for docs in posix-gcc-mt-file-lint.xml posix-gcc-mt-netw-lint.xml \
+ posix-gcc-mt-file-special.xml
+ @${INSTALL_DATA} ${WRKSRC}/artlibgen/templates/${docs} ${DOCSDIR}
+.endfor
+.endif
+
+.if defined(MAINTAINER_MODE)
+full-regression-test: build
+ cd ${WRKSRC}; ${GMAKE} test
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/art/distinfo b/devel/art/distinfo
new file mode 100644
index 000000000000..59840177b7d3
--- /dev/null
+++ b/devel/art/distinfo
@@ -0,0 +1,2 @@
+SHA256 (art-0.9.01.tar.gz) = 5c5e32af127a0755ac524a078a399c1ce49569d800ad4367a2f36aa0f03ac10e
+SIZE (art-0.9.01.tar.gz) = 37083
diff --git a/devel/art/pkg-descr b/devel/art/pkg-descr
new file mode 100644
index 000000000000..ae9e782a44ba
--- /dev/null
+++ b/devel/art/pkg-descr
@@ -0,0 +1,8 @@
+Crossplatform method to trace software errors in runtime during resource
+manipulation is shown. A scheme for describing abstract resources and their
+functions in XML is presented. Due to separation it's possible to describe
+vast classes of resources without changing the analyzer core.
+Detected errors often have an influence on security, safety, robustness and
+resource optimal usage.
+
+WWW: http://skylark.tsu.ru/art/index-en.html
diff --git a/devel/art/pkg-plist b/devel/art/pkg-plist
new file mode 100644
index 000000000000..3a5a3ef43a5c
--- /dev/null
+++ b/devel/art/pkg-plist
@@ -0,0 +1,6 @@
+bin/artlibgen
+bin/artrepgen
+%%PORTDOCS%%%%DOCSDIR%%/posix-gcc-mt-file-special.xml
+%%PORTDOCS%%%%DOCSDIR%%/posix-gcc-mt-file-lint.xml
+%%PORTDOCS%%%%DOCSDIR%%/posix-gcc-mt-netw-lint.xml
+%%PORTDOCS%%@dirrm %%DOCSDIR%%