aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--devel/Makefile1
-rw-r--r--devel/epm/Makefile25
-rw-r--r--devel/epm/distinfo2
-rw-r--r--devel/epm/pkg-descr11
-rw-r--r--devel/epm/pkg-plist7
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 61c9873be87e..a78b57ddc0f7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -221,6 +221,7 @@
SUBDIR += elib-emacs19
SUBDIR += elib-emacs20
SUBDIR += entity
+ SUBDIR += epm
SUBDIR += epydoc
SUBDIR += eric
SUBDIR += erlslang
diff --git a/devel/epm/Makefile b/devel/epm/Makefile
new file mode 100644
index 000000000000..b2573673c4f7
--- /dev/null
+++ b/devel/epm/Makefile
@@ -0,0 +1,25 @@
+# Ports collection makefile for: epm
+# Date created: 20 Nov 2004
+# Whom: NAKATA Maho <maho@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= epm
+PORTVERSION= 3.7
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= maho/openoffice.org
+DISTNAME= ${PORTNAME}-${PORTVERSION}-source
+EXTRACT_SUFX= .tar.bz2
+
+MAINTAINER= openoffice@FreeBSD.org
+COMMENT= A free UNIX software/file packaging program
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+MAN1= epm.1 epminstall.1 mkepmlist.1 setup.1
+MAN5= epm.list.5 setup.types.5
+
+.include <bsd.port.mk>
diff --git a/devel/epm/distinfo b/devel/epm/distinfo
new file mode 100644
index 000000000000..664b93acfff3
--- /dev/null
+++ b/devel/epm/distinfo
@@ -0,0 +1,2 @@
+MD5 (epm-3.7-source.tar.bz2) = d1fd62aa8e38b8dcd32b821822cb29a8
+SIZE (epm-3.7-source.tar.bz2) = 401222
diff --git a/devel/epm/pkg-descr b/devel/epm/pkg-descr
new file mode 100644
index 000000000000..9b111b645c7b
--- /dev/null
+++ b/devel/epm/pkg-descr
@@ -0,0 +1,11 @@
+EPM is a free UNIX software/file packaging program that generates
+distribution archives from a list of files.
+EPM Can:
+o Generate portable script-based distribution packages complete with
+ installation and removal scripts and standard install/uninstall GUIs.
+o Generate "native" distributions in AIX, BSD, Debian, HP-UX, IRIX, MacOS X,
+ Red Hat, Slackware, Solaris, and Tru64 UNIX formats.
+o Provide a complete, cross-platform software distribution solution for
+ your applications.
+
+WWW: http://www.easysw.com/epm/
diff --git a/devel/epm/pkg-plist b/devel/epm/pkg-plist
new file mode 100644
index 000000000000..1b91c2bf78b0
--- /dev/null
+++ b/devel/epm/pkg-plist
@@ -0,0 +1,7 @@
+bin/epm
+bin/epminstall
+bin/mkepmlist
+%%PORTDOCS%%%%DOCSDIR%%/COPYING
+%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/epm-manual.html
+%%PORTDOCS%%%%DOCSDIR%%/epm-manual.pdf